Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 01:27
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Wlan mit WEP funktioniert nicht
Moderators: MU
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
micha

Joined: 04 Mar 2008
Posts: 5

PostPosted: Tue 04 Mar 2008, 11:16    Post_subject:  Wlan mit WEP funktioniert nicht
Sub_title: komischerweise funktioniert aber WPA
 

Hallo Leute,

ich habe ein Problem mit der WLAN-Internetverbindung unter puppy 3.01.

Ich bekomme leider keine WEP-Verbindung zu stande.

Mein Vorgehen im Einzelnen:

auf Icon "Connect" klicken -> "Internet Connection Wizard" kommt
auf "Connect to Internet by network interface..." klicken -> "Puppy Network Wizard" kommt

in "Interfaces" steht folgendes:
Interface Type Module
eth1 Wireless zd1211rw

auf "eth1" klicken -> "Configure network interface eth1" kommt
auf "Wireless" klicken
auf "Scan" klicken und gewünschtes Netzwerk wählen
auf "WEP" klicken und "Key" eintragen
auf "Use This Profile" klicken
danach erscheint Meldung: "REPORT ON TEST OF eth1 CONNECTION: 'Puppy was able to find a live network'"

auf "Auto DHCP" klicken
danach erscheint Meldung: "NETWORK CONFIGURATION OF eth1 UNSUCCESSFUL!"

Ich habe irgendwo gelesen, dass man folgende Module für WEP benötigt:
ieee80211_crypt_wep
arc
ecb

Also habe ich versucht diese Module in der Konsole mit modprobe zu laden, aber leider
gibt es unter puppy 3.01 kein ieee80211_crypt_wep Modul (arc und ecb sind da).
Danach habe ich von Muppy 008.2 das Modul ieee80211_crypt_wep zu puppy 3.01 kopiert.

Jetzt kann ich ieee80211_crypt_wep, arc und ecb laden.

lsmod ergibt u.a. (ein paar Module habe ich gelöscht):

# lsmod
Module Size Used by
ieee80211_crypt_wep 5248 1
michael_mic 2688 0
arc4 2176 2
ecb 3584 2
ieee80211_crypt_tkip 11136 0
zd1211rw 48516 0
firmware_class 9600 1 zd1211rw
ieee80211softmac 29056 1 zd1211rw
ieee80211 33864 2 zd1211rw,ieee80211softmac
ieee80211_crypt 5632 3 ieee80211_crypt_wep,ieee80211_crypt_tkip,ieee80211
cbc 4608 1
blkcipher 6532 2 ecb,cbc
aes 28224 1
cryptoloop 3200 1
usbcore 127128 8 usblp,hci_usb,zd1211rw,usbhid,usb_storage,ehci_hcd,ohci_hcd
#

Aber es hilft alles nichts!

Das komische ist, dass WPA funktioniert! Ich benötige aber leider WEP...

Kann mir einer helfen?

Gruß, Micha.
Back to top
View user's profile Send_private_message 
urban soul


Joined: 05 Mar 2008
Posts: 276
Location: "Killing a nerd is not as much fun as ist sounds" B.Simpson

PostPosted: Fri 07 Mar 2008, 21:41    Post_subject:  

Hallo micha,

wenn dein NIC scannen kann, dann sollte auch 'iwconfig' unterstützt werden.

Probier mal folgendes:

Code:
cat /proc/net/wireless | grep -Eo '.+:' | grep -Eo '[^: ][[:alnum:]]+'

zeigt dir an ob du funktionierende Treiber hast. Der Wert der zurückgeliefert wird ist $DeinInterface. Dann bitte:
Code:
iwconfig $DeinInterface key s:$DeinKey

wenn dann nach
Code:
iwconfig

der key in hex erscheint, trifft meine Vermutung zu, dass iwconfig funktioniert. Nach
Code:
iwconfig $DeinInterface essid $DeinNetz
ifconfig $DeinInterface up
dhcpcd $DeinInterface

sollte Internet da sein.

Es gibt allerdings noch viele andere Möglichkeiten. Dann müsstest Du leider herausfinden welcher Chip in deinem NIC nun tatsächlich steckt. Und das ist manchmal garnicht so einfach.

hier eine Einstiegsseite:
http://linuxwireless.org/en/users/Drivers/zd1211rw#zd1211rw

urban
-----------
signature here should tell about the change-nickname-thing
formerly known as fudgy
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0473s ][ Queries: 12 (0.0048s) ][ GZIP on ]