Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 20:13
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
pcPuppyOS RC5 - Maximum Testers Requested!
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 5 [62 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
jamesbond

Joined: 26 Feb 2007
Posts: 2230
Location: The Blue Marble

PostPosted: Thu 21 Feb 2008, 21:16    Post subject:  

Thanks john. Yeah the partimage is interesting, I'm using it to backup my windows partition as well as full-install linux partitions.

More feedbacks, based on my random testing.

1. Request for Sydney timezone (for now I chose Guam - same GMT+10 as syd)
2. Clam AV update doesn't work behind proxy.
3. Gslapt doesn't work behind proxy.
(Perhaps there is a global proxy settings here that we can use?)

4. Hardinfo for system information display (instead of Xproc)
5. You may want to change the default pdf reader to something else - the gs reader is well - aged (and doesn't work on some pdfs) - and we can't select text for cut / paste. Perhaps epdfview (I haven't used it myself though).
6. CUPS can't print to windows printer. Every time I tried I failed with error message (in the error_log) "Can't load /etc/samba/smb.conf - run testparm to debug it", and the webpage says "/usr/lib/cups/backend/smb failed". I ran testparm, nothing wrong with it. I ran smbspool manually as in

Code:
# DEVICE_URI="smb://user:topsecret@GROUP/SOMEPC/Canon"
# export DEVICE_URI
# echo something | smbspool 99 me test 1 ""

And it worked, so smbspool doesn't seem to be the problem. And /usr/lib/cups/backend/smb is symlinked to /usr/bin/smbspool correctly.

EDIT:
7. Tried mounting a Windows share from puppy with Linneighbourhood. Failed with error message: cli_negprot: SMB signing is mandatory and we have disabled it.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
TheKid7

Joined: 30 Jan 2007
Posts: 14

PostPosted: Fri 22 Feb 2008, 20:25    Post subject: Gxine Crash Problem
Subject description: When opening a streaming asx file PCPuppyOS Crashed(?) Logged Me Out
 

When I tried to open the following streaming audio link (asx file) Gxine appeared to quickly crash and I was at a Login Prompt. I am a Newbie to Linux so I am only reporting a possible "bug". Windows XP does not have any issues with this streaming audio file.

Streaming Audio Link:
http://streamstart.x9tech.com/fbn.asx

Web Page with the streaming audio link ("Play" Button):
http://www.fbnradio.com/
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Sat 23 Feb 2008, 23:57    Post subject: Re: Gxine Crash Problem
Subject description: When opening a streaming asx file PCPuppyOS Crashed(?) Logged Me Out
 

TheKid7 wrote:
When I tried to open the following streaming audio link (asx file) Gxine appeared to quickly crash and I was at a Login Prompt. I am a Newbie to Linux so I am only reporting a possible "bug". Windows XP does not have any issues with this streaming audio file.

Streaming Audio Link:
http://streamstart.x9tech.com/fbn.asx

Web Page with the streaming audio link ("Play" Button):
http://www.fbnradio.com/


Well, for what its worth, its a repeatable bud; blew up on me too. jf
Back to top
View user's profile Send private message 
happyhippo

Joined: 04 Jul 2006
Posts: 42

PostPosted: Mon 25 Feb 2008, 04:43    Post subject:  

some problems

first,after a harddisk install and boot up from hd i get after loading the kernel
expr syntax error.
but it boot up and i get into puppy.
next problem is the network

mostly my dell cpx with pcmcia network card the card is found
now only wifi cards show up to chose.
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Mon 25 Feb 2008, 08:59    Post subject:  

happyhippo wrote:

first,after a harddisk install and boot up from hd i get after loading the kernel
expr syntax error.


I am getting this too, although I have been 'playing around' with turning Pebble on and off, which may have something to do with it.

I've had no problems at all with network, wired or wireless...

jf
Back to top
View user's profile Send private message 
eccentric

Joined: 05 Jan 2006
Posts: 139
Location: Khon Kaen Thailand.....NOW back in the UK

PostPosted: Wed 27 Feb 2008, 23:13    Post subject: pcpuppyos rc5
Subject description: bug or virus?????????????
 

I ran the DVD then saved to a C.F in an IDE addapter, looked at the w.w.web,, then closed down. upon rebooting all went well until i tried to use the PPPoE connection when i clicked on start a message cam up saying:-"security message root is not owned by root" root is my login name. I could not get passed this point. so i shut down and removed the C.F Card then rebooted and started again all went well so i put the C.F card in an USB addapter, deleted the files, then saved to this on closing now i can re boot with no problem. had i a bug or a virus??????????????????????? Michael. Rolling Eyes
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Wed 27 Feb 2008, 23:52    Post subject:  

I've been really swamped lately; this is the first time I've made it to the forum in over a week. I just went through and added a bunch of stuff to my to-do list now, and I'll try to get started on some of this tonight (won't get much done though). Tomorrow I'll hopefully have time to get some more sorted out. I only have one class on Thursday, but I need to study for my test on Friday and to do some homework for next week in advance since I'll be away over the weekend (but will take my laptop so I can work on this a little then too).

@eccentric: sounds like the permissions on /root might have gotten messed up. Probably just a glitch.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 2230
Location: The Blue Marble

PostPosted: Thu 28 Feb 2008, 03:52    Post subject:  

Don't be too hard on yourself.

Well to be fair, the problems I listed above also happens in other puppies, but I never experienced that before because I don't normally use puppy for work environment (=only for recovery purposes). But since pcPuppyOS is "targeted for business users" - I decided to "throw the dog to the field" Razz

Quoting my earlier post
1,3,4,5) - also happens for other puppies
2) is pcPuppyOS specific
6,7) probably happens on other puppies also

As for no 7), Google says this is a known problem, since "smbfs" doesn't support key signing. The solution is to use coax Linneighbourhood to use "cifs" (or use pnethood - supposedly the successor to Linnighbourhood) - but unfortunately "cifs" support doesn't seem to be compiled in kernel?

I have no idea on no 6 though.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Thu 28 Feb 2008, 23:57    Post subject:  

So far today I have completed these items on my list:
fix pebble bug
upgrade to ntfs-3g-1.1004 (from dingo)
upgrade to ntfsprogs-2.0.0 (from dingo)
upgrade pctorrent to 1.4
add more harddrive devices
add mrxvt


I don't know anything about proxies. Shouldn't that be a Gslapt / ClamAV specific issue?
ClamAV website
Config files:
/usr/etc/freshclam.conf
/usr/etc/clamd.conf (the on_access and off_access files are just examples, you only have to edit them if you want to rename one to just clamd.conf. Note: on_access scanning seemed pretty slow and unstable to me)


I tried those audio links and they worked fine. Odd. Maybe they were streaming a different format when I tried than when you tried. Try running Gxine from the commandline and then using one of the menu options to open the stream. That way you might be able to catch any error messages it makes before dying. I'll try that myself over the weekend.


I'll also probably look at partimage and hardinfo over the weekend.


As for Cups and Samba, unless I do them tonight (and I probably won't) they'll probably have to wait until I get back so I can have access to my printer and computer. I can't test them on just my laptop (not willing to fiddle with my grandparents' machines). My professors have already claimed Monday and Tuesday evenings though. I think Wednesday should be fairly clear though.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 2230
Location: The Blue Marble

PostPosted: Fri 29 Feb 2008, 07:23    Post subject:  

Thanks, I will look at the clamav / gslapt sites then Embarassed

Can I suggest you to use the latest ntfs-3g (1.2216 as of time of writing)
instead? Very Happy

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
37fleetwood


Joined: 09 Aug 2007
Posts: 403

PostPosted: Sat 01 Mar 2008, 03:29    Post subject:  

Hi, I'm a total novice so my question may be stupid but here goes. I have downloaded pcPuppyOS RC5 and like it very well. I have a small portrait studio in the planning stages and wanted to install this distro on a laptop which will have most if not all of my business stuff on it. I like the idea of encryption to protect my stuff and protect my customer information if it gets stolen but wouldn't it be better if I used something like True Crypt which will encrypt the whole drive so I don't have to worry if I have everything protected? right now I have windows with bestcrypt and it is very simple to use. I just type in the pass and from there everything is transparently encrypted. I know nobody can get to anything. can True Crypt be offered in the form of a .pet? how well would it work with Puppy? I think this is the only thing missing for my intended use. True Crypt is available for OpenSuse . and Ubuntu it is also relatively small at 2105 K. here is the site:
http://www.truecrypt.org/
thanx so much.
Scott
P.S. if this isn't the place for the question please let me know and direct me there.
Back to top
View user's profile Send private message 
37fleetwood


Joined: 09 Aug 2007
Posts: 403

PostPosted: Sat 01 Mar 2008, 06:42    Post subject:  

ok, I looked at True Crypt and it only allows file system encryption in windows at this point. are there any easy to use interfaces? I stumbled across an article on using features of the kernel to encrypt the file system and swap drive. it was definitely not for the novice!!
Scott
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Sat 01 Mar 2008, 08:58    Post subject:  

pcPuppyOS includes:

Enigmail Security extension to Mozilla Thunderbird and Seamonkey.

and

Emcrypt Device-mapper target that provides transparent encryption of block devices

Emcrypt has a choice of encryptions, including Truecrypt options.

Its not 'very easy' to use, but its not overly arcane, either

It may suit your needs.

jf
Back to top
View user's profile Send private message 
ralphv

Joined: 17 Mar 2007
Posts: 41

PostPosted: Sat 01 Mar 2008, 13:14    Post subject: pcPuppyOS RC5 - Maximum Testers Requested!  

Do I still need the wine .pet that was needed in rc1? I am having trouble running wine.
Ralph
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Sat 01 Mar 2008, 13:28    Post subject:  

You don't need the pet, just pcPuppyOS and the separate winetools download. You need to wait for the next release, which should be 'shortly.'
jf
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 5 [62 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0967s ][ Queries: 13 (0.0134s) ][ GZIP on ]