Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 04:15
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Pdrive 0.27
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 8 of 9 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9 Next
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 09 Dec 2007, 20:22    Post_subject:  

Just added this to pmount, at line 208:

else
[ "$DOFS" = "iso9660" ] && eject $DODEV

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Mon 10 Dec 2007, 12:58    Post_subject:  

I'll go for an upgrade...
_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Wed 13 Feb 2008, 17:13    Post_subject:  

Version 0.25 is uploaded. See main post.
_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Wed 13 Feb 2008, 18:00    Post_subject: Re: Pdrive 0.25
Sub_title: 13. Feb 2008
 

zigbert wrote:
- Updated Barrys fixes: rox -x to rescan dir and detection of partition on / (full installation)


does this apply for dingo or puppy 3.01. in puppy 3.01 pdrive still says unmounted while it is mounted.

Code:
# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda3             12388188   2493888   9390824  21% /
shmfs                    55052         0     55052   0% /dev/shm
/dev/hda5             12389324   4976280   6783700  42% /mnt/hda5


Code:
# mount
rootfs on / type rootfs (rw)
/dev/root on / type ext3 (rw,data=ordered)
none on /proc type proc (rw)
shmfs on /dev/shm type tmpfs (rw)
none on /dev/pts type devpts (rw)
none on /sys type sysfs (rw)
none on /proc/bus/usb type usbfs (rw)
/dev/hda5 on /mnt/hda5 type ext3 (rw,noatime,data=ordered)

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Thu 14 Feb 2008, 02:16    Post_subject:  

Wolf Pup
Pdrive is nothing new. Pdrive is no spicy code. Pdrive is just a new gui to Barrys code (Pmount). I can't tell too much about his code. I never took the time to investigate. If something drives aren't detected correct, the main question is: Does it in Pmount? if YES --> My code hasn't cloned well from Pmount. if NO --> We need a bugfix of Pmount / We need new code in Pdrive. Both is just fine with me. Pdrive used earlier the Pmount version in Puppy 3. From version 0.22, Pdrive uses the rewritten code of the latest Pmount in Dingo. Unfortunately I can't see the new Pmount package in the Puppy 4.00 repository. I grabbed it from an alpha-live-CD.

Sit Heel speak made me aware of the not working swap-detection in another thread. The NEW Pmount doesn't detect swaps, so here has my dirty hands been hacking again. My fault.

Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Thu 14 Feb 2008, 04:16    Post_subject:  

See this screenshot of PDrive and MUT:
http://i27.tinypic.com/2pob0c8.png

The swap partition hdc2 is shown correctly.

The swap partition hdb1 also showed correctly, until I mounted hda6. Then I refreshed PDrive, and hdb1 showed incorrectly as Mounted.
Back to top
View user's profile Send_private_message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Thu 14 Feb 2008, 06:39    Post_subject:  

Zigbert,

I believe there is a regression in version 0.25. Clicking on the "View Advanced" tab, all partitions show 0.0G / 0.0G, with the exception of my "boot" partition which still shows 94M/72M.

I replaced with the script func_probe with the one from 0.24 and sizes were reported again, but they were shown in the device column.

JB
Back to top
View user's profile Send_private_message YIM 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Fri 15 Feb 2008, 09:45    Post_subject:  

Hey guys
Please try version 0.26 (see main post).

Sit Heel Speak
I have made some changes to swap handling, but I haven't investigated your problem. If it still occur, - I really want to know.

Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Fri 15 Feb 2008, 23:56    Post_subject:  

Zigbert,

Tried out 0.26 and sizes are reporting correctly again.

JB
Back to top
View user's profile Send_private_message YIM 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Sun 17 Feb 2008, 04:29    Post_subject:  

Version 0.27 is uploaded. See main post.
_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Tue 19 Feb 2008, 16:05    Post_subject:  

PDrive 0.27 is working correctly now on Puppy 2.17, with regard to swap:
http://i30.tinypic.com/2q3qgdg.png
Back to top
View user's profile Send_private_message 
Jon_J


Joined: 06 Mar 2008
Posts: 76
Location: Illinois

PostPosted: Fri 07 Mar 2008, 03:51    Post_subject: Automounter that mounts during boot?  

I hope I'm not going off topic, but is there an automounter that mounts your hard drives/partitions during the boot process?
I know this is like comparing apples to oranges, but at the Zaurus community, there is a guy that made an automounter package that mounts almost everything automatically.
There are only 3-4 partitions on the internal HDD, they get mounted at boot.
Both CF and SD cards are mounted during boot, (if they are inserted).
CF/SD cards automatically mount/umount upon insertion/removal.
Most all external USB storage devices mount automatically. I had to edit a file to make my 750MB zip drive mount automatically.
This package isn't launched, it just runs when the Zaurus is turned on, or booted.
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Fri 07 Mar 2008, 07:41    Post_subject:  

Dougal has made a automounting daemon for puppy

check the readme.txt here: http://puppylinux.ca/tpp/tronkel/hotpup-1.00/etc/HotPup/

Latest community edition uses it:
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1572834272&t=25757

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6448
Location: Auckland, New Zealand

PostPosted: Sat 08 Mar 2008, 19:33    Post_subject:  

Is this normal?

Quote:
# pdrive
sh: locate: command not found
/usr/local/pdrive/func_probe: line 107: [: -gt: unary operator expected
/usr/local/pdrive/func_probe: line 112: [: -gt: unary operator expected
dc: stack underflow
dc: stack underflow
dc: stack underflow
EXIT=" "
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Sun 09 Mar 2008, 04:17    Post_subject:  

Does Pdrive show free space on a mounted disk?

line 105 and 112 should maybe been changed from
if [ $FREEK -gt ... -----> if [ "$FREE" -gt ...

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 8 of 9 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0866s ][ Queries: 13 (0.0139s) ][ GZIP on ]