Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 04:05
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Como instalar pidgin con soporte para protocolo jabber
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
psiwoods

Joined: 15 Dec 2007
Posts: 124
Location: San Rafael. Mendoza. Argentina.

PostPosted: Sat 02 Feb 2008, 09:13    Post subject:  Como instalar pidgin con soporte para protocolo jabber
Subject description: (no esperen un paso a paso)
 

Hola gente:

(antes que nada sepan que este post fue escrito medio dormido y no esta muy sistematico que digamos... asi que antes de seguir los pasos leanlo entero)

Este post lo estoy armando solo por felicidad. Desde puppy 2.17 en adelante, que fue cuando mi viejita pero amada Tuxina (Mi Celeron 500Hz 256 RAM) descubrio puppy habia extrañado algunas cosas, principalmente un mensajero que usara jabber (lease mensajero de gmail, por ejemplo)...

Y tal vez les pase que tienen que usar el M$N para hablar con gente que no gusta del GPL, asi que gaim o su version actual pidgin se les hace una buena opcion.

Ocurre sin embargo que las versiones de pigdin que hay en los repositorios de puppy no funcionan bien, mas bien diria que gracias a Dios funcionan...

Me ocurrio en Puppy 2.17 3.00 y 3.01 (tambien en las veriones NOP) que no habia forma... PIDGIN NO QUERIA ANDAR CON JABBER... Probe instalando los paquetes de debien incluso... (tienen como 10.000.000 dependencias, no lo recomiendo)... y debo decir que quedo hermoso, con mil iconitos y soporte para mil pelotudeces pero NADA DE SOPORTE PARA JABBER... parece que el problema esta en las librerias TCL y TK8.4

Y ayer, no se como, no se porque... ANDUVO, asi que les cuento como hice, porque la verdad me hizo sentir una alegria barbara...

Antes que nada, estoy trabajando sobre Puppy 3.95, es decir el test alpha4-netsurf que si mal no vi ya ha sdo sacado de los repositorios...

No se si esto funcionara en versiones anteriores pero en esta y supongo que en las siguientes funciona perfecto.

Lo que hice fue usar los paquetes de slackware 12... con resultados asombrosos...

La cosa es facil... tienen que ir a esta pagina:
http://packages.slackware.it/

ahi veran un buscador... que deben aprender a usar... seleccionan

slackware-12.0 -- package -- pidgin --> search

REFERENCIAS: lo que esta en negrita son botones o selectores, lo que esta rn rojo es lo que deben escribir (mi abuelo decia que hay que hacerlas cosas a prueba de boludos)...

Bien... ahi los va a mandar a una pagina con dos versiones de pidgin, yo use la mas reciente... la 2-2-1... hacen clic en el link y los va a mandar a esta pagina:

http://packages.slackware.it/package.php?q=12.0/pidgin-2.2.1-i486-1_slack12.0

Les voy a tirar el paquetes inicial asi se que estan en la version que a mi me funciono, que ademas es la mas reciente, al menos hoy...

desde esta pagina van a poder descargar la el paquete para slackware... llamado:

pidgin-2.2.1-i486-1_slack12.0.tgz

bajenlo a una carpeta, porque van a tener que bajar varios.
una vez ahi se van por consola y escriben

# tgz2pet nombre_del_paquete.tgz

(en este caso seria: tgz2pet pidgin-2.2.1-i486-1_slack12.0.tgz)
van a ver que antes de devolverle el prompt les tira un eror diciendo que no encuentra el directorio .nombre_del_paquete_que_convirtieron

NO LE DEN BOLA, NO PASA NADA...

Bien... ajhora el paquete que bajaron ya no es para slackware sino para puppy, vera que la extension es PET...

Con rox o con lo que sean le hacen clic y le dan a instalarlo... pueden hacerlo desde el administrador de paquetes tambien.. como fuere, ya sabran como hacerlo...

Y ahi empieza la APARENTE DESILUSION... una vez instalado veran que faltan como mil dependencias (otra vez como en debian! pense... pero son son tantas)... el tema es que ahora no se trata de los paquetes lo que nos pibe.. faltan como mil librerias (las que terminan en .so)... una desilusion total... no se gasten en poner pidgin en la consola porque no les va a funcionar... aun.

Ahora viene la otra parte... las malditas dependencias....

cierren la ventanita que aparece luego de la instalacion de cada paquete.. y vayan al administrador de pauqtes a la parte de chequear dependencias (asi nos dice lo mismo que antes solo que en una ventanita que permite seleccionar el texto, osea los nombres de las librerias que le faltan a pidgin, asi se nos hace mas facil)...

Y ahi viene la parte engorrosa... tienen que empezar a buscar las dependencias una por una, en realidad no son tantas... pero son como 12... quiza 15... pero tienen que hacerlo difernte a recien... van a la pagina de slackware donde se buscan lo paquetes y he aqui la diferencia:

ahora, como veran las dependencias de pidgin no muestran los paquetes de slackware que le faltan sino los nombres de las librerias... lo que deben hacer es buscar DENTRO DE LOS PAQUETES DE SLACKWARE.... por lo que en cuando vean el buscador deben cambiar el segundo boton selector cosa que vean esto, pro ejemplo:

slackware-12.0 -- file name -- libgcrypt.so --> search

veran que aparecen bastantes paquetes pero el primero o el segundo suele tener el nomrbe de la libreria que falta... lo bajan y lo instalan igual que al paquete pidgin usando 'tgz2pet'

Hay una de ellas... no recuerdo cual que a su vez les pedira otra dependencia... creo que la que pide es libgpg.. y esa depende de libgcrypt... no quiero tratarlos de estupidos asi que uds veran que tarde o temprano ban a tener todas las librerias instaladas... vayan viendo...

Cuando terminen de hacer todo eso van a hacewr un chequeo de depdendencias del paquete pidgin instalado y veran un hermoso y aliviente cartel verde que dice que toda las librerias estan instaladas y que no faltan dependencias.

Ahi festejamos y abrimos un terminal para poner

# pidgin

Y oh sorpresa... NO ANDA...que!? como?! voy a matar a esta PC!!!!! (y al postea en su caso!)... pero tranquilos porque solo falta una cosa...

escriben en consola

# dbus-uuidgen

y les va a tirar un codigo inmenso, como este:

4123eeaea204b74b48ee8d0047a3f66a

deben crear un archivo de texto llamado 'machine-id'
en la ubicacion '/var/lib/dbus/'

y dentro de ese archivo ponen el codigo grande ese que les tiro el comando 'dbus-uuidgen'... lo guardan y ahora si...

Desde consola hacen

# pidgin

Ahi van a añadir cuenta, ya sabran como, y si no funcionan me mandan un insulto a psi.woods@gmail.com o mejor... desde su gmail me lo dicen online por el procolo jabber Wink

Este post tiene un poco de heterodoxia piorque estaba esperando que thunar terminara de compilarse, cosa que por cierto no funciono asi que estoy muy enojado, pero aun asi... espero que funcione y que tengan mucha suerte.

(Ahora que veo son menos paquetes... les mando una captura de mi administrador de paquetes de puppy... creo que ahi estan todos lo que deben bajar... pero para estar seguros usen el chequeador de dependencias)

Un abrazo a todos.
paquetes.png
 Description   
 Filesize   7.01 KB
 Viewed   965 Time(s)

paquetes.png

Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
psiwoods

Joined: 15 Dec 2007
Posts: 124
Location: San Rafael. Mendoza. Argentina.

PostPosted: Tue 05 Feb 2008, 10:19    Post subject: Cuando funciona y cuando no...  

Gente... yo de nuevo...

Solo una cosa... lo que postee hace un rato solo funciona en pidgin 4 alpha4... supongo por tanto que funciona en las versiones posteriores que tienen mas compaitibilidad con slackware 12

He intentadio lo mismo en puppy linux 30.1 NOP r5 sin resultados positivos.. me pasa lo mismo que siempre.. probe con las librerias tcl y tk de antes pero nada... dice que el servidor no soporta no se que metodo de autenticacion... segun el error que pidgin me tira, por lo que vi en el site de pidgin dice que ese mensaje ocurre cuendo no esta soportado el mnetodo de autenticacion de ssl (creo que era ese)...

Si alguien hace andar jabber en pidgin en una version de puppy 3 me avisa??? por ahora la 4 de puppy esta muy cruda y como toda alpha se cuelga seguido... ademas he uintentado dos veces una instalaciuon HD full con pesimos resultados...
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0707s ][ Queries: 13 (0.0081s) ][ GZIP on ]