Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 02:16
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
HOWTO : Share files and folders between Computers
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 6 [87 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
giac_fab

Joined: 25 Jan 2007
Posts: 114

PostPosted: Sat 12 May 2007, 16:05    Post subject:  

hi.

AWESOME !!!! that's what i wanted , thank you !!!!

_________________
Embarassed I know, my english is very bad Embarassed
Give a man a fish and he eats for a day, teach a man to fish and he eats for a lifetime.
Back to top
View user's profile Send private message 
sunburnt


Joined: 08 Jun 2005
Posts: 5016
Location: Arizona, U.S.A.

PostPosted: Sat 12 May 2007, 16:18    Post subject:  

That's okay... English is a vastly overrated language.

And one of the hardest to learn I hear, it's really quite a mess of exceptions.
Back to top
View user's profile Send private message 
mrascii

Joined: 18 Jun 2007
Posts: 4

PostPosted: Thu 21 Jun 2007, 15:48    Post subject: SMB signing problem  

Hi, thanks for the great step by step but apparently either my puppy laptop or the windows server at my work doesn't play well with others. LinNeighborhood will only display the server name but won't let me at the shared folders that I need, and when I try the command line method I get the following error:

cli_negprot: SMB signing is mandatory and we have disabled it.
8871: protocol negotiation failed
SMB connection failed


Can someone help me fix this? I'm pretty new to linux so keep it simple for me Wink Thanks in advance for your help!


MDB...
Back to top
View user's profile Send private message 
NAKABIRI HARRIET

Joined: 27 Jun 2007
Posts: 1

PostPosted: Wed 27 Jun 2007, 07:03    Post subject: share files and folders between computers
Subject description: how to automount windows samba share on puppy reboot
 

mounted using linneighborhood, exported mountscript to /etc/rc.local, windows shared folder icon on desktop but does not automount on reboot until;
-linneighborhood is opened.
-or /etc/rc.d/rc.local is executed from console.[/list]
Back to top
View user's profile Send private message 
bicarbon8

Joined: 11 Aug 2007
Posts: 2

PostPosted: Sat 11 Aug 2007, 10:48    Post subject:  Read-Write access for FTP login
Subject description: FTP, rw, chmod
 

So I've created a new user and assigned their home to an external drive mapped under /mnt/<drivename>. When I login using FTP from an XP machine I am able to see all the files, but I cannot upload new files. The error says something about not having permissions to perform the action. Is there a way that I can enable read-write access to this drive via FTP for this user? I've tried having the new user assigned as the owner of the drive, but was unsuccessful (possibly my command syntax was incorrect). Thanks!
Back to top
View user's profile Send private message 
erikkire

Joined: 09 Nov 2006
Posts: 31
Location: cebu

PostPosted: Mon 13 Aug 2007, 14:28    Post subject:  

on your puppy menu, click: start-network-RUN-PUREFTPD FTP Server

UNCHECK -- A: Users can only see their files

hope that works.
Back to top
View user's profile Send private message 
bicarbon8

Joined: 11 Aug 2007
Posts: 2

PostPosted: Wed 29 Aug 2007, 11:54    Post subject:  found a solution
Subject description: mount properties
 

So the problem ended up being that by default the mounter that puppy used would only mount USB drives in read only mode. I added a setting to the /etc/fstab file that specified the file should be mounted in Read-Write mode and that fixed it.

Of course then I upgraded to the next version of puppy which didn't have the same mount script and so everything worked without the need for an entry in the /etc/fstab file (go figure).

For anyone else having this problem you'll need to create an entry in your /etc/fstab file similar to the following:
Code:
/dev/drive-to-mount    /mnt/location-to-mount-to    vfat    defaults,rw    0    0
Back to top
View user's profile Send private message 
wmb@firmworks.com

Joined: 04 Sep 2007
Posts: 17

PostPosted: Tue 04 Sep 2007, 20:12    Post subject: mount -t smbfs  

I'm trying to mount an SMB FS share from a Mac Mini with Puppy 2.16.

This works:
Code:
smbmount //MACMINI/space1 /mnt/data -o username=wmb

This, which should be equivalent, fails:
Code:
mount -t smbfs //MACMINI/space1 /mnt/data -o username=wmb

The error message is:
Quote:
mount: Mounting //MACMINI/space1 /mnt/data failed: Invalid argument

The same thing happens with:
Code:
busybox mount -t smbfs //MACMINI/space1 /mnt/data -o username=wmb

Apparently the busybox mount command doesn't support SMB.
So I tried mount-FULL, i.e.:
Code:
mount-FULL -t smbfs //MACMINI/space1 /mnt/data -o username=wmb

It fails with different error messages, but I finally got that mount-FULL command to work by doing this:
Code:
  ln -s /usr/sbin/smbmnt  /usr/bin
  ln -s /usr/sbin/smbmount /sbin/mount.smbfs
  ln -s /usr/sbin/smbmount /sbin/mount.smb
Back to top
View user's profile Send private message 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Wed 05 Sep 2007, 02:32    Post subject:  

Well done I didn't realise that you could use smbmount to provide the necessary extension for mount.

Code:
ln -s /usr/sbin/smbmnt  /usr/bin
doesn't do anything, and a good job to. There is already a directory with this name, replacing it would be disasterous.
_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
kneda

Joined: 02 Jul 2007
Posts: 20

PostPosted: Fri 11 Jan 2008, 13:09    Post subject:  

Quote:
LinNeighborhood:
1. From the start menu select "Network | LinNeighborhood Samba client"
2. Click the "Add" button.
3. Leave Machine and Group empty
4. on IP address type the IP address of your Windows computer.
5. Click the "query" button.
6. You should receive the message "query host... done". If not, check that the IP address is correct and that your network is working OK and repeat step 5.
7. Click OK. The Windows computer should appear on the main window list.
8. Right click on the computer name/address and select "scan as user"
9. Leave domain empty, username as root and password empty. You should see the list of shares on the main window list
10. Right click in the share you want to use and click "mount"
12. Set the parameters for the mount or accept the defaults. The "mount point" is the puppy folder under which you will see the contents of the shared folder. (write down that path so you remember where it's mounted)
13. Click "Mount". Rox should open on that folder
Done!


I can only make OK the 8 first steps
I don't have any password or user in my windows pc, I can see the PC and I "scan as user" with root
Appears the clock icon for few seconds but nothing happen. NOTHING Sad

What I have to do? I can see those folders from other windows pc
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 11 Jan 2008, 13:17    Post subject:  

please try this new, very simple to use program:
http://murga-linux.com/puppy/viewtopic.php?t=23464
Mark
Back to top
View user's profile Send private message Visit poster's website 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Thu 24 Jan 2008, 11:29    Post subject:  

Hello,
(translation on line)
Tests of doggie linux with Cd live and safeguards my data on my hard disk. The access to the PC is good I reads and writes above. But when I test what you wrote for the order of adduser that does not function at home as this image shows it.

I have to create in French a tuto explaining my different problems here .

(original text)
Essais de toutou linux avec le cd live et sauvegarde de mes données sur mon disque dur.
L'accès au PC est bon je lis et écris dessus.
Mais quand j'essaye ce que tu as écrit pour la commande de adduser ça ne fonctionne pas chez moi comme le montre cette image.

J'ai créer en français un tuto expliquant mes différent problèmes ici.

@+
Back to top
View user's profile Send private message 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Thu 24 Jan 2008, 23:53    Post subject:  

It's strange that you want to make / your start folder but I will trust that you know what you are doing.

Have you tried adding the option -H?
Code:
adduser -H -h /  alain

_________________
http://rarsa.blogspot.com Covering my eclectic thoughts
http://www.kwlug.org/blog/48 Covering my Linux How-to
Back to top
View user's profile Send private message Visit poster's website 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Fri 25 Jan 2008, 17:49    Post subject:  

Thank you to answer me, but its does not function.
I will try to give more details, I take again since the beginning the procedure: By taking your example:
To add has to use called “mp3shares” that will share /root/my-music:
Code: adduser - H /root/my-music mp3shares
Me I have to create in root (or this finds “my document”) a file that jet named “Linux” By taking your example and with my own criterion the line of order that I written board is as follows:
Adduser - h /root/Linux toma or Adduser - H - h /root/Linux toma and there that does not function !
As long as I do not know how to create a user with his password Windows cannot see doggie linux

original texte
Merci de me répondre, mais sa ne fonctionne pas.
Je vais essayer de donner plus de détails, je reprends depuis le début la procédure:
En prenant ton exemple :
To add a user called "mp3shares" that will share /root/my-music:
Code: adduser -h /root/my-music mp3shares
Moi j'ai créer dans root (ou ce trouve "my document") un dossier que jais nommé "Linux"
En prenant ton exemple et avec mes propre critère la ligne de commande que j'ais écrit est la suivante:
Adduser –h /root/Linux toma ou Adduser –H –h /root/Linux toma et là ça ne fonctionne pas !
Tant que je ne sais pas comment créer un utilisateur avec son mot de passe windows ne peut voir toutou linux


@+
Back to top
View user's profile Send private message 
paulh177


Joined: 22 Aug 2006
Posts: 875
Location: ST862228

PostPosted: Fri 25 Jan 2008, 18:08    Post subject:  

BusyBox adduser is broken in Puppy 3.
Download TinyLogin using PetGet and try
Code:
tinylogin adduser -h /root/Linux toma

(see here)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 6 [87 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1039s ][ Queries: 13 (0.0165s) ][ GZIP on ]