Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 21:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
fox-1.6.33 + rezound-0.12.3beta + xfe-1.19.1 + more
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 21:44    Post_subject:  fox-1.6.33 + rezound-0.12.3beta + xfe-1.19.1 + more
Sub_title: 2008-07-03 updated
 

These were all compiled in Puppy 4 and may not work in other puppies.

The fox toolkit website
http://fox-toolkit.org/

---2008-01-22 - recompiled like this so I could compile xfe-1.04---

--prefix=/usr --build=i486-t2-linux-gnu --with-xft --enable-release --enable-cups --enable-shared --disable-static

I compiled the latest stable version (1.6.33) but it's a bit over 1MB so I can't post it here. Here's an external link:

http://www.savefile.com/files/1566619

Rezound's website
http://rezound.sourceforge.net/

I also had to host this one on an external link:

http://myfreefilehosting.com/f/2f9385c166_1.27MB

If for some reason those links don't work you can download from my yahoo briefcase at:

http://tinyurl.com/3cyy8a

Rezound depends on libFOX which is posted above and also fftw which I'll post below.
fox_dev-1.6.33.pet
Description 
pet

 Download 
Filename  fox_dev-1.6.33.pet 
Filesize  288.29 KB 
Downloaded  873 Time(s) 
fftw-2.1.5.pet
Description 
pet

 Download 
Filename  fftw-2.1.5.pet 
Filesize  156.19 KB 
Downloaded  838 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 21:45    Post_subject:  

Here's the other packages that are part of the fox toolkit and depend on libFOX posted above.

PathFinder is a file manager, fox_calculator is a scientific calculator, and adie is a text editor.
pathfinder-1.0.pet
Description 
pet

 Download 
Filename  pathfinder-1.0.pet 
Filesize  59.89 KB 
Downloaded  811 Time(s) 
fox_calculator-2.1.0.pet
Description 
pet

 Download 
Filename  fox_calculator-2.1.0.pet 
Filesize  36.52 KB 
Downloaded  779 Time(s) 
adie-3.0.0.pet
Description 
pet

 Download 
Filename  adie-3.0.0.pet 
Filesize  136.4 KB 
Downloaded  794 Time(s) 

Edited_time_total
Back to top
View user's profile Send_private_message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 21:46    Post_subject:  

Finally the last package that is part of the fox toolkit package and depends on libFOX.

shutterbug is a screen capture utility.
shutterbug-3.0.0.pet
Description 
pet

 Download 
Filename  shutterbug-3.0.0.pet 
Filesize  20.13 KB 
Downloaded  831 Time(s) 
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 21 Jan 2008, 22:33    Post_subject:  

mirror:
http://dotpups.de/puppy4/dotpups/Multimedia/Rezound/
mirror:
http://puppyfiles.ca/dotpupsde/puppy4/dotpups/Multimedia/Rezound/

I could run it in Puppy 3 with the Fox-libraries from XFE (all in Muppy008) by installing only:
rezound-0.12.3beta.pet
fftw-2.1.5.pet
LibFLAC.so.8.pup

LibFLAC I made from a debian package.
Is it already included in Puppy 4?

Do you have locale-files for Rezound?
Thank you Smile
Mark
Back to top
View user's profile Send_private_message Visit_website 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 22:38    Post_subject:  

Yeah, Barry put flac in the iso of Puppy 4. I first compiled rezound with the locales and it compiled without any errors but when I went to execute rezound I got this error:

exception -- locale::facet::_S_create_c_locale name not valid

Here's the xfe-1.19.1 package compiled in puppy 4:

I made the icons a seperate package incase anyone wants specific parts of xfe without actually installing xfe. So this xfe depends on xfe-icons & fox.
xfe-1.19.1.pet
Description 
pet

 Download 
Filename  xfe-1.19.1.pet 
Filesize  343.5 KB 
Downloaded  886 Time(s) 
xfe-icons-1.19.1.pet
Description 
pet

 Download 
Filename  xfe-icons-1.19.1.pet 
Filesize  640.53 KB 
Downloaded  878 Time(s) 
xfe_nls-1.19.1.pet
Description 
pet

 Download 
Filename  xfe_nls-1.19.1.pet 
Filesize  266.63 KB 
Downloaded  816 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 22:52    Post_subject:  

and the rest of the xfe package:

xfi is the xfe image viewer
xfv is the xfe text viewer
xfw is the xfe text editor

None of these are necessary to run xfe. You don't need xfe to run any of these apps either. They all depend on fox & xfe-icons.
xfi-1.19.1.pet
Description 
pet

 Download 
Filename  xfi-1.19.1.pet 
Filesize  171.26 KB 
Downloaded  947 Time(s) 
xfv-1.19.1.pet
Description 
pet

 Download 
Filename  xfv-1.19.1.pet 
Filesize  174.21 KB 
Downloaded  959 Time(s) 
xfw-1.19.1.pet
Description 
pet

 Download 
Filename  xfw-1.19.1.pet 
Filesize  191.47 KB 
Downloaded  804 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 21 Jan 2008, 22:55    Post_subject:  

ok, removed libflac from that folder.

For Puppy versions older than 4 I created an own folder:
http://dotpups.de/dotpups/Multimedia/Rezound/
or:
http://puppyfiles.ca/dotpupsde/dotpups/Multimedia/Rezound/

If not already installed (XFE or Muppy), also this is required:
http://dotpups.de/dotpups/Libraries/Fox-1.6.23.pup
or:
http://puppyfiles.ca/dotpupsde/dotpups/Libraries/Fox-1.6.23.pup

Mark
Back to top
View user's profile Send_private_message Visit_website 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 22:57    Post_subject:  

I can make a package of the locale files, but will they work if I compiled rezound disabling nls?
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 21 Jan 2008, 22:58    Post_subject:  

Quote:
exception -- locale::facet::_S_create_c_locale name not valid

Ok, thanks for trying Smile
It is a great program even in english only.
Mark
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 21 Jan 2008, 22:59    Post_subject:  

plinej wrote:
I can make a package of the locale files, but will they work if I compiled rezound disabling nls?


I don't think so.
I could give it a try, if you upload the german one (de)
Mark
Back to top
View user's profile Send_private_message Visit_website 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 23:03    Post_subject:  

edited
Edited_time_total
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 21 Jan 2008, 23:09    Post_subject:  

no, no chance.
Thanks, Mark
Back to top
View user's profile Send_private_message Visit_website 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Mon 21 Jan 2008, 23:09    Post_subject:  

I tried compiling xfe-1.04 as well but got a bunch of errors. I also tried the slackware package but I get seg faults.
Back to top
View user's profile Send_private_message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Tue 22 Jan 2008, 12:21    Post_subject:  

Alright, I re-compiled libFOX and was able to compile xfe-1.04. Rezound will still run with the newly compiled fox package. Please update to the new fox package posted above and the dev files if needed. MU please update your mirror with the new packages.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 22 Jan 2008, 12:34    Post_subject:  

fine, updated the repos Smile
Thanks Plinej, Mark
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0726s ][ Queries: 13 (0.0048s) ][ GZIP on ]