Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 04:11
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
New pcPuppyOS Version - Fixes and New Features, Security!
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Tue 15 Jan 2008, 17:46    Post subject:  New pcPuppyOS Version - Fixes and New Features, Security!
Subject description: Scramdisk & dmcrypt encryption, enigmail, more toggles, Pet-be-Gone, 24-hr clock option
 

EDIT: RC2 posted 22 Jan 08; Upgraded WINE, upgraded JAVA, SAMBA fixed for printer sharing.
jf
http://www.pcpuppyos.com jf
**

New pcPuppyOS is at http://www.pcpuppyos.com If last version was Beta, think of this as RC1. Thank you pizzasgood for all the customization! jf

Various bug fixes, and a host of new features! Focus, as always, is on ease of use and configuration.

New md5 is 648a1229817dd737e5d2950cc9e4db2e

added scramdisk [encrypted storage]
updated thunderbird
added enigmail (gpg was already in, came with gslapt)
removed built-in zdrv_xxx (wasn't needed)
corrected firefox's default size
made firewall toggle-able
added icon for .sfs files
upgraded icewinconfig
added a toggle to set 24 hour time
added a dialog for unclean shutdown (like in 2.15CE , but with a 15 sec time-out)
added Pet-Be-Gone uninstaller, complete with package lists for pcPuppyOS
added hexedit
corrected conky error messages on full-install
added generic support for dmcrypt
added support for encrypting pup_save.2fs with dmcrypt (uses cryptd tag on file name)
removed "light" and "heavy" pup_save.2fs encryption options, as they are currently broken and potentially obsolete. Now there are only two options, "No encryption" on the left and "dmcrypt encryption" on the right.

Previous version stuff:

Addded
cursors
flash-9
gmp-4.2.2-i486
gtk_themes
icewm-1.2.30
jre-1.6.0_02
kompozer-0.77
limewire-4.14.8
mu_gtk_themechooser
pstoedit-3.44
thunderbird-2.0.0.6
undeb
unrpm
devx-301
openmotif-2.2.3
cisco_vpn_client
citrix_client-10.6
gtksamba-0.3.2pl1
pebble_post_init- 0.9
samba-3.0.21c
winetools-0.9
xorg_OPENGL-7.2
mount_all-0.1
xawtv-3.95
skype_static-2.0.0.13
qc-usb-0.6.5-k2.6.21.7
toggle_exec-0.1
xsane-0.994
sane-1.0.18
gimp-2.2.15
conky-1.4.8-i686
gslapt_puppy-0.3.18
libesd-0.2.36
libjack-0.0.23
gtkbasic-0.0.3
gtkbasic_analogclock
Rainlendar-Lite-2.2
cdrdao-1.2.1-1
pcdripper-3.2
gspcav1-20070508-i586
xine_extra_codecs-1-1
devx-301
gutenprint-5.0.1.98.1
cups-1.3.5
ghostscript-8.61
zdrv-301
gsview_afplgs- 4.7-8.54
firefox-2.0.0.11
qt-3.3.8
ooop_extensions-2.3.1.2
ooop_FULL-2.3.1
xfwall-1.4-41
timesync-0.1
wine-0.9.52
clamav-0.92
inkscape-0.43_STATIC_GTKMM
hpijs-1.7
toggle_autologin-0.1

Removed
abiword-2.4.5
abiword_PLUGINS-2.4.5
epdfview-0.1.6
gnumeric-1.6.3
gnumeric_PLUGINS-1.6.3
goffice-0.2.1
jwm2-2.0.1
jwmconfig-23sept07
seamonkey-1.1.2-1
mtpaint-3.10
pbcdripper-2.5
gutenprint-5.0.1-1
espgs-8.15.4
inkscapelite-0.36.2

Last edited by friedsonjm on Tue 22 Jan 2008, 06:38; edited 1 time in total
Back to top
View user's profile Send private message 
NathanO

Joined: 22 Feb 2007
Posts: 196
Location: San Antonio, TX

PostPosted: Fri 18 Jan 2008, 12:54    Post subject:  

Downloaded Jan 15 version this morning. Burned a new CD. Have previous version I have been playing with.

On both my tower [a box of parts put together] and my HP Pavillion zv6000 laptop the previous version works no problem. I have put it on a USB stick without a save file to show off at the computer show this weekend.

The Jan 15 version worked on tower no problem, no shut down problem. 24 hour chooser worked, thank you for doing it.

On the laptop Xorg would not work and Xversa would not give proper resolution. Previous version Xorg chose 1280 x 800 x 24 and worked every time. What command or what built in program do you need me to run to give you the information you need to look at the problem?

Nathan
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Fri 18 Jan 2008, 17:14    Post subject:  

I have run into this myself. Fix is:

If in Xvesa already, go to /usr/X11R7/bin/. Delete X. Right-click Xorg and choose "link". Link it to X. Use relative when it asks.

Or, from the command line:
rm /usr/X11R7/bin/X
ln -s /usr/X11R7/bin/Xorg /usr/X11R7/X
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Fri 18 Jan 2008, 17:26    Post subject:  

Also, my problem has been on a machine with an ATI card -what video card are you using?
Back to top
View user's profile Send private message 
NathanO

Joined: 22 Feb 2007
Posts: 196
Location: San Antonio, TX

PostPosted: Fri 18 Jan 2008, 17:46    Post subject:  

As I said I am using an HP Pavilion ZV6000. It is the built in video card that hod no problem with the pre Jan 15 version. What output would you like me to give you with what command to verifiy the card and driver
Back to top
View user's profile Send private message 
NathanO

Joined: 22 Feb 2007
Posts: 196
Location: San Antonio, TX

PostPosted: Fri 18 Jan 2008, 17:51    Post subject:  

The Xorgwizard shows ATI Raden XPRESS 200M 5955 (PCIE)
Back to top
View user's profile Send private message 
NathanO

Joined: 22 Feb 2007
Posts: 196
Location: San Antonio, TX

PostPosted: Fri 18 Jan 2008, 18:03    Post subject:  

Went back to the pre Jan 15 version. Xorgwizard shows same information. One difference was in pre Jan 15 shows Resolution, Horz Freq, and Ref Freq, where Jan 15 did not show any info on the three lines. This was even with the changes you showed above.

Resolution 1280 x 800
Horizontal freq 48.9347 Khz
Refresh freq 59.9689 Hz
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Fri 18 Jan 2008, 18:07    Post subject:  

OK. Use Xorg VIdeo Wizard, Edit Xorg.conf Find the Device settings, you will see
Driver "vga" #card0driver
change "vga" to "ati"
save Ctrl-s
and quit Ctrl-q
Reboots.
jf
Back to top
View user's profile Send private message 
NathanO

Joined: 22 Feb 2007
Posts: 196
Location: San Antonio, TX

PostPosted: Fri 18 Jan 2008, 18:11    Post subject:  

This is off a CD boot with no save file so I should need to remaster CD for this to stay if I reboot correct?
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Fri 18 Jan 2008, 23:50    Post subject:  

NathanO wrote:
This is off a CD boot with no save file so I should need to remaster CD for this to stay if I reboot correct?

Um, well, first thing is.. did that fix work?
jf
Back to top
View user's profile Send private message 
NathanO

Joined: 22 Feb 2007
Posts: 196
Location: San Antonio, TX

PostPosted: Sat 19 Jan 2008, 07:56    Post subject:  

Will be at a computer show today and at the TX Transportation Museum on Sun, will try all fixes on Mon
Back to top
View user's profile Send private message 
buttonss

Joined: 22 Aug 2005
Posts: 11

PostPosted: Sat 19 Jan 2008, 08:19    Post subject:  

Don't forget to update java runtime environment to 1.6.0_03!
Back to top
View user's profile Send private message 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Sun 20 Jan 2008, 21:42    Post subject:  

buttonss wrote:
Don't forget to update java runtime environment to 1.6.0_03!


Being done... new ISO should go up today or tomorrow.
jf
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Sun 20 Jan 2008, 23:09    Post subject:  

Sorry for the delay. I haven't had a chance to visit the forum all week.

The only thing I can think of that would have changed whether Xorg works is removing the built-in zdrv_301.sfs package. In the eariler ISOs, I had extracted the file and added it to the normal filesystem. Originally I thought it would fix an error friedsonjm was having. It didn't, but I didn't bother removing it until the last ISO. I only took it out because it seemed to be redundant (the real zdrv_301.sfs file was still around). But I'll put it back in the next ISO. Even if it's redundant, it decreases the potential for problems when Puppy can't locate the .sfs file. Maybe this will fix your problem. If not, we'll need to investigate further. When Xorg fails to start, /var/log/Xorg.0.log is the first place to look for error messages. It's also good if you know roughly what the /etc/X11/xorg.conf file should look like, because then you can scan over that and see if there's anything odd (such as using the wrong driver, or listing two screens but only having one screen section (that happens to me due to my dual-screen setup, so I must manually correct things, which is easy enough)).

I already corrected the CUPS bug today, along with updating Java, Wine, and the ClamAV definitions. I have a new ISO built with all these changes, but untested. I wanted to run through the forum first to see if there's anything else I need to do. So far I haven't found anything. I have about three threads left to read, then I'll go test then upload. Then play Dwarf Fortress for the first time in weeks. Smile

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
friedsonjm

Joined: 10 Mar 2007
Posts: 208

PostPosted: Mon 21 Jan 2008, 08:45    Post subject:  

New version, RC2, will be posted late Monday 21 Jan 08....
jf
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0766s ][ Queries: 12 (0.0079s) ][ GZIP on ]