Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:21
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Dingo Alpha 5 of 11 Jan. Issues (aka Bugs or Problems)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Wed 16 Jan 2008, 04:06    Post_subject: Re: Idea for devx, to help new users  

John Doe wrote:
If you rename 'make' to 'make-FULL' in the devx file
Do you even need to bother doing this. If you keep them the same name won't the version in the devx file just mask/overide the version in the pup_xxx.sfs if it is loaded.
_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send_private_message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Wed 16 Jan 2008, 04:39    Post_subject: Re: Idea for devx, to help new users  

HairyWill wrote:
Do you even need to bother doing this. If you keep them the same name won't the version in the devx file just mask/overide the version in the pup_xxx.sfs if it is loaded.


didn't test it that way, but did think of that while typing at one point.

willing to give you odds that you are correct.

just strip out some of the logic in it and just make sure the echos for the script that is masked work prior to masking.

it's all irrelevant (but might be helpful to new users)
Back to top
View user's profile Send_private_message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Wed 16 Jan 2008, 07:32    Post_subject:  

RE: PCMCIA

After the core driver is loaded, the device will appear in the output of lspsi/elspci and the correct module loaded like for a pci device (the modules [most of them, at least] are listed in modules.pcimap).

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4797
Location: GB

PostPosted: Wed 16 Jan 2008, 12:38    Post_subject:  

Tried to get cfdisk working with the full path specified - no go!

Pmount continues to annoy me - how to eject a CD with it?!
Back to top
View user's profile Send_private_message 
alienjeff


Joined: 08 Jul 2006
Posts: 2291
Location: Winsted, CT - USA

PostPosted: Wed 16 Jan 2008, 14:19    Post_subject:  


_________________
hangout: ##b0rked on irc.freenode.net
diversion: http://alienjeff.net - visit The Fringe
quote: "The foundation of authority is based upon the consent of the people." - Thomas Hooker

Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Wed 16 Jan 2008, 14:43    Post_subject:  

Alienjeff, Laughing

Sage, when I unmount a (mounted) CD, it ejects. Other than that, I have to push the eject button on the drive to eject it. Is it like that for you?
Back to top
View user's profile Send_private_message 
Caneri

Joined: 04 Sep 2007
Posts: 1580
Location: Canada

PostPosted: Wed 16 Jan 2008, 16:42    Post_subject:  

AJ...lol

It looks like someone's trying to abort a M$ Vista install...lol

Eric

_________________
Be not afraid to grow slowly, only be afraid of standing still.
Chinese Proverb

Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 16 Jan 2008, 19:45    Post_subject:  

Dougal wrote:
RE: PCMCIA

After the core driver is loaded, the device will appear in the output of lspsi/elspci and the correct module loaded like for a pci device (the modules [most of them, at least] are listed in modules.pcimap).

That's not my problem. 'modules.pcimap' lists the PCI-to-PCMCIA interface modules, such as yenta-socket, but not the modules for a particular card, like the 'xirc2ps_cs' required by my PCMCIA network card. 'elspci' will not help either.

The old 'cardmgr' package has a database that determines what module to load for a particular card. The new 'pcmciautils' does not have that mechanism/database, or at least not that I can see.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 16 Jan 2008, 19:48    Post_subject:  

Sage wrote:
Pmount continues to annoy me - how to eject a CD with it?!

I just verified with Pmount, unmounted a CD, it automatically ejected, as per normal.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Wed 16 Jan 2008, 22:05    Post_subject:  

I think everyone misunderstood Sage.

I believe he is after a button to eject the CD without mounting and then unmounting it.

Rest of the JWM Config Wizard is on the way. I've got it all working, just have to write up a post later tonight and post it.
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Wed 16 Jan 2008, 22:44    Post_subject: Invalid IF statement in rc.network script
Sub_title: Multiple NICs cause script to bypass "sleep 3" - old bug
 

Line 49 of /etc/rc.d/rc.network is an IF statement that tests for file existence. But "-f /etc/eth[0-9]mode" is invalid because it expands internally to "-f /etc/eth0mode /etc/eth1mode", whereas the "-f" primary accepts only a single file name. The message "/etc/rc.d/rc.network: line 49: binary operator expected" (for two NICs) or ". . . [: too many arguments" (for three NICs) is generated and the conditional "sleep 3" does not occur. The message appears in /tmp/bootsysinit.log.

The following substitute statement works with multiple NIC eth?mode files (and should also with "*wireless"):
Code:
if [ "`ls /etc | grep 'eth[0-9]mode\|ethernetmodules\|*wireless'`" != "" ];then

Richard
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4797
Location: GB

PostPosted: Thu 17 Jan 2008, 02:11    Post_subject:  

Is that a toaster you're poking with a paper clip, AJ?! All my paper clips are worn out - can you send a couple, please.
JD almost got it right. There is no 'EJECT' provided with Pmount. Never had any auto-ejects with the thousands of drives that passed this way.
Come on Jesse! let's have your MUT port and we can all sleep soundly again.....
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Thu 17 Jan 2008, 03:14    Post_subject:  

The gimageview .pet in the repository has an & in gimageview.desktop, which causes an error if you do
Code:
jwm -p

It doesn't actually seem to cause any problems, but it can be fixed by using &
Back to top
View user's profile Send_private_message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Thu 17 Jan 2008, 03:39    Post_subject:  

Sage wrote:
Is that a toaster you're poking with a paper clip, AJ?! All my paper clips are worn out - can you send a couple, please.


I almost started a poll to ask who has or doesn't have one of those bent paper clips next to them.

SHit my empty 4230-01-101-3984 has one of this in it. Much better than worrying about smokes.

Sage wrote:
JD almost got it right. There is no 'EJECT' provided with Pmount. Never had any auto-ejects with the thousands of drives that passed this way.
Come on Jesse! let's have your MUT port and we can all sleep soundly again.....


I miss mut also. First thing I used to do when hitting the 'desktop' was change that icon to mut.

---

jwm config stuff tomorrow. drank too much again.
Back to top
View user's profile Send_private_message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Thu 17 Jan 2008, 08:26    Post_subject:  

BarryK wrote:
That's not my problem. 'modules.pcimap' lists the PCI-to-PCMCIA interface modules, such as yenta-socket, but not the modules for a particular card, like the 'xirc2ps_cs' required by my PCMCIA network card. 'elspci' will not help either

I was not referring to yenta-socket etc., but to the drivers for the actual devices: most of them are listed in modules.pcimap. I went over it a month or so ago and there were only a few that weren't.

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0844s ][ Queries: 13 (0.0056s) ][ GZIP on ]