Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 07:39
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to disable screensaver while using Gxine?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
profolio

Joined: 03 Nov 2006
Posts: 66
Location: Montreal Qc

PostPosted: Sun 03 Dec 2006, 14:22    Post subject:  How to disable screensaver while using Gxine?
Subject description: Preventing screensaver in Gxine
 

In Puppy 2.12 whenever I watch a movie using Gxine after a while
the screen goes blank (screensaver) which is kind of annoying when you have to press a key to resume playing every so often.
Is there a way to prevent this...? I could'nt find anything in the preferences that alluded to a solution.
Thanks.
Back to top
View user's profile Send private message 
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Sun 03 Dec 2006, 19:24    Post subject:  

Are you sure its the screensaver and not just the monitor going to sleep.

I had this problem years ago when I first started with PC's then I was informed that the monitor could go to sleep.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 03 Dec 2006, 20:56    Post subject:  

Yes, it's the monitor going to sleep. But, I don't recall having this problem with older versions of Gxine.
Back to top
View user's profile Send private message Visit poster's website 
Pence

Joined: 30 Jul 2005
Posts: 201

PostPosted: Sun 03 Dec 2006, 21:45    Post subject:  

My monitor would go blank (sleep) during long slide shows with GTKSee . Someone told me to click Menu=>Control Panel=>Gxset X settings=>Screensaver...then unpick DPMS (Energy star).
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10656
Location: Arizona USA

PostPosted: Sun 03 Dec 2006, 22:29    Post subject:  

In 2.12 my monitor shuts off while I'm playing mp3 files unless I go to Menu -> Control Panel -> Gxset X settings, select the Screen saver tab and uncheck enable screen saver. I don't know that I'd consider this a bug, more like an unfortunate choice of default settings. Smile My gripe is, the setting isn't saved. I have to do it each time I reboot.
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Sun 03 Dec 2006, 22:49    Post subject:  

you could put this line in /root/.xinitrc, before exec $CURRENTWM, to disable the screensaver

xset s off

or right click the gxine icon on the desktop to edit /usr/local/bin/defaultmediaplayer, and put that line in that file, like this:

#!/bin/sh
xset s off
exec gxine "$@"
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10656
Location: Arizona USA

PostPosted: Sun 03 Dec 2006, 23:30    Post subject:  

GuestToo, will this permanently disable the screen saver? I want the screen saver to come on automatically after a long period of no activity, just not when I'm watching a movie or listening to something. Shocked
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Mon 04 Dec 2006, 00:25    Post subject:  

yes, it turns the screen saver off

you could put this in defaultmediaplayer:

#!/bin/sh
xset s off
gxine "$@"
xset s on

which should disable the screensaver when gxine runs, and re-enable it when gxine shuts down

you can set the inactivity time if you like ... for example, run the screen saver after 600 seconds (10 minutes) of inactivity:

xset s 600

30 minutes:

xset s 1800

again, you can put the commands in /root/.xinitrc (it won't work in rc.local), or put the commands in defaultmediaplayer

i don't know why the gui doesn't save the changes

man page:
http://www.die.net/doc/linux/man/man1/xset.1.html
Back to top
View user's profile Send private message 
profolio

Joined: 03 Nov 2006
Posts: 66
Location: Montreal Qc

PostPosted: Mon 04 Dec 2006, 08:19    Post subject: re Gxine  

Thanks for the replies.
As usual, a wealth of solutions and info
Back to top
View user's profile Send private message 
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Mon 04 Dec 2006, 20:23    Post subject:  

Now that's interesting: The Gx Settings GUI saves my settings without any problems at all. Odd that it seems to not be saving for others. I don't recall if it worked in 2.02 but it has from 2.10 and up. Now in Grafpup it never did.

Fluxbox, JWM, and IceWM likewise load the Gx.sh file (or whatever it's called) from my /root directory where I save it. The only one that doesn't is my desktop environment Xfce, but that doesn't bother me as it only takes a second to disable the screensaver and then turn on Mark's Puppy Screensaver instead. (Love those desktop waves! So don't the grandkids!)

In all of my distros I have the DPMS turned off by default in the Xorg.conf file. I hate it when the LCD monitor goes -snap!- as it shuts off. I don't mind it going blank, I just don't care for the power going off. Sad

That's my 2 pieces of wampum anyway.

Amicalement,

Eyes-Only
"L'Peau-Rouge"
(P/s: Howdy Profolio!! Wink )
Back to top
View user's profile Send private message 
davek7

Joined: 14 Mar 2007
Posts: 4

PostPosted: Wed 14 Mar 2007, 10:06    Post subject: Screensaver  

How do you set up the screensaver?
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Sat 22 Dec 2007, 09:42    Post subject:  

bookmarked
Back to top
View user's profile Send private message 
mbspringer133

Joined: 08 Jun 2012
Posts: 1

PostPosted: Fri 08 Jun 2012, 14:51    Post subject: how to disable screensaver
Subject description: how to disable screensaver Wary Puppy version 5.2, released Oct 2011
 

(click) Menu

(click) Desktop

(click) pupX: set properties of X

the third tab will be

(click ) Screensaver

(clear the check box that displays) Enable screensaver
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0623s ][ Queries: 12 (0.0058s) ][ GZIP on ]