Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 01:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Pdrive 0.27
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 9 [122 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
kjoe

Joined: 25 Jul 2007
Posts: 27
Location: Austria

PostPosted: Sun 25 Nov 2007, 17:55    Post subject:  

zigbert !

I've replaced /usr/local/pdrive/func_probe with the file you attached.
This fixed the detection problem with hda10. Every partition was shown correctly (hda1 as vfat; hda10 as swap).

Thank you.

kjoe

PS: In your prior post '...This should prevent it to detect hda10 as swap.' you meant hda1, right?
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5650
Location: Valåmoen, Norway

PostPosted: Mon 26 Nov 2007, 15:10    Post subject:  

version 0.21 is uploaded. See main post.
_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5650
Location: Valåmoen, Norway

PostPosted: Thu 06 Dec 2007, 13:26    Post subject:  

version 0.22 is uploaded. See main post.
_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Thu 06 Dec 2007, 19:51    Post subject:  

Gave 0.22 a shot - still wouldn't mount hda1 on my harddrive..... Strange thing is, Barry's new pmount is working fine.

Here is the message shown when trying to mount....

Error - Choose one of the partitions.

JB
Back to top
View user's profile Send private message Yahoo Messenger 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Thu 06 Dec 2007, 20:24    Post subject:  

So you highlight your hda1 partition by selecting it and you push mount and you get this message?

Works for me for my hda1 ntfs partition. (with 0.22)

BTW your hda1 doesn't happen to be your /mnt/home one?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5650
Location: Valåmoen, Norway

PostPosted: Fri 07 Dec 2007, 14:26    Post subject:  

JB4x4 wrote:
Here is the message shown when trying to mount....

Error - Choose one of the partitions.

1. Could you please confirm this bug. Did you select hda1, and then press 'mount'.
2. Could you please post a screenshot of Pdrive and Pmount. I am interesting in what headings it shows. If this is your 15-partition-disc, it would be rather informative Wink

Thanks
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sat 08 Dec 2007, 17:47    Post subject:  

Correct, either selecting the partition and pressing (un)Mount or double clicking on the partition result in the same message. Note: I can mount and unmount with the "new" pmount. Refreshing pdrive between shows the current state correctly, but it will not mount or unmount the partition.
pmountvspdrive.jpg
 Description   
 Filesize   38.55 KB
 Viewed   956 Time(s)

pmountvspdrive.jpg

Back to top
View user's profile Send private message Yahoo Messenger 
zigbert


Joined: 29 Mar 2006
Posts: 5650
Location: Valåmoen, Norway

PostPosted: Sun 09 Dec 2007, 06:16    Post subject:  

Version 0.23 is uploaded. I hope (and guess) this will solve your problem JB4x4. See main post.
_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sun 09 Dec 2007, 07:24    Post subject:  

Tried out the new version.................

and.............

IT WORKS.

Congratulations Zigbert, you have made my excessively partitioned drive Smile useable. Thank you very much for your hard work. I will continue testing to see if anything else comes up.

JB
Back to top
View user's profile Send private message Yahoo Messenger 
pdrito

Joined: 18 Jan 2007
Posts: 50

PostPosted: Sun 09 Dec 2007, 12:27    Post subject: bug ?
Subject description: on 0.23 version
 

zigbert,

Thanks for your work. !!

I am using Puppy-2.14.

I try your 0.21 version. ALL seems OK.

I try the last 0.23 version, and the size/free of drives/partitions reads wrong (about the double size).

pdrito.
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5650
Location: Valåmoen, Norway

PostPosted: Sun 09 Dec 2007, 12:38    Post subject:  

pdrito
Does Barrys new Pmount detect your size correct. I have not changed anything in Barrys sizedetection code (I think). Would you please post a screenshot of the the new Pmount together with Pdrive 0.23.

Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sun 09 Dec 2007, 12:51    Post subject:  

I too show double the drive size - free space is correct though.

Here is a screens shot...
pdrivesize.png
 Description   
 Filesize   166.21 KB
 Viewed   680 Time(s)

pdrivesize.png

Back to top
View user's profile Send private message Yahoo Messenger 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sun 09 Dec 2007, 13:04    Post subject:  

zigbert ---

Try this:

change the code at the start of func_probe

Code:
PROBEPART="`probepart`"
DISKINFO="`probedisk`"
PARTSINFO="`echo "$PROBEPART" -k | grep -v 'none' | tr ' ' '_' | tr '\t' '_' | tr '\n' ' '`"


to

Code:
PROBEPART="`probepart -k`"
DISKINFO="`probedisk`"
PARTSINFO="`echo "$PROBEPART" | grep -v 'none' | tr ' ' '_' | tr '\t' '_' | tr '\n' ' '`"


I moved the "-k" seems to have fixed the size problem (on my pc)

JB
Back to top
View user's profile Send private message Yahoo Messenger 
pdrito

Joined: 18 Jan 2007
Posts: 50

PostPosted: Sun 09 Dec 2007, 13:09    Post subject:  

On puppy-214 I have this images:
Barry's pmount
Pdrive 0.23 version


When you ask me for the last Barry's pmount, do you meant on puppy-3.01 or puppy-4 alpha2 ?.
on.puppy214.pmount.and.pdrive023.jpg
 Description   
 Filesize   114.34 KB
 Viewed   668 Time(s)

on.puppy214.pmount.and.pdrive023.jpg

Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 09 Dec 2007, 20:15    Post subject:  

zigbert, the underlying code in pmount was a dog's breakfast. I've been intending to rewrite it for ages. I've attached the latest pmount (slightly later than the one I uploaded to ibiblio several days ago) and a bugfixed 'mount' script that has to be used for mounting ntfs.

You might like to examine the new code, and if you wish use it for Pdrive.
mount.gz
Description 
gz

 Download 
Filename  mount.gz 
Filesize  1.63 KB 
Downloaded  795 Time(s) 
pmount.gz
Description 
gz

 Download 
Filename  pmount.gz 
Filesize  2.57 KB 
Downloaded  639 Time(s) 

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 7 of 9 [122 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0846s ][ Queries: 13 (0.0170s) ][ GZIP on ]