Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 10:50
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 3.00 bug reports here
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 9 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message

Joined: 08 Dec 2005
Posts: 31

PostPosted: Wed 03 Oct 2007, 22:58    Post_subject: BUG: /bin/sh:can't access tty;job control turned off  

kkpity wrote:
/bin/sh:can't access tty;job control turned off

I too have had this problem. Tested on three different PCs. Strange... This was with the seamonkey ISO that was annouced on Distrowatch.

Edit: I noticed that I put the cd into a scsi cdrom drive. Puppy did boot when I switched to the ide cdrom drive on one of the PCs. My 2.8 ghz machine didn't like it in it's ide drive though. The machine that booted is an 10 year old 500mhz. Strange...

Back to top
View user's profile Send_private_message 

Joined: 29 Jul 2006
Posts: 864
Location: Oregon USA

PostPosted: Thu 04 Oct 2007, 01:16    Post_subject: Problems and recommendations  

1. Seamonkey has been chosen as the default, central internet suite for Puppy. So be it. Overall a good choice. But let's use a recent, complete version that works with important extensions, for example GPG. (Slackware's package is apparently not satisfactory in this case.) Suggest compiling a complete ver 1.1.4. And let's not go overboard to make Puppy run in computers with tiny rams - they're on the way out.

2. We need a consistent package handling system. Slaptget should be fine when it arrives, thank goodness, but there is a lot of legacy compatibility and menu stuff to be sorted. The current experimental Slaptget.pet add-on for ver. 3 is incomplete, unreliable, menus don't work, causes sytem lockups. Sorry, but at least that's my experience.

3. Puppy is a wonderfully compact and fast system. Roxfiler is excellent but will not be loved by naive windows refugees. So be it, we can't please eveyone. Please, no KDE. However, we could pay more attention to human factors. As mentioned repeatedly, Pfind, PSI, and Pdict all force one to grab the mouse instead of continuing keying to enter. Small, but annoying. Omitting local help files is necessary for compactness and internet help links are more up to date; applications should have such links available where practical. It's frustrating to need help but be unable to find it without a search.

4. Gxine is the chosen default MM player, and a good one. MM is always a diverse headache, but Gxine in Puppy has seemingly forever been incomplete and confusing, and the current inability to use full screen should not have been overlooked.

5. I am a user, not a developer, and have been extremely interested in promoting and seeing Puppy succeed - on a large scale, not just for my own use. Barry has done wonders on the internal machinery, but more help is needed to smooth the rough edges and have things work as reasonably expected. I still envision a Puppy that regular people use productively, not just for "fun" in figuring it out. 2.17.1 is very reliable and mature at the basic functions, but when one tries to do things a little out of the ordinary it can get difficult. Scanning, e.g. although these problems are mostly not peculiar to Puppy, but to the lack of Linux drivers and applications.

Puppy 3 is I reckon still a beta in fact if not name - as most computer systems are. But it will I hope "get there" in my lifetime - and Barry's.
Welcome back, MU, and others like you. OK, I'm ready to dodge - I do mean well.

Back to top
View user's profile Send_private_message Visit_website 

Joined: 04 Oct 2005
Posts: 4936
Location: GB

PostPosted: Thu 04 Oct 2007, 03:33    Post_subject:  

maddog: There is a long running thread:


that tells you that scsi doesn't boot in Puppy, but does read and write to scsi drives.

Booting from a scsi CDdrive is a much, much older paradox - you need DOS drivers to see it. 'doze eventually solved the problem with a floppy boot disc with ASPI drivers supplied by Adaptec.
However, as you read from the above thread, one guy has solved booting from scsi (perhaps only the HD?) for Puppy, too.
Until Barry finds the time and inclination to make this apparently minor adjustment, you can use DSL or one of the major distros. DSL has always been able to boot installations from scsi hard drives. Unix was entirely based on scsi HW, so it's something of a conundrum that some distros struggle with it - everything needed is in the kernel, always has been.

You could write to Barry to encourage him when he returns from the Perth Show next week? Several of us have, but he's a very busy guy! After all, that scsi thread (there are others, too) has received thirteen thousand+ hits - and I'll only admit to a dozen or so, myself.
Back to top
View user's profile Send_private_message 

Joined: 29 Jul 2006
Posts: 864
Location: Oregon USA

PostPosted: Thu 04 Oct 2007, 09:42    Post_subject: Another note on problems and recommendations  

Thanks for your tolerance of my forthright observations above. Here's more, not version 3 specific, but not to be overlooked as part of the whole.

Any "distro" has to do a lot of testing to be palatable to the public. Puppy has done well at developing innovative mechanisms, such as the Petget package manager (soon to be augmented/superseded by Gslapt?) But volunteers are needed to test/fix user type items.

In the Petget manager I just now looked at three things at random:

Bluefish - 0.7 There has never been such a version, yet it sort of installs.
Galculator 1.2.4 "installs" and appears in the menu but doesn't run.
Gphoto 2.1.6. I don't know what this is; there's no description. It cites dependencies it can't find and I can't find. It "installs," doesn't appear in the menu and won't run.

Maybe there's something wrong with my Puppy in particular but if so no indication. Such things can leave an ordinary user scratching his head.

Back to top
View user's profile Send_private_message Visit_website 

Joined: 04 Oct 2007
Posts: 1
Location: Tennessee, USA

PostPosted: Thu 04 Oct 2007, 11:46    Post_subject: Live cd boot issues  

I have been trying to revive an older laptop, and have a few issues with trying to get it to boot the 3.0 Puppy live cd.

Right after the Perform a 'switch_root' to the new Unionfs filesystem is done, it starts this:

modprobe: FATAL: Error running install command for binfmt_0000 and it just repeats that error forever until I ctl-alt-del.

I found a copy of puppy 2.13 and it boots just fine.

Any help is appreciated.

ps. Its a Compaq Armada E500 laptop with PIII 500 and 128meg. PCMCIA D-link wireless adapter installed.
Back to top
View user's profile Send_private_message 

Joined: 04 Oct 2005
Posts: 4936
Location: GB

PostPosted: Thu 04 Oct 2007, 12:09    Post_subject:  

Armadas are compatible, in principle, (I have one myself) but a number of issues have been raised here, so worth a Search.
Two suggestions come immediately to mind.
Compaq wrote some hidden files to hard disc which are accessed during boot up. These can be viewed with a suitable utility, Linux or DOS. It has been said that they interact with the BIOS at start up. However, it is doubtful whether they are essential despite some claims to that effect.
Here is the simplest way of dealing with the situation, even if the description might sound complicated.
Remove the HD and install it into some modern HW using an IDE adapter, available from Radioshack, NewEgg (USA), CPC (UK), Komplett (Europe). This operation takes minutes only.
Take an image of this disc - and verify it!
Fdisk from DOS or cfdisk from Puppy. Delete everything and set up one main partition and a very small swap partition (something between 48 & 128 is entirely adequate depending on main memory).
Format main to ext2 and format swap.
Install Puppy and return the HD to the old laptop.
Adjust BIOS as appropriate.
Once it runs, set up as usual. If it doesn't work, restore the image and try something else!
Edit your profile to disclose your general location (there may be a Forum member living around your corner that can offer more detailed assistance).
Back to top
View user's profile Send_private_message 

Joined: 09 Nov 2005
Posts: 28

PostPosted: Thu 04 Oct 2007, 14:37    Post_subject: can't install flash 9  

I installed the Firefox 2.0.4 using petget. It installed by complained about 3 missing components.

I tried to install flash 9 and it fails because it says it can't find iconv. It also wants glibc 2.2, which doesn' seem to be part of 3.00
Back to top
View user's profile Send_private_message 

Joined: 31 Dec 2006
Posts: 208

PostPosted: Thu 04 Oct 2007, 18:10    Post_subject:  

In puppy 2.16 my eth0 is autodetected (8139too) and will configure, i have an usb rt73 based wireless stick, not autodetected, but can be either modprobed or installed and configured using the network wizard.

In puppy 3 final-seamonkey, NEITHER are detected, and rt73 connot be loaded or modprobed ( no such module). Havent tried 8139too modprobe as i couldnt remember which module it used until i was back into 2.16.
Back to top
View user's profile Send_private_message 

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Fri 05 Oct 2007, 02:26    Post_subject:  

Message was given to me that Seamonkey 1.1.2 in pup v3 has a bug in it (SM problem) & the solution is upgrading to 1.1.4

That's all I know & gotta go.
Back to top
View user's profile Send_private_message 

Joined: 18 Oct 2006
Posts: 84

PostPosted: Fri 05 Oct 2007, 09:13    Post_subject:  

iandel wrote:

1. It doesn't detect eth0 or eth1 on one computer (Desktop with asus m/board) or eth0 on the other (Gateway laptop) or load the modules (or drivers or whatever they are in the wizard for network). These worked fine previoulsy (2.14).

All these things work fine when booting from the CD with pfix=ram,clean. They don't work after it is installed on the hard drive.

Same thing here. Run 3.00 from CD first time and everything works. Save the session and no more networking or sound, nor will it detect it. Says I have no network card or sound.
Try new CD. Everything works. OK good. Do frugal install. No Network or sound. Delete that install. Do Full install. Everything works but now it runs slower since nothing is loaded in ram.

So to sum up: Everything works upon boot as long as I do not save the session. saving the session, either as a Live CD or frugal install kills sound and network. Bummer
Any thoughts?

Back to top
View user's profile Send_private_message 

Joined: 28 Sep 2005
Posts: 30
Location: USA

PostPosted: Fri 05 Oct 2007, 09:49    Post_subject:  


Update to previous post:

Everything works when booting from CD, pfix=ram,clean but ethernet is not detected when running from HD and USB does not exist in any form.

The ethernet drivers "forcedeath" and "3c59x" which load from cd will NOT load, even when manually selected, when running on HD.

Why is it that it Puppy 3.00 will run happily and well from CD but not install correctly on HD? Frugal and full installs have the same problem.
Back to top
View user's profile Send_private_message Visit_website 

Joined: 04 Oct 2005
Posts: 4936
Location: GB

PostPosted: Fri 05 Oct 2007, 10:07    Post_subject:  

No problems installing v3.0, but it screws up X operation if updating v2.15CE. Seem to remember other folks having trouble upgrading CE s? Tried a few editing guesses but eventually resorted to mke2fs!

There is a confusion of order in installation screens that I raised before and is still present.
When doing an upgrade (using the CD and pfix=ram), it isn't apparent that an UPGRADE rather than new installation will be possible until fairly late in the selection process. The word isn't present until the last moment. No idea how you coders organise the information displayed, but UPGRADE needs to show right at the beginning, even if the value entered isn't used until later.
Back to top
View user's profile Send_private_message 

Joined: 08 Jul 2006
Posts: 2291
Location: Winsted, CT - USA

PostPosted: Fri 05 Oct 2007, 10:08    Post_subject:  

@iandel: Did you happen to test the alpha or any betas of v3.00 on your computer? If so, did ethernet function properly?
hangout: ##b0rked on irc.freenode.net
diversion: http://alienjeff.net - visit The Fringe
quote: "The foundation of authority is based upon the consent of the people." - Thomas Hooker

Back to top
View user's profile Send_private_message 

Joined: 09 Dec 2006
Posts: 836
Location: Ohio, USA

PostPosted: Fri 05 Oct 2007, 12:52    Post_subject:  

I believe this has been stated already, but Puppy seems to be unable to load the driver squash file from a frugal install to a folder. Stick it in "/" and it's good to go.

This could cause the ethernet problem if you're using a frugal install. If you are using a full HD install I don't know what's wrong.

Be brave that God may help thee, speak the truth even if it leads to death, and safeguard the helpless. - A knight's oath
Back to top
View user's profile Send_private_message Visit_website 

Joined: 12 May 2007
Posts: 37

PostPosted: Fri 05 Oct 2007, 13:22    Post_subject:  

I have the same error mentioned above:

/bin/sh:can't access tty;job control turned off

I've got a frugal install in a 300 MB FAT partition... the GRUB entry is standard:

title Puppy
rootnoverify (hd0,2)
kernel (hd0,2)/vmlinuz root=/dev/ram0 pmedia=satahd
initrd (hd0,2)/initrd.gz

Maybe it's because it is a SATA drive?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 9 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1041s ][ Queries: 13 (0.0144s) ][ GZIP on ]