Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 13:11
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 3.00BETA bug reports here
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message

Joined: 29 Jul 2006
Posts: 864
Location: Oregon USA

PostPosted: Sun 16 Sep 2007, 17:12    Post_subject:  

I have tried both a pristine 3beta and an upgrade 3beta from 2.17.1

(2.17.1 has worked perfectly since it appeared. 2.20 was not close enough to seriously test.)

IGxine advised me to add the extra codecs package but could not.

zigbert wrote on Developer News:
Friday, September 14, 2007, 04:53 PM
Your request is already fixed in the latest PBdict and Pfind.

I don't see this working in 3beta, zigbert.

A detail - The link to the release notes in the help file is broken.

In the upgrade test -
Seamonkey (and Mail & News) and Abiword do not run, although it seems both Seamonkey 1.08 and 1.12 are installed. (Both Seamonkey and Abiword work in pristine 3beta.)

Yes, I understand it was advised not to upgrade, but that's the real and necessary test and it has not been a problem for me from 2.13 until 2.20.

So back to 2.17.1 for now.


Back to top
View user's profile Send_private_message Visit_website 
Puppy Master

Joined: 09 May 2005
Posts: 7441
Location: Perth, Western Australia

PostPosted: Sun 16 Sep 2007, 18:28    Post_subject:  

Artie wrote:
Chooselocale Fetch doesn't work just get ERROR: Aborting

Try it now. The PET package was not uploaded to ibiblio.
Back to top
View user's profile Send_private_message Visit_website 
Puppy Master

Joined: 09 May 2005
Posts: 7441
Location: Perth, Western Australia

PostPosted: Sun 16 Sep 2007, 18:38    Post_subject:  

Henry wrote:
Gxine advised me to add the extra codecs package but could not.

Okay, I've uploaded the extra codecs package to ibiblio. Run Gxine from a terminal to see any error messages, also let me know if it still wants more codecs -- and what type of media file you're trying to play.
Back to top
View user's profile Send_private_message Visit_website 

Joined: 29 Jul 2006
Posts: 864
Location: Oregon USA

PostPosted: Sun 16 Sep 2007, 19:18    Post_subject:  

Thanks, Barry,

No cause for alarm. I did install the now available codecs package. It said there was a dependency missing, xine.lib. (I need to install PSI to make it easier to look for this stuff ;-) It still says sipr.so or cook.so missing, but this happens when I try media/tv/bbc24. I have no interest in this, but it usually works as a test. Most of the BBC stuff is Real, which I generally avoid anyway. Once upon a time I had Real Player 10 installed, but it's a complication I don't need. Here's the response from the console:
# gxine
AFD changed from -2 to -1
xine-lib: error: Error loading library:: sipr.so

EDIT: I should have noted that Gxine _does_ play DVDs well, also works with Seamonkey for streaming radio mp3, aacplus, windows media, but of course not realplayer.

Back to top
View user's profile Send_private_message Visit_website 

Joined: 29 Jul 2006
Posts: 864
Location: Oregon USA

PostPosted: Sun 16 Sep 2007, 20:03    Post_subject: Seamonkey Mail GPG  

Had been hoping that this would get fixed in 3. Hope springs eternal!

With the pristine installation I added PSI and thence gnupg 4.7 followed by the Enigmail extension, which for the first time would not install, giving
"unexpected error - 201"

I guess the background of this problem is familiar. If necessary I can recite the strings.

Back to top
View user's profile Send_private_message Visit_website 
Official Dog Handler

Joined: 04 May 2005
Posts: 11463
Location: Arizona USA

PostPosted: Sun 16 Sep 2007, 20:20    Post_subject:  

My microphone doesn't work in Skype 1.4 (the latest version of Skype, downloaded from the Skype website.) The microphone works in Puppy 2.17 with the same Skype download. I tinkered with every setting in alsamixer and the Puppy mixer, to no avail. In 2.17 I can always hear the microphone in the speakers, but not in 3.0 beta. I don't know of any other way to test the microphone in Puppy. Some sort of karaoke program would be nice. Laughing
Puppy Help 101 - an interactive tutorial for Lupu 5.25
Back to top
View user's profile Send_private_message 

Joined: 03 Nov 2006
Posts: 171
Location: UK

PostPosted: Sun 16 Sep 2007, 20:37    Post_subject: Xvesa Problem  

Tested v3.00 from disc using pfix=ram.
Tried Xvesa, dialog box came up, but as I moved the mouse the menu screen came up momentarily and greyed out the screen resolutions buttons.
Unable to click anything - no button worked - had to reboot into Xorg which gives me a flashy screen.
I use external serial conection diamond supraexpress56e modem.
Tried pupdial got online for a couple of minutes bfore it shut itself down perhaps a timeout error waiting for browser?.
Tried gkdial and works ok.
Havn`t tried a full install yet. Has anyone?
Back to top
View user's profile Send_private_message 
Official Crustacean

Joined: 04 May 2005
Posts: 15121
Location: Paradox Realm

PostPosted: Sun 16 Sep 2007, 20:49    Post_subject:  

Smile The bubbles game is much faster running. Not really a bug - just something I noticed . . . Smile
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 

Joined: 24 Aug 2005
Posts: 1614
Location: Maine, USA

PostPosted: Sun 16 Sep 2007, 21:27    Post_subject: Network Wizard sends invalid MAC address to router
Sub_title: MAC address is preceded by 12 bytes, so misunderstood by router -- WORKAROUND! - see updates below.

The "autodhcp" function of the network wizard in both 3.00b and 2.17.1 appears to send an incorrect MAC address to my router, causing it to assign a new IP address each time autodhcp is used in the same PC, instead of assigning the static DHCP address I set up in the router. Puppy 2.16.1 works correctly.

For example, I have a static address set as:
aptiva   00-10-b5-d7-56-54
but the router assigns a dynamic address for the same MAC address:
puppypc   65746830000100010E7F4E800010B5D7
The start of the MAC address is the last 8 characters of that string (0010B5D7). As you can see in the data below, the first 16 characters (8 bytes in hex) is constant (5746830 00010001); the remaining 4 (0E7F4E80, 0E7F4B61, 0E50E099...) seem to vary between autodhcp invocations. That variation probably causes each use to be treated by the router as a different MAC address.

Here is a snapshot of the static and dynamic DHCP addresses:

Static DHCP Client List
     Host Name       IP Address       MAC Address    
   HPdj5850   00-30-6e-c6-fc-86   editdelete   
   Equium   00-00-39-ba-51-0e   editdelete   
   NetVista   00-09-6b-c3-bd-e7   editdelete   
   Rich-Server   00-10-4b-6f-e5-a8   editdelete   
   ThinkPad-T30   00-09-6b-7a-27-18   editdelete   
   aptiva-xubuntu   00-10-b5-d7-56-54   editdelete   
   CM34622   00-12-79-68-87-0d   editdelete   
Dynamic DHCP Client List
Host Name    IP Address    MAC Address                   Expired Time    
puppypc   65746830000100010E7F4E800010B5D7   Apr/13/2002 04:54:22
puppypc   65746830000100010E7F4B610010B5D7   Apr/13/2002 04:40:12
puppypc   65746830000100010E7F2E7B0010B5D7   Apr/13/2002 04:29:02
puppypc   65746830000100010E50E09900096BC3   Apr/13/2002 05:50:02
xubuntu-box   00-01-80-04-54-89            Apr/09/2002 20:19:14
puppypc   65746830000100010E785E5500018004   Apr/09/2002 18:20:12
puppypc   65746830000100010E5F553C000039BA   Apr/13/2002 07:34:05
The "ubuntu-box" entry is in the correct form; the older Puppys use that form.

As further evidence, here are entries from the router's log showing an entry for Puppy and one for WinXP (also used by Puppy 2.16.1):
Time    Message    Source    Destination    Note
Apr/06/2002 08:48:58    DHCP lease IP to puppypc            65-74-68-30-00-01
Apr/06/2002 07:23:43    DHCP lease IP to NetVista            00-09-6b-c3-bd-e7
Note the "MAC address" starting with "65".

I used mostly CD-boots to test this, as well as a frugal installation. I am ready to test any fix for this.


UPDATE: I have isolated the problem to the file dhcpcd. If I replace it in 3.00beta with the same file from 2.16.1, the bad MAC address problem does not occur! That appears to be a workaround; but is there any hazard to doing that -- any dependencies that need attention?

UPDATE2: Using the new Slackware binary compatibility capability, I extracted and substituted dhcpcd version 2.0.4 from Slackware 12; it also did not exhibit the problem I described above! That version is the Puppy 2.16 version with many patches added. Version 3.1.0 is a total rewrite and is later than the Slackware, Debian or T2 stable and unstable versions -- bleeding edge.

Barry, please consider replacing the Puppy 3.00 version of dhcpcd with the Slackware version, because the current version cannot be trusted on a LAN when it misidentifies PCs by transmitting bogus MAC addresses. (My LAN supports a telecommuter and cannot be suspect when problems arise.) Thanks.

EDIT: My router is a D-Link DI-524, with wireless turned off. The PCs are various oldies but all show the same DHCP misbehavior under 2.17.1 and 3.00beta.

Back to top
View user's profile Send_private_message 

Joined: 18 Jan 2007
Posts: 50

PostPosted: Sun 16 Sep 2007, 22:12    Post_subject: CD/DVD Multisession problem. Again  

Hi friends,

The CD/DVD multisession problem start on 2.20 version.

On http://www.murga-linux.com/puppy/viewtopic.php?t=21475
I wrote:

"Hi friends.

The facts:
1.- I dont have hardisk
2.- I have 1.5 GB memory ram
3.- Always I work with a multisession Puppy disc (CD or DVD)
4.- I load puppy 2.20Alpha iso from a multisesion format disc. No problem.
5.- I configure country, xorg, and net server. No problem
The issue:
When I try to reboot, It supossed to ask for record the changes on CD... but
when start the routine record messages, finally It start to ask for a NEW CD, because the used one is full, and IS TIME FOR A NEW DISC.
What is happening ?
It is a bug ?
It is my fault or I miss something ? (again).

I like to try this alpha puppy , but I stuck with this.


Well... exactly the same for puppy-3.00Beta now.
Hope this will be fixed.

Back to top
View user's profile Send_private_message 

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Sun 16 Sep 2007, 23:53    Post_subject:  

I tried booting into ram, and used xvesa. Puppy is getting pretty smooth and fast; I got on the internet no problem this way although I needed the network wizard. A couple of minor items:

1) Partview is still the old one. Remember my modest contribution, an updated partview? http://www.murga-linux.com/puppy/viewtopic.php?search_id=831610497&t=20576

2) Got the same "making filesystem usable... failed" message during boot as the others did; worked otherwise...

3) You might want to make the network wizard window wider, or condition its width on the widths of the data displayed for the devices detected. Mine was wide enough that the text went off the edge.

4) Never mind...

5) I'm still less than thrilled at the Welcome message pasted on the desktop, where it is obscured by icons and the like; looks a little rough. Always prefer for it to be in a dillo (or equivalent) window.

6) Top says seamonkey uses 42.7% of my 320MB memory. Does that seem reasonable?

7) ePDFView seems only to display images, not text. At least it's that way with my saved Home Power magazines, which display properly in the old acroread dotpup in 2.16.1. I can post a snapshot of this if you are interested.

8 ) In Gxine I opened the Media menu and tried to listen to some stations. I always get the message "Error loading library: cook.so". Also got the suggestion to load the extra codecs. When I tried that it installed, except that it said the dependency xine_lib is missing. Anyway it still complained about loading cook.so. BTW I just tried this in 2.16.1 and found it didn't work either; it acts like it is (no error messages) but I get no sound.

9) When I do Menu>Help, I get the Netsurf (which is a slow dog) help page; the first thing it suggests is looking at the release notes. Clicking that link gives "not found" because the link looks for 2.21 notes when they are 3.00 in /usr/share/doc. I suspect you will have a lot of these things to chase down...

10) If you do "man ls" in a console window, Netsurf goes and gets the page from Wikipedia. It displays this page pretty well except the bit of black-background text in about the middle of the page. Compare the same page rendered by Seamonkey, which gets it right. This may be asking too much of a small browser though; I know Dillo also had such issues.

11) On reboot, it hung going into the xvesa wizard. Had to ctrl-alt-backspace to restart X and get the wizard again, which worked 2nd time around.

Looks good, despite a few glitches!

Back to top
View user's profile Send_private_message 

Joined: 08 Aug 2006
Posts: 34
Location: Mississippi

PostPosted: Mon 17 Sep 2007, 00:18    Post_subject: Full HD install Good to GO  

Did full hd of Puppy and it was really smooth, everything I have tested so far is working good on my system. The only thing I noticed is that Puppy now mounts both of my swap partitions they are are 2 physical differnt drives. normally in the past Puppy would only mount the swap part on the drive it was installed to. I have no problem with it mounting both swaps, my only concern is is it ok to have more then 1 swap part mounted. Puppy 2.17.1 still only uses the one? Other then that puppy 3.0 is looking really good from my end. Good job as always to eveyone.

Gateway E3600 PC(mfg date: 12/06/01)
256 ram
ati video 32megs
($25 garage sale special and still going strong)
Back to top
View user's profile Send_private_message 

Joined: 05 Jan 2006
Posts: 164
Location: Khon Kaen Thailand.....NOW back in the UK

PostPosted: Mon 17 Sep 2007, 00:58    Post_subject: pppoe
Sub_title: unable to use pppoe

Barry Sir,
I can enter my network cofig OK, but when i try to use pppoe i get this message
error starting connection
/usr/bin/pppoe-start.line 44
/bin/id:no such file or directory
pppoe-start: you must be root to
run this script.
I thought i was root???? this does not happen in 220. i am using 220 now to write to you.
any advice is most welcome. Thank you for all of your hard work in providing Puppy.
Back to top
View user's profile Send_private_message YIM MSNM 

Joined: 21 Oct 2006
Posts: 537

PostPosted: Mon 17 Sep 2007, 02:53    Post_subject:  

Hi Barry, just tried Puppy 3.00 BETA with kernel (frugal fresh install and get the same 3 problems (there may be more I haven't done much testing yet)
Cups knows the printer is there (it tells me what type it is) but will not do test print or show any waiting jobs, no driver show for ethernet and no sound.
Back to top
View user's profile Send_private_message 

Joined: 16 Jan 2006
Posts: 162
Location: Christchurch, New Zealand

PostPosted: Mon 17 Sep 2007, 03:52    Post_subject: Abiword not showing text  

Abiword opening doc or rtf doesn't show the text. Copy & paste into new Abiword document saved as rtf and re-opened doesn't show the text. Opening as text (Geany) shows that the text is present (after a heap of RTF tags).
Is it just me?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1088s ][ Queries: 13 (0.0051s) ][ GZIP on ]