Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 29 Nov 2014, 06:03
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
2.17 puppy not booting when pup_217.sfs not in /
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
mochuk

Joined: 13 Sep 2007
Posts: 1

PostPosted: Thu 13 Sep 2007, 20:37    Post subject:  2.17 puppy not booting when pup_217.sfs not in /
Subject description: with possible solution
 

Puppy 2.17, usbflash, frugal, all files located in /boot/puppy

Also with using the psubdir Variable (psubdir=boot/puppy), puppy is not booting, because it can't find the file pup_217.sfs.
The Problem is the function loadpupsfsfunc() in /initrd/sbin/init. It tries to get /pup_217.sfs instead of /boot/puppy/pup_217.sfs:
Code:

SIZEPUPSFSK=`du ${1}/$NAMEPUPSFS | cut -f 1`
...
cp -f ${sfsmntpt}/$NAMEPUPSFS /mnt/tmpfs/
...
losetup /dev/loop0 ${sfsmntpt}/$NAMEPUPSFS

Because pup_217.sys ($NAMEPUPSFS) is not in / this attempts will fail.
A working solution is to extract the subdir from the variable "$PUPSFS", so that pup_217.sfs is found:
Code:

sfssubdir="`echo -n "$PUPSFS" | cut -f 3 -d ','`"
   sfssubdir=${sfssubdir%/*}  #extract dirname
   sfssubdir=${sfssubdir#/}   #strip trailing slash
...
SIZEPUPSFSK=`du ${sfsmntpt}/${sfssubdir}/$NAMEPUPSFS | cut -f 1`
...
cp -f ${sfsmntpt}/${sfssubdir}/$NAMEPUPSFS /mnt/tmpfs/
...
losetup /dev/loop0 ${sfsmntpt}/${sfssubdir}/$NAMEPUPSFS
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Fri 14 Sep 2007, 08:14    Post subject:  

Interesting work Mochuk. I too looked at the init script when Puppy 2.17 did not boot as I would like. It is recognised that there are a number of bugs in the script as it has grown over time.

The next release of Puppy, 3.00, will start afresh with a new init script. Barry has also said it will boot when the Puppy files are in a subdirectory, (at the first level only). The alpha release (2.20) can be made to work this way.

I've stopped looking at the 2.17 script now and awaiting the new release, when I can peruse the new script.

ICPUG
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0476s ][ Queries: 12 (0.0040s) ][ GZIP on ]