Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 19:30
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
HOWTO install Java the hard way
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
Bruce B

Joined: 18 May 2005
Posts: 11132
Location: The Peoples Republic of California

PostPosted: Tue 04 Sep 2007, 17:27    Post_subject:  HOWTO install Java the hard way  

This HOWTO was written by Sit Heel Speak. Originally posted in the beginners forum, then lost in the shuffle. Later added to the HOWTO section by Bruce B

NOTE: Before starting this how to, please read the follow up
posts by other users, especially the one by Bluedogruns


I've just installed the current Java Runtime Environment ( into Puppy 2.17.1 (with WhoDo's EZPup 2.1.7R2) directly from Sun, no dotpup involved. Here's the procedure. I composed this so a French-speaker can translate it using Babelfish:

1. Open Seamonkey. Surf you to

2. In the lower right, press "Java for games, apps, and a whole lot more."

3. Press you the green "Free Java Download" button.

4. Press you the green down-arrow "Linux (self-extracting file)" button.

5. A dialog box opens, "Opening jre-6u2-linux-i586.bin".

6. Be sure that "Save it to disk" is highlighted.

7. Click you the "OK" button.

8. Click you the "Browse for other folders" line.

9. In the left window, double-click "File System".

10. Grab the "Enter name of file to save to..." window's title bar and move the window to the center of your screen.

11. In the right window, scroll down to "usr" and doubleclick.

12. Scroll down and doubleclick "local".

13. Scroll down and doubleclick "bin".

14. Click you the "Save" button.

15. Wait you for the 18+MB download to conclude. You will see the download's progress in the "Download Manager" window, which you can see by pressing the tiny green down-arrow on the taskbar.

16. Open you Puppy's lower-left Menu (Start) button, Filesystem - Rox-Filer file manager.

17. Press you the up arrow at top left of the Rox window. This places you in / .

18. Click you the "usr" icon.

19. Click you the "local" icon.

20. Click you the "bin" icon.

21. Right-click the icon for jre-6u2-linux-i586.bin (which you have just downloaded).

22. Highlight "File 'jre-6u2-linux-i586.bin'" and roll you the mouse to the right and roll to "Properties" .

23. Left-click "Properties" .

24. Click you the checkbox "Exec" (=make executeable) in the "Owner" row.

25. Click the Close button.

26. Right-click in the whitespace of the /usr/local/bin Rox window.

27. Roll down to "Window" and slide the mouse right and to "Terminal here" .

28. Left-click "Terminal here" .

29. At the # prompt, issue the command


30. You see the license. Repeatedly, but slowly, press the "Page Down" key until you see the word "More" no longer.

31. Now you see "Do you agree to the above license terms? [yes or no]"

32. Press y {enter} .

33. Now Java unpacks. In a minute you see "Done."

34. Menu - Filesystem - Rox-Filer

35. Up-arrow usr lib mozilla plugins

36. Right-click in whitespace in this Rox window, Window-->Terminal here .

37. Create you a symbolic link: issue you this command:

ln -s /usr/local/bin/jre1.6.0_02/plugin/i386/ns7/libjavaplugin_oji.so ./libjavaplugin_oji.so

38. Click you in Seamonkey

Edit - Preferences - Advanced (click on the word "Advanced") - click the "Enable Java" button.

39. Click you in Seamonkey

Edit - Preferences - Advanced (click on the + sign) - Scripts and Plugins

40. Be sure that "Enable JavaScript for Navigator" is checked.

41. Edit - Preferences - Advanced (on the + sign) - Cache - Clear Cache

42. Close Seamonkey and restart it.

42. Now surf to


43. At the lower right, click "Java for games, apps, and a whole lot more"

44. Click the tiny "Do I have Java?" phrase.

In a few seconds, you should see "Congratulations!"

Now you have Java.

You can get rid of the installer


(either delete it or move it off to another drive)

by Sit Heel Speak

Back to top
View user's profile Send_private_message 

Joined: 11 Sep 2007
Posts: 4

PostPosted: Sat 15 Sep 2007, 05:26    Post_subject:  Java
Sub_title: not quite

Hi and thanks for a really idiot-proof instruction for Java installation.
I was doing well until the issuing of the symbolic link.
All I get is "command not found"

Any further help for this newbie would be great (I'm trying to get Logmein to work).

Back to top
View user's profile Send_private_message 
Bruce B

Joined: 18 May 2005
Posts: 11132
Location: The Peoples Republic of California

PostPosted: Sun 16 Sep 2007, 13:49    Post_subject:  

ln is a valid command - perhaps you made a typo.

If you don't think so, hope you have suggestions about what you think happened.
Back to top
View user's profile Send_private_message 

Joined: 11 Sep 2007
Posts: 4

PostPosted: Sun 16 Sep 2007, 17:01    Post_subject: Command problem
Sub_title: Java

Hi Bruce and thanks for taking the time and trouble to respond.
No typos here.
I am attaching an image of what happens when I try to run this command.
Maybe this will throw some light?

Thanks again.

 Filesize   155.41 KB
 Viewed   24855 Time(s)


Back to top
View user's profile Send_private_message 

Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 16 Sep 2007, 18:36    Post_subject:  

no in but ln (small L and small N).
Stands for LiNk.

Back to top
View user's profile Send_private_message Visit_website 

Joined: 12 Sep 2007
Posts: 38

PostPosted: Sun 16 Sep 2007, 23:33    Post_subject: I know what is wrong.
Sub_title: I had the same issue.


I am new to Puppy and Linux and have had to ask 3 or 4 questions myself to get Puppy just the way I want it. Actually getting Java installed was one of my questions too.

Even as a newbie I have figured what is wrong here and following these instructions to the letter will not make it work. Took me a couple of hours to figure out everything. Now I can contribute something for the help I got from others.

Let me start by saying if it was not for this post in the first place I would still be working getting Java going, but since I am persistent I have the solution.

I followed these instructions and had the same issue. I dug into it deep checking on the Sun site and double checking everything close and here is how to make it work. I have three things for you to follow.

First things first go to the folder where you made your symbolic link and delete the one you created it will not work should be in
usr/lib/mozilla/plugins (I don't know how to edit the link so just recreate it).

Now follow the same instructions that you followed before to recreate the link except this time do the following:

ln -s /usr/local/bin/jre1.6.0_02/plugin/i386/ns7/libjavaplugin_oji.so

You will notice all you are doing is not putting this part of the command ./libjavaplugin_oji.so back in the link because having that gives the link the incorrect path. See original command below.


ln -s /usr/local/bin/jre1.6.0_02/plugin/i386/ns7/libjavaplugin_oji.so ./libjavaplugin_oji.so

You will now have Java working in Seamonkey, but you are not done if you have Firefox.

Somewhere in your folder structure you will have a Firefox folder. On my machine it is located /usr/local in that location there is a Firefox folder. In the Firefox folder there is another plugin folder. You need to follow the same instructions to create a symbolic link there just like you did in the mozilla/plugin folder.

Now you will have Java in Firefox.

There is one last thing though. If you happen to look on the Sun site to see their manual setup instructions they state in the path for the symbolic link to go to folder ns7-gcc29. There is a library in that folder with the same name as the one in the ns7 folder. It is a bigger file. It seems to work ok if you use it in the Seamonkey/Mozilla plugin folder but if you us it for the Firefox plugin folder as soon as you start to check if Java is installed your Firefox will crash.

Hope this helps others out.
Back to top
View user's profile Send_private_message 

Joined: 11 Sep 2007
Posts: 4

PostPosted: Tue 18 Sep 2007, 16:07    Post_subject:  HOWTO install Java the hard way
Sub_title: Hooray!


Many thanks Bluedogrun, MU and Bruce B.
You've all been really helpful.
I can now use just Puppy on my laptop to access my work PC (Sadly this has to run M$)

Back to top
View user's profile Send_private_message 

Joined: 19 Sep 2007
Posts: 2

PostPosted: Wed 19 Sep 2007, 11:25    Post_subject: one more problem...  


(First: sorry for my bad English... Wink )

Thank's for this very good and easy howto!
But I still have a problem:
I've installed Java and it works fine.
But when I restart PuppyLinux (It is installed on an usb-flash-device),
the symbolic link is ereased and Java doesn't work.
What can I do...?
Back to top
View user's profile Send_private_message 

Joined: 14 Sep 2007
Posts: 24

PostPosted: Wed 19 Sep 2007, 21:01    Post_subject:  

Thanks. It wasn't that hard at all. Even this newb could do it. Smile
Back to top
View user's profile Send_private_message 

Joined: 15 Aug 2007
Posts: 39

PostPosted: Thu 20 Sep 2007, 18:16    Post_subject:  

i get this error in the terminal...

Creating jre1.6.0_02/lib/rt.jar
Error: write on output file failed err=28
ERROR: Failed to unpack JAR file:


Installation failed. Please refer to the Troubleshooting Section of
the Installation Instructions on the download page.

any suggestions? i can't find the troubleshooting page at the java site.
Back to top
View user's profile Send_private_message 

Joined: 12 Mar 2007
Posts: 286

PostPosted: Thu 20 Sep 2007, 19:51    Post_subject:  

This is the only way I install java.BTW my biology teacher require this kind of procedure(sp) for our labs(we have to write our own).
I need help with my forum. LINK:http://www.programers.co.nr/
http://www.freewebs.com/programm/iframe.html is my gateway page...
Back to top
View user's profile Send_private_message Visit_website YIM 

Joined: 27 Jun 2005
Posts: 429
Location: VT USA

PostPosted: Tue 30 Oct 2007, 22:58    Post_subject:  

Great Tutorial,

I can't seem to locate the mozilla plugins directory in tmxxine however to get java working in Seamonkey 2.1.1 I tried all the obvious locations but it seems there has been a default change for some of these files in Puppy 3.x. I also couldn't locate flash9 there although it works in Seamonkey.

Edit: Sorry I should not work on computers when I have the flue, It was right where it belonged. I created a link in the same way and it works just fine.

I used the middle button and dragged the link (relative) to the firefox plugin folder after I installed Firefox and it worked perfectly.

Questions? Search Puppy Linux Answers with Google
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 

Joined: 27 Nov 2006
Posts: 112
Location: Brazil

PostPosted: Mon 12 Nov 2007, 11:34    Post_subject:  

I've followed all instructions step by step with no errors, but the test from Sun fails and it says that I have no java on my system.

I'm using puppy 3.01 from CD.

I've tested with seamonkey 1.1.2 (the default that comes in 3.01), 1.1.5 and 1.1.6.

I've also tested with java 1.6 update 2 and update 3.

I've inserted the link at:
/usr/lib/seamonkey-1.1.x/plugin (x is 2, 3 or 5),
/usr/include/seamonkey-1.1.x/plugin (x is 2, 3 or 5) and

I've also delete Cache and Javascript is enabled.

I've no Firefox on my system.

Any clue?

Thanks in advance


Linux user #388359 (http://counter.li.org/)
Back to top
View user's profile Send_private_message 

Joined: 27 Nov 2006
Posts: 112
Location: Brazil

PostPosted: Mon 12 Nov 2007, 16:40    Post_subject:  

I solved this issue with following:


"..but I discovered why. When I tried to follow sbaguz's advice, above, I clicked (in SeaMonkey) Edit-Preferences and then the + beside Advanced, and then Scripts and Plugins. Enable Javascript for Navigator was enabled. At first though, I did not realize that I also need to click "Edit-Preferences" and then click "Advanced" itself, not the expansion + beside it, to bring up the Enable Java checkbox. And check it."

and also doing the "ln -s" to the following locations:

I'm using seamonkey-1.1.6 and jre 1.6 update 3.

Hope this help others with same issue.



Linux user #388359 (http://counter.li.org/)
Back to top
View user's profile Send_private_message 

Joined: 20 Feb 2008
Posts: 2

PostPosted: Wed 20 Feb 2008, 08:18    Post_subject:  

to set it up so you can run programs like Azureus
you have to add the path to the java binary in /etc/profile, and also add the java home variable, something like:
export JAVA_HOME=/usr/local/bin/jre1.6.0_02

and don't forget to

open up the actual azureus executable.... open it up as text....
there are a couple of options right at the top.....
in the option to set the java dir, set it to wherever yer java is installed ..... keep in mind that it wants the fulll path to the java bin....
same with the azureus dir.....

I cut & pasted this from here:
After several hours trying i finally found this post l and it was a lifesaver. (I was about to give up on puppy.)

Thanks for the instructions about how to install java. It made installing java really easy.
Very Happy
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 2.2485s ][ Queries: 13 (1.8187s) ][ GZIP on ]