Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 13:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Trying to get Code::Blocks to run
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Fri 17 Aug 2007, 18:10    Post subject:  Trying to get Code::Blocks to run  

I have wxWidgets 2.8.4 installed, I downloaded a nightly build of Code::Blocks (www.codeblocks.org), but when I run from terminal I get
Code:

sh-3.00# codeblocks
codeblocks: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /usr/lib/libcodeblocks.so.0)

I checked in /usr/lib and libstdc++.so.6 is a symlink to libstdc++.so.6.3

Any ideas how to fix? I don't know what that error means.

TIA David
Back to top
View user's profile Send private message 
headfound


Joined: 24 Jun 2006
Posts: 343
Location: England

PostPosted: Fri 17 Aug 2007, 19:04    Post subject:  

I'm not sure, but from a quick google search, it looks like you need a newer version of gcc installed for it to work.

edit -
similar problem was encountered here (different program), might help?

http://www.murga-linux.com/puppy/viewtopic.php?t=9933

_________________
Download a better Computer Smile
Puppy Linux Song
altern8life
Back to top
View user's profile Send private message Visit poster's website 
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Fri 17 Aug 2007, 20:19    Post subject:  

I updated to libstdc++.so.6.0.9, now I get
Code:
sh-3.00# codeblocks
codeblocks: error while loading shared libraries: libstdc++.so.6: cannot handle TLS data


Maybe I should try an earlier version of codeblocks.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0379s ][ Queries: 12 (0.0034s) ][ GZIP on ]