Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 14:27
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Puppy 2.17beta available
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 4 [59 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
Firefox

Joined: 03 Nov 2006
Posts: 171
Location: UK

PostPosted: Mon 16 Jul 2007, 06:17    Post subject: puppy 2.17Beat
Subject description: First Impressions
 

Puppy 2.17Beta,
Using Xvesa on clean hda1, I installed as co-exist. Returns error 15 will not boot.
On looking at menu1st strings it thinks its a full hd install and doesnt provide the correct strings for booting.
Tried connect for dial up, recognised my ttys0 modem and dialled ok. When Seamonkey was started wouldnt allow connection to websites when url typed in.

Cleaned drive, tried full hd install on hda1.Xvesa had problem with menu whiteout and locked out had to reboot. Used xorgwizard and xwin to take me to 640x480 screen and used wizard to set to 1024.
Tried modem connect, found my modem and dialled but fell over when seamonkey called.
The dial string was diferent to the frugal install in that in had = signs in it.
Used wvdial153 and gnome-ppp to connect.
Installed EZ pup and found a couple of files missing but seams ok.
Back to top
View user's profile Send private message 
willhunt


Joined: 05 Oct 2005
Posts: 495

PostPosted: Mon 16 Jul 2007, 06:21    Post subject: date and time working great usa-indiana east
Subject description: another great puppy
 

Everything working here sofar Smile
installed seamonkey 1.1.2 gtk looking good again so far Smile

_________________
176 Icewm Themes Exclamation
vlc-0.8.6c-i586.pet
vlc-0.8.6c-i586.pet
Back to top
View user's profile Send private message 
Firefox

Joined: 03 Nov 2006
Posts: 171
Location: UK

PostPosted: Mon 16 Jul 2007, 06:28    Post subject:  

As an aside to my previous post puppy doesnt cross partition boundaries and search directories and folders does it??.Because on my hd I have hda2 which containes loads of puppy files.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7084
Location: Perth, Western Australia

PostPosted: Mon 16 Jul 2007, 08:10    Post subject:  

Kernel source SFS file is now on ibiblio (kernel-src_217.sfs):
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/sfs_modules-2/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7084
Location: Perth, Western Australia

PostPosted: Mon 16 Jul 2007, 08:19    Post subject: Re: puppy 2.17Beat
Subject description: First Impressions
 

Firefox wrote:
Puppy 2.17Beta,
Using Xvesa on clean hda1, I installed as co-exist. Returns error 15 will not boot.
On looking at menu1st strings it thinks its a full hd install and doesnt provide the correct strings for booting.
Tried connect for dial up, recognised my ttys0 modem and dialled ok. When Seamonkey was started wouldnt allow connection to websites when url typed in.

Hmmm, I'm surprised. That bug for a frugal install was fixed. Well, I'll test it again. Did you do this with a clean 2.17beta, no prior pup_save, and the pup_217.sfs and zrdv_217.sfs from 2.17alpha testing removed from the hard drive?

You used PupDial? Again, the same question re an old pup_217.sfs messing things up. If not, did the wvdial connection log show that negotiation with the ISP was successful?
Back to top
View user's profile Send private message Visit poster's website 
Firefox

Joined: 03 Nov 2006
Posts: 171
Location: UK

PostPosted: Mon 16 Jul 2007, 08:57    Post subject: Reply  

I deleted then reformated hda1 and wiped mbr. There was nothing on it except an empty lost& found file.

I just tried the connect icon and it works fine, using it now, Maybe a reboot was needed or maybe me pressing bittons to quick
Everything fine now.
Back to top
View user's profile Send private message 
Scoticus


Joined: 01 Jan 2007
Posts: 443
Location: Erskine, Scotland

PostPosted: Mon 16 Jul 2007, 09:14    Post subject: Puppy 2.17beta available  

Barry

There have been a number of posts on loading sfs files where things appear still be up in the air.

There are 3 posts :

OpenOffice, devx, -any sfs files not being merged or loaded

Placing sfs files in a frugal install

More problems merging sfs files.

where I and others are struggling. Therefore the question in relation to 2.17.

I was hoping that everything would fall into place easily as I have to get OO up and running after a HD crash and 2.16.1 was my main hope
Back to top
View user's profile Send private message 
kirk

Joined: 11 Nov 2005
Posts: 1436
Location: florida

PostPosted: Mon 16 Jul 2007, 10:34    Post subject:  

* The rt73-rt2570 module problem seems fixed.

* The clock being an hour slow is fixed.

* Still have pup_save.2fs being created on a ext3 partition. When rc.shutdown is running the final sanity check shows that the name of the save file is pup_save.2fs and the file system inside the pup_save file will be ext3.

* Encrypted pup_saves are mounted as ext2 and not fscked. A comment in the init script says "#forum feedback this takes to long when encrypted..." That's a mis-understanding. When I posted that, some assumed I was talking about an encrypted pup_save, but it was non-encrypted with a lot of files.

* The bcm43xx problem I reported for 217a is a non-problem. I tried it again last night and it worked. I had tried it a few times before and couldn't get it going. Don't know why. Sorry for the spam.

The ext/fsck problems are not new to 2.17. Looking good though.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Mon 16 Jul 2007, 12:45    Post subject: Upgrading difficulties?  

Hello, again (edit)

I think everything is mostly working now! Instead of trying to use the 2fs file from 2.17alpha with 2.17beta, I used the 2fs from the older NOP 2.16.1, thus doing a true version upgrade. Had to jiggle a few things, relocate icons, etc., but now Glipper works, and with the help of the upgrade moving some of the old cups dross out via /tmp/versioncleanup/ and removing the old ghostscripyt programs the new cups works too!

BTW I have stuck with Adobe Reader 5 in favor of epdfview!

Henry
---------------------------------------------------
I had written (disregard, I guess):

Two things, so far, I have trouble with in 2.17beta are Glipper and CUPS. Yes, they work fine in a fresh install! But it seems very hard in an upgrade to overcome the effects of previous use of Glipper and and 0.3 cups, which seem to be "uninstallable," at least without skilled surgery.

As a result, in the menu Glipper icons appear both for the regular and the new autorun choice. Problem is Glipper never returns after a reboot, even though the "glipper_on" file toggles as expected in root.

Cups works but only with the old, bulky 0.3 version previously used. Long term one expects the problem of the package installer having very old and very new items, mostly inadequately described, will pass. In the meantime, maybe someone can suggest a way around this.

Last edited by Henry on Mon 16 Jul 2007, 17:21; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
headfound


Joined: 24 Jun 2006
Posts: 349
Location: England

PostPosted: Mon 16 Jul 2007, 15:33    Post subject:  

Barry, i'll post this here as your blog gave a cgi error!
In the gamepup i just created, i put a small program in to pop a window up after the xorg/xvesa wizards saying ' welcome to puppy, Do you want to view a short introduction, yes or no'. 'Yes' opens dillo with the normal page, 'no' kills the script.
It might be worth considering as the majority of people trying the new releases are already users!
I used MU's wizardmaker, but i'm sure you could make something smaller and simpler.

_________________
Download a better Computer Smile
Puppy Linux Song
altern8life
Back to top
View user's profile Send private message Visit poster's website 
Leon

Joined: 22 Jun 2005
Posts: 236
Location: Slovenia

PostPosted: Mon 16 Jul 2007, 16:47    Post subject: Re: Puppy 2.17beta available  

Scoticus wrote:
There have been a number of posts on loading sfs files where things appear still be up in the air.

There are 3 posts :

OpenOffice, devx, -any sfs files not being merged or loaded

Placing sfs files in a frugal install

More problems merging sfs files.

where I and others are struggling. Therefore the question in relation to 2.17.

I was hoping that everything would fall into place easily as I have to get OO up and running after a HD crash and 2.16.1 was my main hope

I use one frugal install with Grub4dos on a hard disk FAT32 partition and another one booting from Wkpup2 floppy diskette on a usb flash drive VFAT partition. Both sfs files, devx_200.sfs and OpenOffice.org ooo-220.sfs mount from / directory without any problem in both installations.

I noticed that psubdir parameter works now for pup_save.2fs file and not for pup_xxx.sfs file as before.

Now it's possible to have all pup_xxx.sfs, devx_xxx.sfs, zdrv_xxx.sfs and pupswap.swp on / directory and all pup_save.2fs with the other Puppy files each in its own directory.

This is a part of my menu.lst:

# Boot Puppy Linux
title Puppy-p2.17b, idehd, bp217b, pup_save.2fs file created by Puppy-p2.17b
rootnoverify (hd0,4)
kernel /bp217b/vmlinuz root=/dev/ram0 PMEDIA=idehd psubdir=bp217b
initrd /bp217b/initrd.gz
boot

# Boot Puppy Linux
title Puppy-p2.17b, idehd, bp217b_, pup_save.2fs file upgraded from previous version
rootnoverify (hd0,4)
kernel /bp217b_/vmlinuz root=/dev/ram0 PMEDIA=idehd psubdir=bp217b_
initrd /bp217b_/initrd.gz
boot

# Boot Puppy Linux
title Puppy-p2.17b, idehd, bp217b0, create new pup_save.2fs
rootnoverify (hd0,4)
kernel /bp217b0/vmlinuz root=/dev/ram0 PMEDIA=idehd psubdir=bp217b0 pfix=ram
initrd /bp217b0/initrd.gz
boot
Back to top
View user's profile Send private message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Mon 16 Jul 2007, 17:36    Post subject:  

BUGS

1# Modem that is autodetected when booting to RAM is not detected when booting from FULL HD install. When I open pupdial and hit "probe for modem" it is found.

scratch this one, it's a behaviour not a bug -> 2# Using Full HD install, I uncompressed OpenOffice Squash. Did fixmenus and restarted X all was well. When I rebooted, entire pinboard vanished except for the office icons.

Last edited by John Doe on Mon 16 Jul 2007, 22:37; edited 1 time in total
Back to top
View user's profile Send private message 
Greatnessguru


Joined: 09 Jul 2007
Posts: 104
Location: rural McBain MI USA (near Cadillac MI)

PostPosted: Mon 16 Jul 2007, 18:56    Post subject: Urgent Sm/Ff/Tb security releases, this week.  

Heads up:

mozilla . dev . planning
http://groups.google.com/group/mozilla.dev.planning/
Weekly Status Meeting: July 16
"WeeklyUpdates/2007-07-16
Fx/TB 1.5.0.13/2.0.0.5
* Due a critical security bug (cross browser scripting) Fx/Tb2005 has become a firedrill release.
* A regression was found in Fx2005rc1 builds which caused a respin.
* Fx2005rc2 testing is in progress. We will have updates ready to test this evening.
* At this point the tentative release date is next Thursday (7/19), but we might be able to accelerate the release, as Fx2005 buils are ready/tested. This is to be discussed.
* Tb2005 will either be released at the same time or shortly after Fx."

SeaMonkey RCs:
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/candidates-1.1.3/

Note: no Sm 1.0.x.RCs since that branch is EOLed.

Thank you,
Eddie
Back to top
View user's profile Send private message Visit poster's website 
kirk

Joined: 11 Nov 2005
Posts: 1436
Location: florida

PostPosted: Mon 16 Jul 2007, 22:31    Post subject:  

Tried the kernel-src.sfs, when I tried building a driver (rt2570) it complained:

ERROR: Kernel configuration is invalid.
include/linux/autoconf.h or include/config/auto.conf are missing.


Also, not a Puppy problem, if geany is minimized and you right click to close it, X crashes.
Back to top
View user's profile Send private message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Mon 16 Jul 2007, 22:38    Post subject:  

scratch this one, it's a behaviour not a bug ->
wrote:
2# Using Full HD install, I uncompressed OpenOffice Squash. Did fixmenus and restarted X all was well. When I rebooted, entire pinboard vanished except for the office icons.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 4 [59 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1078s ][ Queries: 12 (0.0214s) ][ GZIP on ]