Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 23:27
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
2.14 beta SATA drive problem (solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
kirk

Joined: 11 Nov 2005
Posts: 1437
Location: florida

PostPosted: Mon 12 Feb 2007, 20:15    Post subject:  2.14 beta SATA drive problem (solved)  

When booting from CD and your pup_save file is on a SATA drive, PUPMODE is set to 13 instead of 12. Here's my PUPSTATE:

PUPMODE=13
PDEV1='hdc'
DEV1FS='iso9660'
PUPSFS='pup_214.sfs'
PUPSAVE='ext3,sda4,/pup_save.2fs'
PMEDIA='idecd'
SATADRIVES='sda '
#these directories are unionfs layers in /initrd...
SAVE_LAYER='/pup_ro1'
PUP_LAYER='/pup_ro2'
ZDRV='iso9660,hdc,/zdrv_214.sfs'

Here's some history:

http://www.murga-linux.com/puppy/viewtopic.php?search_id=1121756263&t=14054

Last edited by kirk on Mon 19 Feb 2007, 22:25; edited 1 time in total
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Tue 13 Feb 2007, 03:44    Post subject:  

Okay, I'll examine the logic of how PUPMODE variable is assigned in
that case, see if I can fix it.
Back to top
View user's profile Send private message Visit poster's website 
kirk

Joined: 11 Nov 2005
Posts: 1437
Location: florida

PostPosted: Mon 19 Feb 2007, 22:25    Post subject:  

Fixed in 2.14 . Thanks Barry!
Back to top
View user's profile Send private message 
The Alchemist

Joined: 18 Feb 2007
Posts: 9

PostPosted: Thu 31 May 2007, 02:37    Post subject:  

This bug is back in 2.16....

The Alc
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Thu 31 May 2007, 06:42    Post subject:  

Quote:
Dougal, with help of others, did figure out how to distinguish between a USB Flash and hard drive, I think it is a 'removable' flag -- Dougal can confirm this.
Anyway, it is not implemented in 2.16. If the differentiation between the two types is consistent when I get to test on some more hardware, I am targetting to include in 2.17. So then it should finally work right, 12 instead of 13.

If I recall rightly, Dougal found this 'removable' flag in /sys, which currently is not mounted in the initrd. So, I wonder if the same info is available in /proc?

My mind was not focussed, been sitting in front of this screen too long today. I posted the above, but it has nothing to do with this thread.
Puppy is able to detect which drives are SATA at bootup, so should be able to bootup with PUPMODE=12. Something went wrong with the logic between 2.14 and 2.16. I'll check it out.
Back to top
View user's profile Send private message Visit poster's website 
The Alchemist

Joined: 18 Feb 2007
Posts: 9

PostPosted: Wed 12 Sep 2007, 05:52    Post subject:  

This bug is still in 2.17...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0489s ][ Queries: 12 (0.0072s) ][ GZIP on ]