Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 04:21
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
2.16 Final can not remove icons on desktop * SOLVED *
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Author Message
PhilCoo

Joined: 24 Mar 2007
Posts: 39
Location: Staffordshire, UK

PostPosted: Sun 20 May 2007, 12:06    Post subject:  

This is from the bootconfig file:

PREVUNIONRECORD='2007-05-19-21-02 pup_216.sfs '
LASTUNIONRECORD='2007-05-20-07-21 pup_216.sfs '

Will try the mod to rc.update on line 280 as well as reverting to the original rc.update before I changed text.

Phil
Back to top
View user's profile Send private message 
Grizz

Joined: 20 May 2007
Posts: 15

PostPosted: Sun 20 May 2007, 12:07    Post subject:  

First post.
2.16 is fantastic. BUT
I was having the same icon problem booting from a multisession cd. HOWEVER
I now boot from an SD card stuck in a usb adapter. The icons stay the way I position them, and the deleted icons don't come back. I have no idea why, but it works.

Hope this helps someone.

Grizz
Back to top
View user's profile Send private message 
PhilCoo

Joined: 24 Mar 2007
Posts: 39
Location: Staffordshire, UK

PostPosted: Sun 20 May 2007, 12:20    Post subject:    

Have just re-booted with the rc.update as per original but line 280 altered as per Barry's post,and the icons are correct,no extra icons that had been deleted.

Thanks again Barry. Very Happy Very Happy Very Happy

Phil
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 20 May 2007, 21:45    Post subject:  

Ah ha! This is the problem:
PREVUNIONRECORD='2007-05-19-21-02 pup_216.sfs '
LASTUNIONRECORD='2007-05-20-07-21 pup_216.sfs '
....you are running a multisession CD/DVD!

Under normal circumstances, those two variables should be identical, but it falls down for the multisession CD as the last-loaded folder is different each time. The two variables are only supposed to be different when the SFS layers have changed.

Okay, I'll post a fixed rc.update here soon.
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 20 May 2007, 22:03    Post subject:  

Okay, try this.
Download and gunzip it:
# gunzip rc.update.gz
then copy it to /etc/rc.d/rc.update

then delete an icon on desktop, reboot.
rc.update.gz
Description 
gz

 Download 
Filename  rc.update.gz 
Filesize  4.65 KB 
Downloaded  288 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
PhilCoo

Joined: 24 Mar 2007
Posts: 39
Location: Staffordshire, UK

PostPosted: Mon 21 May 2007, 03:19    Post subject:  

Just tried this update on new cd to eliminate any mistakes on my part, back to same as before with icons coming back after being deleted.

Phil
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 21 May 2007, 05:22    Post subject:  

No, surely not!
Okay, try this one. Gunzip and copy it to /etc/rc.d, then delete an icon and reboot. This one writes some information to /tmp/test.log -- could you please post the contents of that file.
rc.update.gz
Description 
gz

 Download 
Filename  rc.update.gz 
Filesize  4.7 KB 
Downloaded  311 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
PhilCoo

Joined: 24 Mar 2007
Posts: 39
Location: Staffordshire, UK

PostPosted: Mon 21 May 2007, 05:58    Post subject:  success  

contents of test.log

LASTUNIONRECORD=2007-05-21-10-52 pup_216.sfs PREVUNIONRECORD=2007-05-21-08-10 pup_216.sfs
xLASTUNIONRECORD=pup_216.sfs xPREVUNIONRECORD=pup_216.sfs
NEWPVERSION=216 OLDPVERSION=216

This has worked with no extra icons appearing that had been deleted previously.

Thanks for your assistance Barry

Phil
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 21 May 2007, 20:03    Post subject:  

Phil, ...er, the last two rc.updates I posted are identical, just the second one outputed some info to test.log. So the first one I posted will work just the same.
Back to top
View user's profile Send private message Visit poster's website 
PhilCoo

Joined: 24 Mar 2007
Posts: 39
Location: Staffordshire, UK

PostPosted: Tue 22 May 2007, 05:04    Post subject:    

Barry .. Started from scratch again with new cd burnt in Puppy this time not Windoze,
1, boot cd,remove icons,save and reboot,icons re-appear
2, apply rc.update, remove icons,save and reboot, icons stayed away

I am puzzled,must be a bad burn on previous cd's.

Thanks for your persistance

Phil Very Happy Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0544s ][ Queries: 13 (0.0043s) ][ GZIP on ]