Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 02:42
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Touchpad tap not working Puppy-216
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
wdef

Joined: 13 Apr 2007
Posts: 91

PostPosted: Mon 21 May 2007, 11:29    Post_subject:  Touchpad tap not working Puppy-216  

No obvious errors in Xorg.0.log..

But touchpad tapping is not working in lieu of a left-click.

This is on a HP dv4000 series laptop.

Something missing from Xorg.conf to enable this?
Back to top
View user's profile Send_private_message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Mon 21 May 2007, 15:37    Post_subject:  

I tune my xorg.conf like this for touchpad:

Option "MaxTapTime" "225"
Option "MaxTapMove" "225"

First one is tap, second is "double tap lock" for moving windows.

also like this right now:

Option "MinSpeed" "0.20"
Option "MaxSpeed" "0.25"
Option "AccelFactor" "0.010"

Everyone is going to like it a bit different I think.

Was also going to try to observe this with different resolutions to see if it made a change to behaviour in itself.

*note. If you remaster the wizard, there are TWO places where you change that. Originally I did a quich search and just changed the first. It didn't work Embarassed
Back to top
View user's profile Send_private_message 
wdef

Joined: 13 Apr 2007
Posts: 91

PostPosted: Mon 21 May 2007, 15:56    Post_subject:  

Option "MaxTapTime" "225"
Option "MaxTapMove" "225"

did it.

Puppy had MaxTapTime set to 0.

That saved me some man page wading, thanks.

Should Puppy's auto running of xorgwizard during boot set this up by itself though?

Tapping worked fine in previous Puppies.
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 21 May 2007, 20:22    Post_subject:  

The problem is that "tapping" drove some of us nuts. On my laptop, it is too sensitive, if my fingers get accidentally onto the touchpad, odd things suddenly happen. So I think Dougal and kirk configured the Wizard with that in mind.
Back to top
View user's profile Send_private_message Visit_website 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Tue 22 May 2007, 01:22    Post_subject:  

Remember I mentioned the tapping was too sensitive when you were building 2.x?

I think you'll find that with the Synaptic driver loaded tapping is ok again and one doesn't get as many "random clicks" while moving the cursor.

Not that I'm advocating a change, everyone is going to end up liking something different (I had to change speed and acceleration myself to get it like I like [still working on it]).

Just wanted to make sure you gave it a second chance with the new drivers. I find it's much nicer to give a thump on the pad sometimes instead of listening to the click of the button. The button will wear out eventually also, so I thump for now.
Back to top
View user's profile Send_private_message 
wdef

Joined: 13 Apr 2007
Posts: 91

PostPosted: Tue 22 May 2007, 13:52    Post_subject:  

I agree - tapping is more controlled with the synaptics driver.

I don't seem to need to change any other touchpad settings (though I spent a lot of time getting these right with Fedora).

Tapping worked out of the box without the synaptics driver too (no scrolling though), but I agree it did lack control - esp with the earlier rox version I found windows flying open seemingly by themselves. It was very annoying. That improved when I tried one of the newer rox-2.5 packages, configured differently I suppose.

In 2.16, there's no control problem at all with tapping.

Since I tend to thump my notebook keyboard like Leon Russell in the Mad Dogs and Englishmen tour, tapping reduces a lot of wear on the left click pad (and my wrists).
Back to top
View user's profile Send_private_message 
dcg

Joined: 13 Dec 2006
Posts: 28

PostPosted: Sat 24 Nov 2007, 02:11    Post_subject: "Touchpad on Acer"
Sub_title: "Tapping touchpad doesn't work in 3.01"
 

I am an old man but pretty new to puppy.I have been troubled with
nonfunctioning Acer touchpad, and thanks to reading your posts the
problem is solved.Thanks again to John Doe, wdef, and of course B.
Kauler and all administrators.
Thanks Kindly....dcg
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 24 Nov 2007, 06:17    Post_subject:  

BarryK wrote:
The problem is that "tapping" drove some of us nuts. On my laptop, it is too sensitive, if my fingers get accidentally onto the touchpad, odd things suddenly happen. So I think Dougal and kirk configured the Wizard with that in mind.
What is driving me nuts for the moment is the Touchpad itself.
Having a Thinkpad R40 with a trackpoint, touchpad is interfering and I would like to disable it.

Only thing I found to do that is the syndaemon an synclient for the synaptic driver.

As far as I can see it isn't implemented in Puppy.

Could this be done?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
laptopnewbee

Joined: 19 Aug 2006
Posts: 165

PostPosted: Mon 26 Nov 2007, 16:38    Post_subject:  

and now i know how to kill that annoying thing on my laptop while in puppy.

edit:
now that i have read the rest of the thread i can offer a suggestion for anyone who wants to disable the pointer control. because i sometimes lose function of my usb mouse due to other usb devices causing issues, it turns out that the ability to fall back to the touch pad for mousing is useful. i'm currently looking for a bit of plastic that i can make into a decent looking cover for the pad. this will prevent stray fingers from activating it in error.

_________________
so much to learn, so late a start.
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 26 Nov 2007, 18:42    Post_subject:  

This http://www.debuntu.org/2006/06/25/70-how-to-disabling-your-touchpad-while-typing seems to be a solution, but synclient and syndaemon aren't implemented.
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
laptopnewbee

Joined: 19 Aug 2006
Posts: 165

PostPosted: Tue 27 Nov 2007, 12:41    Post_subject:  

Béèm wrote:

This http://www.debuntu.org/2006/06/25/70-how-to-disabling-your-touchpad-while-typing seems to be a solution, but synclient and syndaemon aren't implemented.

looks like something to tinker with if the software can be put in place. now to figure out where to get it if it's not already there.

_________________
so much to learn, so late a start.
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 27 Nov 2007, 14:11    Post_subject:  

No this syndaemon and synclient are not in Puppy.
I did a search. I don't know if they can be compiled separately or that they have to be included in a kernel compile.

Nobody seems to be able to answer questions about this.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
lgoldstar

Joined: 13 Dec 2007
Posts: 1

PostPosted: Thu 13 Dec 2007, 01:09    Post_subject:  

Just upgraded to 3.01 and lost touchpad functionality. This solution worked great and everything is back to normal.

Keep up the great work on this excellent distro!

-L
Back to top
View user's profile Send_private_message 
Swarup

Joined: 20 May 2008
Posts: 219

PostPosted: Thu 22 May 2008, 20:01    Post_subject:  

John Doe wrote:
I tune my xorg.conf like this for touchpad:

Option "MaxTapTime" "225"
Option "MaxTapMove" "225"

First one is tap, second is "double tap lock" for moving windows.


I made these above changes in my xorg.conf, but my touchpad tap still hasn't started working. Any ideas what else I could try? I use a year 1999 Gateway 9300 laptop.
Back to top
View user's profile Send_private_message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Thu 22 May 2008, 20:30    Post_subject:  

Aitch wrote:
Hi darkman

Try typing in a console:-

modprobe evdev

and then restart x-server from the shutdown entry in menu (menu button).

If the track pad starts working after the "modprobe evdev" command, then evdev module is not being loaded at startup.
Open the file /etc/rc.d/rc.local in a text editor and check to see if the last line of the file is:"modprobe evdev". If it is not, then enter it.

There was a recent post

Ray MK wrote:
Try this - it works on both my laptops.

Go to - /root/etc/X11/xorg.conf --- Scroll way down to

Where it says Option MaxTapTime

the setting now is probably set to 0 --- change the setting to 220

Save the file and exit - Magic - mouse tap function works

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "220" <<<<<<<<<<<<<<<<<<<<<<
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.10"
Option "MaxSpeed" "0.30"
Option "AccelFactor" "0.0030"
Option "SHMConfig" "on"
#Option "Repeater" "/dev/ps2mouse"
EndSection


Hope that does it - regards Ray MK


Good Luck

Aitch


Pizzasgood wrote:
If running modprobe evdev again and then restarting the X server fixes it again, you just need to edit the file /etc/rc.d/rc.local and add that command to the end of it. That way the command will be run every time you boot, before X is started.

You should be able to tweak the sensitivity by changing the numbers in xorg.conf that Aitch referenced. The important ones look like "MinSpeed", "MaxSpeed", and "AccelFactor". Then restart the X server to check.

May be a good idea to make a backup copy of xorg.conf before tweaking it, and then make another after you're finished (so you don't need to remember exactly what you changed).


Aitch:)
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0847s ][ Queries: 12 (0.0037s) ][ GZIP on ]