Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 14:25
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
HOWTO : Share files and folders between Computers
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 6 [87 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
r__hughes

Joined: 13 Apr 2006
Posts: 342
Location: Canada

PostPosted: Thu 28 Sep 2006, 10:43    Post subject:  

fluxit wrote:
wget -r url will recurse directories. ---------

Thanks - I'll look into that.
Back to top
View user's profile Send private message 
ICanoe2


Joined: 03 Jun 2006
Posts: 26
Location: Niagara-on-the-Lake, Canada

PostPosted: Sun 12 Nov 2006, 20:54    Post subject: Help - I'm really thick!  

I have tried following rarsa's instructions and gone through this thread numerous times however with limited success in file sharing.

Problem 1 - Seeing my XP machine
Linneighbourhood works great => no problems
In Lineighbourhood I can see the following
Service: //DININGROOM/Denise
Mountpoint: /root/mnt/DININGROOM/Denise
Command line => problems
I tried the following commands
smbmount //192.168.0.188/Denise/mnt/DININGROOM
result = cannot resolve mount point
smbmount//192.168.0.188/Denise/mnt/DININGROOM
result = no such file or directory
I'm still not sure if there should be a space between smbmount and // Confused

After reading further in the post I tried various permutations of the smbmount command as above with the exception being that I replaced the IP address with DININGROOM (the computer name) with results similar to the above.
HELP PLEASE
Embarassed

Problem 2 - Seeing Puppy via my XP machine - SOLVED (see below)
I again followed the instructions in the thread.
I tried to add a user named "localuser" via the following command
adduser -h/root localuser
result = login already in use
I tried to add a user named "share" via thr following command
adduser -h/root share
result = SUCCESS Very Happy
I then added name and password and optimism was high.
I went to my XP machine and explored to this location but the only thing I can see is the readme file called betaftpd.anon
How do I see my files and where do I enter this username and password information?
PLEASE HELP! Confused

*After posting I played some more on my XP machine and found "Login as... in the file menu. Oops Embarassed
Hurray, I can see all of my files both ways. No it's just the command line so that I can make this available with start-up
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 1999
Location: Maine, USA

PostPosted: Mon 13 Nov 2006, 10:49    Post subject:  

If your xp machine is //192.168.0.188/Denise
and you have a directory /mnt/DININGROOM on your puppy box.

Then:
Code:
smbmount //192.168.0.188/Denise /mnt/DININGROOM

should work.

note the <space> after Denise.

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 13 Nov 2006, 15:13    Post subject:  

Very nice Howto, it should be added to Linuxneighbourhood in Puppy.

I have a problem though:
Connecting to the XP-machine works fine, and I can copy files among Puppy and XP.
But special characters are shown wrong.

As this is a common problem in applications based on Gtk1 (Rox-filer 1.2), I tried it in the Gnome-Filemanager Nautilus (that can display unicode, as it is based on Gtk2).
Still no joy, even after installing some truetype-fonts (the free dejavu, and tahoma from Windows).

In Nautilus, I can create a file like test-.txt.
But in Windows, it displays as test-.txt.

If I create such a file test-.txt in Windows, Nautilus displays it as
test2-.txt
So the "" is replaced with a unicode-placeholder "0081".

Does someone know, if there maybe is a parameter that can be used to mount the share with a different charset or codepage?

Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 14 Nov 2006, 16:44    Post subject:  

ok, without linneighbourhood I found a solution:

smbmount //MACHINE/folder /root/mnt/MACHINE/folder -o guest,codepage=cp437

I'm writing a script at work that scans the network for shares, and then automatically mounts all available folders in /root/LocalNetwork/ (those without password). Will continue/finish it in 2 days I think.

this is how the script looks like at moment:
http://dotpups.de/tests/Muppy-SMB
It does not work at moment, as I added some test-code, and were interrupted then.

Mark
Back to top
View user's profile Send private message Visit poster's website 
gliezl


Joined: 06 Aug 2005
Posts: 322
Location: Manila

PostPosted: Tue 14 Nov 2006, 22:35    Post subject:  

Wow, it's an improved smblogin script.
Just tell me Mark when its ready, I'll be glad to test it. Smile

_________________
"If you have knowledge, let others light their candles in it."
~Margaret Fuller

Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Wed 15 Nov 2006, 03:17    Post subject:  

Very interesting, Mark. Your script looks like a good example of what can be done with PuppyBasic.

Hmm, I have been planning to write a script that will run on a MicroClientJr with a remote control interface to turn house lamps on and off. PuppyBasic looks like it might be a good candidate for the job! Smile

Paul

_________________
Testing Puppy since v0.9.2 - my desktop OS since v1.0.7
Running SlaxerPup-4.12 - Puppy with a Slackware 12.2 heart Cool
Back to top
View user's profile Send private message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Wed 15 Nov 2006, 04:05    Post subject:  

MU wrote:
Does someone know, if there maybe is a parameter that can be used to mount the share with a different charset or codepage?


This looks pretty complicated. You are getting into some RFC level stuff here.

Here are some links I stumbled on:

http://samba.org/samba/docs/man/Samba-HOWTO-Collection/unicode.html

http://www.adaptec.com/en-US/_whitepapers/tech/etherstor/unicode_wp.htm#4.1

http://lists.samba.org/archive/samba-technical/2005-July/042008.html

http://lists.samba.org/archive/samba-technical/2005-July/042010.html

http://lists.samba.org/archive/jcifs/2003-January/001721.html

http://lists.mplayerhq.hu/pipermail/mplayer-users/2003-July/034818.html

Perhaps it's been worked out since then? Last time I got down to the socket/character level was about three years ago.

It sure would be great to make sure Puppy had this worked out, if it's a problem.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 18 Nov 2006, 08:28    Post subject:  

my script will not work because of a logical error Confused

I wanted to use netstat, to determine the PCs, that are in the network.
Then I could try to run smbclient on the found IP-adresses, to look up, if there are Shares.
This worked during my first test, as I already were connected to the XP machine using LinNeighbourHood or smbclient.
But if you don't run those first, the XP-machine is not visible in netstat.
So of course my "auto-detection" can not work.

I found no solution yet.
Only a hint, that in KDE you can type smb:/ in Konqueror, to list all Windows-shares.

So it must be possible somehow, the question is:
how do I do it without the KDE-mechanisms?

More googling and tests are required, don't expect a quick solution.

Mark
Back to top
View user's profile Send private message Visit poster's website 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Sat 18 Nov 2006, 09:36    Post subject:  

maybe this would help:
http://justlinux.com/forum/showthread.php?t=127591
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 18 Nov 2006, 15:17    Post subject:  

Thanks G2, as usual a brilliant suggestions Smile
I found it in the samba-dotpup from sunburnt.

Runs without error after creating a symlink, so you don't need to install the whole huge dotpup.

You can get it here:
http://dotpups.de/dotpups/Network/samba-utilities/

I will test it on monday at work.

Thanks!
Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 20 Nov 2006, 12:04    Post subject:  

no, findsmb did not work either.

But it seems that "smbtree" can be used.

./smbtree -N| tr -s " "|cut -f2|grep '\\'

This will list the host.
example:

Code:
sh-3.00# ./smbtree -N| tr -s " "|cut -f2|grep '\\'
\\TORSTEN
sh-3.00#


To find the folders:
Code:
sh-3.00# ./smbtree -N| tr -s " "|cut -f3|grep '\\'
\\TORSTEN\Kyocera
\\TORSTEN\Dokumente
\\TORSTEN\C
\\TORSTEN\Exceldateien
\\TORSTEN\HPOffice
\\TORSTEN\print$
\\TORSTEN\SharedDocs
\\TORSTEN\IPC$
sh-3.00#


I uploaded the binary.

Topic continues in an own thread:
Muppy-SMB to find and mount Windows shared folders
http://www.murga-linux.com/puppy/viewtopic.php?t=12945

Mark
Back to top
View user's profile Send private message Visit poster's website 
gabriel_007

Joined: 25 Feb 2006
Posts: 23
Location: Warsaw

PostPosted: Mon 12 Mar 2007, 18:09    Post subject:  

Dear Friends
I tried to follow these steps once again after my xp installations and upgrading to puppy 2.14 (to let puppy see a windows share folder). LinNeighborhood displays this after I try to scan as user:

Quote:
Error returning browse list: NT_STATUS_OK


I tried to google this, but information I found is simply too complicated for a casual user like me. Could someone be so kind and help me with this? Thank You very much in advance.
Back to top
View user's profile Send private message 
giac_fab

Joined: 25 Jan 2007
Posts: 114

PostPosted: Sat 12 May 2007, 09:22    Post subject:  

Does exist a way to mount puppy share into /mnt/ ????

I have a puppy pc with video files and a pc (also with puppy) connected to my tv; I want stream the video files without download it, with ftp I must download the file before open it ........

_________________
Embarassed I know, my english is very bad Embarassed
Give a man a fish and he eats for a day, teach a man to fish and he eats for a lifetime.
Back to top
View user's profile Send private message 
sunburnt


Joined: 08 Jun 2005
Posts: 5009
Location: Arizona, U.S.A.

PostPosted: Sat 12 May 2007, 15:35    Post subject:  

Hi giac_fab; I assume you want to stream from the Puppy PC to other local PCs?
One way is to install the Samba server, Puppy & Win. PCs can use the shares.
MU's package is: Muppy-SMB
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 6 [87 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0914s ][ Queries: 13 (0.0055s) ][ GZIP on ]