Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Aug 2014, 14:42
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
WG511 success
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
klsmith

Joined: 11 Apr 2007
Posts: 1

PostPosted: Wed 11 Apr 2007, 11:49    Post subject:  WG511 success
Subject description: Noob success WG511 after research
 

First let me say thanks to all the contributors on this forum. I also hope that fellow noobs will take heart knowing that even difficult problems can be fixed, especially if you research. I had decided to put Linux on a Sony Vaio laptop (PCG FX- 190) and use a Netgear WG511v2 (Made in Taiwan). I installed SAM and was able to bring the adapter up immediately using ndiswrapper. I later decided to install Puppy 2.15CE and was able to do the same thing there. An unimportant glitch forced me to reinstall SAM which required me to reinstall Pup. SAM worked but Pup didn't. Knowing that I already had it working in SAM and that it had worked BEFORE in Pup was madening. I worked on it for days, doing reinstalls several times, always with SAM yes, Pup no. (There is much literature about the many apparent different versions of the same named product from Netgear, but I found most, if not all of it to be just a distraction from the fact that I already had it up and running in SAM and previously in Pup.) What had changed or what had I done different in Pup that first time? I will never know for sure but I think it had to do with bringing up wlan0 up first rather than eth0.

In any case, and with special thanks to tempestuous and cobelloy, I did this:

1 - Copy the WG511v2 files to the root directory (possibly an act of horror to some, but so I could navigate to it easily--I find the file structure nfamilliar and difficult, coming from Winland) from here:
http://www.parseerror.com/cache/drivers/WG511v2/WG511v2-cd/Driver/Windows%20XP/
(Of course having the Netgear disk would have helped, but . . .)

2 - Bring up Pup without eth0 in the picture by first adding ndiswrapper, then RELOADING my eth0 entry (in my case eepro100) and unloading it. Pup will only unload the LAST entry loaded even if the other entry (ndiswrapper) was a failure while IT was a success.

3 - I did a right click and selected Open terminal here while in the Windows XP directory.

4 - In the terminal I typed "ndiswrapper WG511v2.INF" (carful about case), to load it manually, bypassing the GUI method, though I have no idea why it WOULD be different, but it was.

5 - I typed "ndiswrapper -l" and got back:
wg511v2 driver installed, hardware present

6 - I typed WAG and followed the instructions to success. (My difficulties were never with the essid or encryption key--just bringing the dang think up.)

Hope this helps, and thanks again to all,
klsmith
Back to top
View user's profile Send private message 
Ardee

Joined: 29 Aug 2006
Posts: 58

PostPosted: Thu 03 May 2007, 09:38    Post subject:  

I was very pleased to eventually find this post. I'm using 2.14 with the WG511v2 card, and used the Network setup wizard to install ndiswrapper, which was reported as installed OK. The wizard still saw no active port, though. Once I ran ndiswrapper in the directory holding the .inf file wlan0 appeared, and I continued to set it up successfully with the wizard.

Much thanks to klsmith.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0419s ][ Queries: 12 (0.0038s) ][ GZIP on ]