Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 22:07
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Can see wireless networks, can't connect to routers (Solved)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 24 Aug 2005
Posts: 2
Location: USA

PostPosted: Wed 24 Aug 2005, 21:09    Post_subject:  Can see wireless networks, can't connect to routers (Solved)  

Recently, I installed Puppy 1.0.4 Mozilla as a MultiSession Live-CD on my Dell 600m laptop and I have been amazed at how well everything works! Kudos for creating such an easy and thin OS! The usage model of only having to carry a CDR around, as opposed to a whole system, is very appealing.

Had a question about configuring my wireless PCMCIA card to connect to my wireless router. My install is vanilla, except for adding Bladehunter's WiFi Beta and the WAG DotPup. These succeeded in enabling the Dell Truemobile 1300 wireless card as determined by #modprobe ndiswrapper, #dmesg, which generates output similar to the help file. IWCONFIG results also look good, except the number by invalid misc is always in the hundreds to thousands. What does this indicate?

I have tried the edits to wireless.conf, wireless, and rc.local as described in the help files, with no luck. The WAG application has been a great help, the scan reveals up to 5 networks. But I cannot connect to either of my routers (not using at same time), or those of my friendly neighbors, even when using DHCP.

As a newbie to Linux, I was wondering if there is any general wireless help out there? Searches reveal many small fragments and it is hard to understand which file edits are applicable (outside of the DotPup READMEs) or what they actually do. In other words, very tactical and I'm not understanding the strategy.

Two other questions--

1) At what point(s) during the WiFi DotPup install do I need to reboot?
2) One of my routers is marked as compatable with Linux, the other is not (can't connect to either). Does this actually make a difference, or is that for configuring the router only?

Thanks in advance for any help! It is greatly appreciated!
Back to top
View user's profile Send_private_message 

Joined: 20 Aug 2005
Posts: 175

PostPosted: Thu 25 Aug 2005, 08:22    Post_subject:  

I can't help you with the Wifi dotpup.

You are running the latest version of WAG, correct? (ver 0.2.5) Older versions slipped up on APs with spaces in the name. And you're only trying to connect to unencrypted networks, right?

I am a little surprised that scanning works, but connection doesn't. Scanning seems to be the variable, and I am putting together a list of cards which don't support it.

What are you clicking to connect? My typical pattern:

Turn dhcpcd off (if it isn't already)
Reseat twice
Scan, connect
Turn on dhcpcd

Messing with dhcpcd at the wrong time can make things go a little screwy.
Back to top
View user's profile Send_private_message 

Joined: 24 Aug 2005
Posts: 2
Location: USA

PostPosted: Thu 25 Aug 2005, 22:40    Post_subject: Now connected!  

Thanks Keenerd! Reseating twice seems to have fixed this.

For anyone reading this, here are the exact steps I used. There are a few other differences than previous attempts.

1) Installed Keenerd's WAG application and identified the slot. Edited the file which opens to include ndiswrapper and use wlan0, and my routers default IP. I have many neighbors with networks and need to distinguish mine.
2) Installed Bladehunter's WIFi Beta and edited rc.local to include the reference to rc.wireless as described in the README
(note) On previous failed attempts, had reversed the order of these, and typically didn't start step 2 until already trying/killing DHCP and the PID file and usually trying various configuration edits, iwconfig settings, and ifconfig. This attempt was much cleaner.
3) De installed the Morizot firewall since these firewalls may interfere with network. Not thrilled about doing this. In hindsight, maybe this was the issue the whole time.
4) Opened WAG as described in the README
5) Reseated, Ejected, reseated the card.
6) Ran the modprobe toggle (this may have been before step 5, cannot remember)
7) My network appeared in WAG, IWCONFIG, and IFCONFIG
Cool Ran DHCP
9) Removed LAN cable
10) Ping succeeded, looking good!
11) On the net with wireless

Next steps-- configure it work upon boot, and then enable WEP on the network. Will require figuring out configurations, but worth it for the (minimal) security

Thanks everyone who has shared so much helpful information, especially Bladehunter and Keenerd for great applications with documentation!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0460s ][ Queries: 12 (0.0034s) ][ GZIP on ]