Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 02:36
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
How to install opensound.com drivers
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
catfish

Joined: 11 Apr 2007
Posts: 6

PostPosted: Wed 11 Apr 2007, 00:29    Post subject:  How to install opensound.com drivers  

I'm new to Puppy, running 2.15CE and loving it! One thing I haven't been able to do is get sound out of my semi-pro card, an M-Audio Delta44. They have opensound.com do their Linux drivers, and so I downloaded their RPM for kernel 2.6 (hoping that's the right one... extensive searching didn't help me). I tried installing it with rpm -i, but no luck.

Is there any way to do this? From what I understand, these drivers are the only way to get my soundcard running under Linux.

Thanks in advance!
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Wed 11 Apr 2007, 02:07    Post subject: Re: How to install opensound.com drivers  

catfish wrote:
I tried installing it with rpm -i, but no luck.

Is there any way to do this? From what I understand, these drivers are the only way to get my soundcard running under Linux.

Puppy 2.15CE comes with the CLI utilities unrpm and undeb. If you open a console and navigate to the folder with your rpm file you should be able to simply type unrpm file.rpm and it will expand the contents to that directory for you. You should also be able to click on the RPM file in Rox and it should expand just like a .tar.gz file.

Then you can see where the files need to be placed and place them there manually.

Hope that helps.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Thu 12 Apr 2007, 07:00    Post subject:  

Puppy's ALSA sound drivers fully support your card. Your driver is snd-ice1712.
Why install an old OSS audio driver?

If your card is not automatically detected at boot, run the sound wizard (alsaconf).
Back to top
View user's profile Send private message 
catfish

Joined: 11 Apr 2007
Posts: 6

PostPosted: Fri 13 Apr 2007, 13:12    Post subject: Thanks to both of you  

Thanks to both of you for these tips. I didn't know how Puppy handles RPMs, so this is quite useful. I assume this means that the RPM command isn't a full RPM... is this so?

Also, I had no clue that ALSA supports the Delta 44. I guess the fact that the manufacturer, M-Audio, refers people to Opensound led me to believe that this is the only thing that works with the card.

Cheers!
Back to top
View user's profile Send private message 
catfish

Joined: 11 Apr 2007
Posts: 6

PostPosted: Fri 13 Apr 2007, 13:16    Post subject: One more question  

When I did RPM -i on the OSS RPM, some files seem to have been created, but RPM -u seems to do nothing. Would it be safe to eliminate all files matching *oss (at least those that seem to be related to sound -- I obviously wouldn't delete a file named "Moss Cultivation")?
Back to top
View user's profile Send private message 
catfish

Joined: 11 Apr 2007
Posts: 6

PostPosted: Fri 13 Apr 2007, 13:51    Post subject: Almost there  

When I went to AlsaConfig it turns out that my Delta was already there, with the right driver! It just wasn't selected, because the default onboard sound had gotten priority.

I still am not getting sound, though. Here's how I have things set up:

ALSA
- snd-ice1712 drivers installed

XMMS
- ALSA 1.2.10 output plug-in selected (libALSO.so)
- Device settings / Audio device: Default PCM OR M-Audio Delta 44
- Device settings / Mixer: M-Audio Delta 44
- Mixer device: Tried several (there are almost 20!)

MIXERS
- Puppy Volume Mixer: Everything at full blast
- ZMixer: PCM at 100%, everything else (including Master) is at 0% and I can't change it.

Regardless of the XMMS settings I use, I either get no sound (though the EQ display shows sound being produced) or I get a "Failed to open output" for ALSA error.

Any suggestions?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sat 14 Apr 2007, 02:57    Post subject: Re: Almost there  

catfish wrote:
It just wasn't selected, because the default onboard sound had gotten priority.

You didn't tell us about the onboard sound card before. This is important, because setting up multiple sound cards with ALSA drivers can get a little complex. I think your /etc/modules.conf file needs to have separate entries for each card, like this -
alias snd-card-0 snd-...
alias snd-card-1 snd-...

Then there's still the problem that when you run various audio/mixer applications, they always default to the first card.
You could search the forum for information about all of this, or just take the easy (and sensible) option and disable your onboard sound card in BIOS.

Now erase your pup_save file and boot Puppy afresh. You will now only have to deal with the Delta44.
Regarding mixer settings, run "alsamixer" from the console. This is the audio mixer native to ALSA which will access ALL the card's advanced features.

And if you want to get into multitrack midi recording, search the forum for applications contributed by Dougal and plinej.
Multitrack midi requires a low-latency audio driver such as ALSA provides. You would have NO CHANCE of low-latency audio work with the OSS drivers.
Back to top
View user's profile Send private message 
catfish

Joined: 11 Apr 2007
Posts: 6

PostPosted: Sun 15 Apr 2007, 11:55    Post subject:  

Thanks for the assistance, tempestuous! I disabled the onboard sound in BIOS, deleted puppy_save, and started over.

The Delta44 was automatically detected by Puppy during "install" (guess that's the best word for it, though it doesn't seem like installing). I then used alsamixer to unmute everything (and there alsamix shows so many interfaces that you'd think I had an entire studio in my box!).

I can now play a wav file with aplay, and I hear everything perfectly. This is great, as it means that all hardware is connected correctly and the mixer is configured right, too.

What I still can't do is get any X app to play sound. I'm focusing on XMMS since it allows me to configure just about everything.

XMMS gives me two Output Plugin | Audio Device options:
- default
- M Audio Delta 44; ICE1712 multi (hw:0,0)

I have only one Mixer Card alternative:
- M Audio Delta 44

And under Mixer Devices, I have a huge array of options:
- 4 ADCs
- 4 DACs
- 10 Multis
- 2 Master Tracks

I also have the choice of using or not using Software Volume Control.

My math is wretched, but I believe the above variables have over 100 possible combinations if I'm not mistaken.

And I just can't find the right one!

What do I need to do here to get sound from a "normal" program?

(And BTW, I shut down the aplay terminal and alsamixer before doing this, to prevent conflicts).

Thanks for everyone's continued patience....
Back to top
View user's profile Send private message 
catfish

Joined: 11 Apr 2007
Posts: 6

PostPosted: Sun 15 Apr 2007, 12:07    Post subject:  

Argh... forgot to detail just how things fail right now (using XMMS):

- When Audio Device is set to "M Audio Delta 44: ICE 1712 multi (hw:0,0), I get a "Failed to open audio output: ALSA 1.2.10 output plug-in error". This happens no matter how I configure any of the other settings.

- When Audio Device is set to "default", XMMS seems to be playing the music (the graphic EQ bars move up and down), and no error is produced, but there's also no sound.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sun 15 Apr 2007, 22:15    Post subject:  

catfish wrote:
the graphic EQ bars move up and down

That's a good sign. I think it's a routing or device numbering problem, due to the fact that your card is quite sophisticated.

Here's a fallback solution; try xhippo+lamip audio player -
http://www.murga-linux.com/puppy/viewtopic.php?p=66787#66787
It's a simple gui controlling a commandline player, so it may work.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0671s ][ Queries: 12 (0.0046s) ][ GZIP on ]