Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 21:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
xmms problem
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Sun 08 Apr 2007, 03:00    Post subject:  xmms problem  

hi everybody,
i'm a totally newbie in linux, trying to learn and use puppy, i'm using pizzapup 3.0, which i find wonderful and extremely beautiful to see...almost everything goes well, installed also new software, like skype....the problem is xmms, when i play mp3s from hd (ntfs) it randomly stops playing for a fraction of second, sometimes short, other longer, so it's impossible to use it and listen, and when it happens you hear a noise from hd, as if the heads were moving somewhere..the problem is not cpu, since its usage is extremely low..i tried playing mp3s from an usb key and everything goes well, no stops, xmms works fine..my system is a VIA epia me6000, 600mhz cpu, with a 2.5'hd...i also tried booting puppy 2.15ce and that works fine, any stop....but i want to use pizzapup, it's far more beautiful.
thank in advance to all replies.
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Mon 09 Apr 2007, 00:10    Post subject:  

That's strange. Pizzapup 3.0 is based on a slightly older version of Puppy than 2.15CE, so maybe the NTFS support has improved?

Have you tried Pizzapup 3.0.1 yet? It's based on Puppy 2.14, so it should behave similarly to 2.15CE. Personally, I prefer 3.0 as I put more time into it and 3.0.1 feels more scattered as a result. But it still runs fine. Though I just noticed I didn't fix the Mplayerplug-in after I moved Firefox Rolling Eyes

Maybe Mplayer would have better performance? It may be an XMMS issue. I'm pretty sure I used a different version of XMMS than 2.15 used. I doubt that's the problem, but you never know.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Mon 09 Apr 2007, 04:13    Post subject:  

hi pizzapup, thanks for reply...yes, i tried also 3.01 an it has the same problem..i also tried 3.0 on my pc at work (p41.6) and it has the same annoying stops....for the few i can understand, also i think it's a problem of xmms or of the ntfs interface; mplayer works fine however, but to play mp3s xmms is far better.....
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Mon 09 Apr 2007, 12:04    Post subject:  

Strange. I'm listening to some music on my ntfs partition now and it's working great (in 3.0.1). I'm testing both mp3s and wavs, both come out nice.

Have you defragmented the drive lately? I know Linux has trouble with a fragmented NTFS partition. Maybe the files are fragmented and it gets delayed piecing it together. Confused

But that wouldn't explain why 2.15 could do it. Hmmm. So maybe it's an XMMS problem.

You could try copying the XMMS files from 2.15 into your Pizzapup. I don't know where it's located in 2.15, but in Pizzapup 3.0.1 it's like this:

/usr/share/doc/xmms/
/usr/share/applications/xmms.desktop
/usr/local/lib/xmms/
/usr/local/lib/X11/mini-icons/xmms16.xpm
/usr/local/lib/X11/mini-icons/xmms.xpm
/usr/local/lib/libxmms.so.1.3.1
/usr/local/lib/libxmms.so
/usr/local/lib/libxmms.so.1
/usr/local/bin/wmxmms
/usr/local/bin/xmms
/usr/local/share/xmms/
/root/.xmms/

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Tue 10 Apr 2007, 16:11    Post subject:  

ok, so i've made some tries...on my pc at work, xmms seems to work, so the problem seems only to be in my system; i think you are right when you speak about ntfs fragmentation..i tried also an ext usb hd, fat32 and ntfs, and when i play mp3s from fat32 everything works well..i will try do some defragmentation on my ntfs drive to see if thngs go better...this is however a strange issue......
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0417s ][ Queries: 12 (0.0036s) ][ GZIP on ]