Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 15 Dec 2019, 15:32
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
DpupBuster CE 64 and 32 bit
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 10 [142 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Author Message
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Sun 10 Nov 2019, 01:13    Post subject: fluxbox
Subject description: fluxbox
 

dejan555 wrote:
Here's fluxbox pet compiled on buster 64:

fluxbox-1.3.7-dpupbuster64.pet 882kb
fluxbox-1.3.7-DOC-dpupbuster64 43kb
.

thanks dejan555 .

downloading and testing fluxbox

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
linux28

Joined: 05 Apr 2009
Posts: 237

PostPosted: Sun 10 Nov 2019, 07:54    Post subject:  

http://murga-linux.com/puppy/viewtopic.php?t=76495
Broadcom-STA "wl" wifi drivers
Driver does not Question
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 237

PostPosted: Sun 10 Nov 2019, 08:02    Post subject:  

http://murga-linux.com/puppy/viewtopic.php?t=76495
Broadcom-STA "wl" wifi drivers
Driver does not Question
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Mon 11 Nov 2019, 15:09    Post subject: fluxbox
Subject description: fluxbox
 

testing the fluxbox that went up dejan555.




_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
linux28

Joined: 05 Apr 2009
Posts: 237

PostPosted: Tue 12 Nov 2019, 01:49    Post subject:  

No Audio on ALC887?
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Tue 12 Nov 2019, 09:29    Post subject: audio
Subject description: audio
 

linux28 wrote:
No Audio on ALC887?


I would have to recognize your audio card.
you should try boosting sound wizard

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
linux28

Joined: 05 Apr 2009
Posts: 237

PostPosted: Tue 12 Nov 2019, 20:22    Post subject: Re: audio
Subject description: audio
 

josejp2424 wrote:
linux28 wrote:
No Audio on ALC887?


I would have to recognize your audio card.
you should try boosting sound wizard

sound wizard
I tried it and said that I can't find the hardware.
No sound, there is also a computer used on the 750ti graphics card, after installing the driver, it goes black.
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Tue 19 Nov 2019, 17:44    Post subject: libreOffice-6.3.3
Subject description: libreOffice
 

LibreOffice 6.3.3



Download LibreOffice-6.3.3

MD5
# 7fc618db3440438a9b3dacfeb6c4cc8e

locales libreoffice-= ar - ca - es - fr - hu - it - ja - ru - zh_CN

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Sat 23 Nov 2019, 12:34    Post subject: thunderbird
Subject description: thunderbird
 

thunderbir installer.
will always install the last one. thunderbird package.



Download Thunderbird

MD5
# d543c8b297460686f91a1db6370695af

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 2209

PostPosted: Wed 27 Nov 2019, 00:13    Post subject:  

It might just be an issue related to the gitlab servers but whenever I try to log into gitlab using firefox-esr I get the following error:

Quote:
" 422
The change you requested was rejected.

Make sure you have access to the thing you tried to change.

Please contact your GitLab administrator if you think this is a mistake."


Edit: I couldn't log into GitLab with gnu icecat either. So I decided to try to install iron from the official website. If I su to spot, then I get the errors:

Code:

[root@dpupbuster64 /usr/share/iron] $ su spot
[spot@dpupbuster64 /usr/share/iron] $ ./chrome
[22692:22703:1127/050719.116536:ERROR:cache_util.cc(141)] Unable to move cache folder /root/.config/chromium/ShaderCache/GPUCache to /root/.config/chromium/ShaderCache/old_GPUCache_000
[22692:22703:1127/050719.209606:ERROR:disk_cache.cc(178)] Unable to create cache
[22692:22703:1127/050719.209667:ERROR:shader_disk_cache.cc(620)] Shader Cache Creation failed: -2
[22692:22692:1127/050719.632831:ERROR:process_singleton_posix.cc(433)] readlink failed: Permission denied (13)
[22692:22692:1127/050719.632910:ERROR:process_singleton_posix.cc(257)] readlink(/root/.config/chromium/SingletonLock) failed: Permission denied (13)
[22692:22692:1127/050719.632969:ERROR:process_singleton_posix.cc(257)] readlink(/root/.config/chromium/SingletonLock) failed: Permission denied (13)
[22692:22692:1127/050719.632990:ERROR:process_singleton_posix.cc(281)] Failed to create /root/.config/chromium/SingletonLock: Permission denied (13)
[22692:22692:1127/050719.633017:ERROR:process_singleton_posix.cc(433)] readlink failed: Permission denied (13)
[22692:22692:1127/050719.633040:ERROR:process_singleton_posix.cc(257)] readlink(/root/.config/chromium/SingletonLock) failed: Permission denied (13)
[22692:22692:1127/050719.633096:ERROR:chrome_browser_main.cc(1430)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.


It started as root though with the --no-sandbox option but crached.

Code:

[root@dpupbuster64 /usr/share/iron] $ ./chrome --no-sandbox
[24280:24365:1127/051231.291274:ERROR:bus.cc(394)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[24317:24317:1127/051235.499494:ERROR:gl_surface_glx.cc(78)] XGetWindowAttributes failed for window 52428804.
[24317:24317:1127/051235.499986:ERROR:gl_surface_glx.cc(839)] Failed to get GLXConfig
[24317:24317:1127/051235.500146:ERROR:gpu_info_collector.cc(60)] gl::GLContext::CreateOffscreenGLSurface failed
[24317:24317:1127/051235.500291:ERROR:gpu_info_collector.cc(199)] Could not create surface for info collection.
[24317:24317:1127/051235.500443:ERROR:gpu_init.cc(66)] gpu::CollectGraphicsInfo failed.
[24317:24317:1127/051235.635938:ERROR:viz_main_impl.cc(167)] Exiting GPU process due to errors during initialization

(chrome:24280): LIBDBUSMENU-GLIB-WARNING **: 05:12:35.892: Unable to get session bus: Unknown or unsupported transport “disabled” for address “disabled:”
[24280:24399:1127/051235.934642:ERROR:object_proxy.cc(619)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[24280:24399:1127/051235.935262:ERROR:object_proxy.cc(619)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[24280:24399:1127/051235.935811:ERROR:object_proxy.cc(619)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[24280:24280:1127/051236.243402:FATAL:template_expressions.cc(98)] Check failed: value != replacements.end(). $i18n replacement key "localNtpCustomBgIntegrity" not found
#0 0x555c6582e719 base::debug::CollectStackTrace()
#1 0x555c6578d003 base::debug::StackTrace::StackTrace()
#2 0x555c657a1173 logging::LogMessage::~LogMessage()
#3 0x555c65af89e2 ui::ReplaceTemplateExpressions()
#4 0x555c65651eb1 LocalNtpSource::StartDataRequest()
#5 0x555c657d7a0f base::TaskAnnotator::RunTask()
#6 0x555c657e814c base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoWorkImpl()
#7 0x555c657e7e38 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoSomeWork()
#8 0x555c657a517a base::MessagePumpGlib::Run()
#9 0x555c657e8a79 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::Run()
#10 0x555c657c0cc7 base::RunLoop::RunWithTimeout()
#11 0x555c6541d227 ChromeBrowserMainParts::MainMessageLoopRun()
#12 0x555c63ca5b4b content::BrowserMainLoop::RunMainMessageLoopParts()
#13 0x555c63ca79a2 content::BrowserMainRunnerImpl::Run()
#14 0x555c63ca2b2f content::BrowserMain()
#15 0x555c653b1e4c content::ContentMainRunnerImpl::RunServiceManager()
#16 0x555c653b1b76 content::ContentMainRunnerImpl::Run()
#17 0x555c653fd92d service_manager::Main()
#18 0x555c653afe81 content::ContentMain()
#19 0x555c631541bf ChromeMain
#20 0x7f205229809b __libc_start_main
#21 0x555c6315402a _start
Task trace:
#0 0x555c6410e6b5 content::(anonymous namespace)::StartURLLoader()
#1 0x555c6410df27 content::(anonymous namespace)::WebUIURLLoaderFactory::CreateLoaderAndStart()
#2 0x555c6595c026 mojo::SimpleWatcher::Context::Notify()
IPC message handler context: 0x40F1D8EC

Received signal 6
#0 0x555c6582e719 base::debug::CollectStackTrace()
#1 0x555c6578d003 base::debug::StackTrace::StackTrace()
#2 0x555c6582e2a1 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x7f2054736730 <unknown>
#4 0x7f20522ab7bb gsignal
#5 0x7f2052296535 abort
#6 0x555c6582d105 base::debug::BreakDebugger()
#7 0x555c657a15a1 logging::LogMessage::~LogMessage()
#8 0x555c65af89e2 ui::ReplaceTemplateExpressions()
#9 0x555c65651eb1 LocalNtpSource::StartDataRequest()
#10 0x555c657d7a0f base::TaskAnnotator::RunTask()
#11 0x555c657e814c base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoWorkImpl()
#12 0x555c657e7e38 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoSomeWork()
#13 0x555c657a517a base::MessagePumpGlib::Run()
#14 0x555c657e8a79 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::Run()
#15 0x555c657c0cc7 base::RunLoop::RunWithTimeout()
#16 0x555c6541d227 ChromeBrowserMainParts::MainMessageLoopRun()
#17 0x555c63ca5b4b content::BrowserMainLoop::RunMainMessageLoopParts()
#18 0x555c63ca79a2 content::BrowserMainRunnerImpl::Run()
#19 0x555c63ca2b2f content::BrowserMain()
#20 0x555c653b1e4c content::ContentMainRunnerImpl::RunServiceManager()
#21 0x555c653b1b76 content::ContentMainRunnerImpl::Run()
#22 0x555c653fd92d service_manager::Main()
#23 0x555c653afe81 content::ContentMain()
#24 0x555c631541bf ChromeMain
#25 0x7f205229809b __libc_start_main
#26 0x555c6315402a _start
  r8: 0000000000000000  r9: 00007ffe0468dec0 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007ffe0468f210 r13: 00007ffe0468e168 r14: 00007ffe0468f218 r15: 00007ffe0468f220
  di: 0000000000000002  si: 00007ffe0468dec0  bp: 00007ffe0468e110  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f20522ab7bb  sp: 00007ffe0468dec0
  ip: 00007f20522ab7bb efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
[root@dpupbuster64 /usr/share/iron] $ [1127/051237.587956:ERROR:nacl_helper_linux.cc(310)] NaCl helper process running without a sandbox!
Most likely you need to configure your SUID sandbox correctly


_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 2209

PostPosted: Wed 27 Nov 2019, 01:22    Post subject:  

I tried installing chromium via package and I got a segmentation fault. Maybe I'll try one of the portable browsers on this forum.
_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 2209

PostPosted: Wed 27 Nov 2019, 01:42    Post subject:  

I installed google chrome from the official website.

I was able to run it with the following command:
Code:

run-as-spot /usr/bin/google-chrome-stable


after that I was able to log into gitlab.


Note that the run-as-spot command only works if you are the root user. It doesn't work if you are already spot.

I didn't try this run-as-spot command with chromium or iron, so maybe they might have worked with this command.

P.S. I'm able to log into gitlab in firefox-esr in my tiny_puduan distro so I'm not sure why it isn't working on buster with firefox-esr.

_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 2209

PostPosted: Wed 27 Nov 2019, 09:16    Post subject:  

I installed DpupBuster CE 64 because I wanted a more official version of pkg for testing purposes. Since the version that I use in my tiny_puduan is "heavily modified" or at least it is according to sc0ttman it won't be acceptable as a testing environment if I want to contribute to the official version of pkg.

Some differences that I noticed for pkg in dpup buster vs the official version of pkg:

The file ppa2pup, doesn't seem to exist. Also ppa2pup no longer seems to be referenced in /usr/sbin/pkg.

See:
https://gitlab.com/sc0ttj/Pkg/blob/master/usr/sbin/pkg#L1493
https://gitlab.com/sc0ttj/Pkg/blob/master/usr/sbin/pkg#L1803

Please let me know of any modifications that you made to pkg?

BTW, the following command doesn't seem to work properly:
Code:

pkg --repo-update


It hangs because 0seup is looking for user input. Pressing "enter" a few times helps the script finish but the prompt doesn't show.

I haven't tried it yet but you might be interested in wdlkmpx changes here:

Code:

  # now call petget 0setup.. [add argument]
  /usr/local/petget/0setup x &>$TMPDIR/update_repo_results

https://github.com/puppylinux-woof-CE/Pkg/commit/6dc32299c45620e36d439c53c724bf2a6c2381a7
https://gitlab.com/sc0ttj/Pkg/issues/71

When I tested this I missed the part where wdlkmpx said that it required a patched 0setup:

Quote:

Pkg was not compatible with current stuff in the testing branch

This Pkg is somewhat fixed to work with current woofce
https://github.com/puppylinux-woof-CE/Pkg/commits

But requires a patched 0setup:
f99cf47

In puppy/woof/fyhk everything is tightly integrated and the design is terrible, it's surprisingly easy to break stuff for everyone else just by making improvements to the code. It's not that hard to understand that.

https://github.com/puppylinux-woof-CE/woof-CE/issues/1623#issuecomment-543370726

Or as an alternative to using 0setup, one can use ppa2pup. I have created a faster version of ppa2pup. See:
github.com/s243a/.../usr/sbin/ppa2pup
http://www.murga-linux.com/puppy/viewtopic.php?t=117436

sc0ttman, wants to keep the old version of ppa2pup (see post). Therefore, I'll probably rename my awk version of ppa2pup to something like ppa2pup_gawk.

Anyway, I would be interested to know of any changes that you made to pkg. I recall reading something about dpup buster having issues with the multi-arch symlink, when using pkg. For testing, I want to use as official code as possible but I need to be aware of any potential issues like the multi-arch symlink that you previously mentioned. I can copy sc0ttman's official code into dpup buster but I need to know of any potential issues than need to be resolved, that you patched.

_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Thu 28 Nov 2019, 19:43    Post subject: pkg
Subject description: pkg
 

s243a wrote:
I installed DpupBuster CE 64 because I wanted a more official version of pkg for testing purposes. Since the version that I use in my tiny_puduan is "heavily modified" or at least it is according to sc0ttman it won't be acceptable as a testing environment if I want to contribute to the official version of pkg.

Some differences that I noticed for pkg in dpup buster vs the official version of pkg:

The file ppa2pup, doesn't seem to exist. Also ppa2pup no longer seems to be referenced in /usr/sbin/pkg.

See:
https://gitlab.com/sc0ttj/Pkg/blob/master/usr/sbin/pkg#L1493
https://gitlab.com/sc0ttj/Pkg/blob/master/usr/sbin/pkg#L1803

Please let me know of any modifications that you made to pkg?

BTW, the following command doesn't seem to work properly:
Code:

pkg --repo-update


It hangs because 0seup is looking for user input. Pressing "enter" a few times helps the script finish but the prompt doesn't show.

I haven't tried it yet but you might be interested in wdlkmpx changes here:

Code:

  # now call petget 0setup.. [add argument]
  /usr/local/petget/0setup x &>$TMPDIR/update_repo_results

https://github.com/puppylinux-woof-CE/Pkg/commit/6dc32299c45620e36d439c53c724bf2a6c2381a7
https://gitlab.com/sc0ttj/Pkg/issues/71

When I tested this I missed the part where wdlkmpx said that it required a patched 0setup:

Quote:

Pkg was not compatible with current stuff in the testing branch

This Pkg is somewhat fixed to work with current woofce
https://github.com/puppylinux-woof-CE/Pkg/commits

But requires a patched 0setup:
f99cf47

In puppy/woof/fyhk everything is tightly integrated and the design is terrible, it's surprisingly easy to break stuff for everyone else just by making improvements to the code. It's not that hard to understand that.

https://github.com/puppylinux-woof-CE/woof-CE/issues/1623#issuecomment-543370726

Or as an alternative to using 0setup, one can use ppa2pup. I have created a faster version of ppa2pup. See:
github.com/s243a/.../usr/sbin/ppa2pup
http://www.murga-linux.com/puppy/viewtopic.php?t=117436

sc0ttman, wants to keep the old version of ppa2pup (see post). Therefore, I'll probably rename my awk version of ppa2pup to something like ppa2pup_gawk.

Anyway, I would be interested to know of any changes that you made to pkg. I recall reading something about dpup buster having issues with the multi-arch symlink, when using pkg. For testing, I want to use as official code as possible but I need to be aware of any potential issues like the multi-arch symlink that you previously mentioned. I can copy sc0ttman's official code into dpup buster but I need to know of any potential issues than need to be resolved, that you patched.
.


hi s243a.
The pkg I use is the official one.
the pkg --repo-update if it works. what if it takes time to update,
When I used the puppylinux repo it was fast.
but reading the repo debian takes time updating.
and dpupbuster only uses repos debian.

I will test your modifications, which you mention and I will be commenting on you.

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 2209

PostPosted: Thu 28 Nov 2019, 22:11    Post subject: Re: pkg
Subject description: pkg
 

josejp2424 wrote:

I will test your modifications, which you mention and I will be commenting on you.


There is a merge request now:

https://gitlab.com/sc0ttj/Pkg/merge_requests/4

the code to be merged works, although:
- there might be some logic issues to work out regarding how to call 0setup (if at all) [1]
- I included sc0ttman's suggested code as part of this branch to be merged without testing (see commit). I'll test this tonight.

Maybe, wait a few days for these details to be worked out, unless you want to contributed to the discussion about the merge request. Smile. That said if you want to do some testing, there are only two files that need to be replaced. These are:
/usr/sbin/pkg
/usr/sbin/ppa2pup_gawk

Notes
---------------------------

1 -
Quote:
BTW, how we use ppa2pup or ppa2pup_gawk as a fallback to 0setup when 0setup doesn't exist needs more work:


ppa2pup only works on .deb based pups,
IIRC, in standard Puppy only third-party repos go in /etc/sources.list and /etc/slackpkg/mirrors, not system repos, so they would't get updated
we need to also handle Slackware pups if 0setup doesn't exist (fall back to slack2pup?)

We need to check $DISTRO_BINARY_COMPAT:

if .deb based pup, and no 0setup, use ppa2pup
if slack based pup, and no 0setup, use slack2pup
if no repos in /etc/sources.list or /etc/mirrors/slackpkg.... ?????

https://gitlab.com/sc0ttj/Pkg/merge_requests/4#note_251616106

_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 9 of 10 [142 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.3188s ][ Queries: 13 (0.0239s) ][ GZIP on ]