Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 16 Dec 2019, 04:56
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
DevuanDog 'beowulf' build system
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 5 [66 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
zagreb999

Joined: 11 Apr 2014
Posts: 535
Location: Yugoslavija

PostPosted: Sun 19 May 2019, 04:34    Post subject:  

Unlike Debian, antiX is systemd-free!
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 799
Location: Pennsylvania U.S.

PostPosted: Sun 19 May 2019, 18:53    Post subject: stretchdog & beowulf  

Hi fred...

OK
Downloaded the script-
mklive-beowulf
in my frugal install of StretchDog64

Tried running it in the terminal... that didn't work!

What's the correct step? and...

I assume this will convert StretchDog to beowulf ?

You will have to forgive me, 'Dogs' and their procedures are a new ball game to me and I'm sure many other Puppy users.

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4217
Location: holland

PostPosted: Mon 20 May 2019, 14:32    Post subject: Re: stretchdog & beowulf  

sszindian wrote:
Hi fred...

OK
Downloaded the script-
mklive-beowulf
in my frugal install of StretchDog64

Tried running it in the terminal... that didn't work!

What's the correct step? and...

I assume this will convert StretchDog to beowulf ?

You will have to forgive me, 'Dogs' and their procedures are a new ball game to me and I'm sure many other Puppy users.

>>>---Indian------>


Some more info would be helpful to find out what's the problem, "didn't work" doesn't say much
Did you make it executable ?, e.g.
Code:
chmod +x ./mklive-beowulf

What do you see when running from terminal ?, and did you try this ?:
Code:
./mklive-beowulf -gui

It's for to display the GUI.
Quote:
I assume this will convert StretchDog to beowulf ?

It will create DevuanDog 'beowulf' ISO, a complete new system, not converting Stretchdog.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 535
Location: Yugoslavija

PostPosted: Mon 20 May 2019, 14:43    Post subject:  

this script for me works perfectly
in ddog...
Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 657
Location: Rakaia

PostPosted: Tue 21 May 2019, 03:49    Post subject:  

musher0 wrote:
Not you as in you personally, darry!

Sorry if I offended you. Bad translation. In certain contexts, and this is one of them, in
French we can use "vous" ( " you" ) as a kind of neutral, without pointing a finger at anyone

I mean the Sparky people. The nerve THEY have to call THEIR 864 Mb distro "minimal".
That's how I should have said it in the first place.

Again, sorry.


I accept your apology Musher and to be honest the mood I was in at the time didn't help. I am running Puppy (after giving up on it) on new machine I acquired cheaply - dv6000).

The issues I had with Cosmic and Disco lead me to want to give on Pup on another machine Compaq CQ61.

_________________
Puppy Linux Wiki: http://wikka.puppylinux.com/HomePage

https://freemedia.neocities.org/
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 14554
Location: Gatineau (Qc), Canada

PostPosted: Tue 21 May 2019, 05:37    Post subject:  

Good to have you back Darry. I'll try to think twice, next time...
_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 799
Location: Pennsylvania U.S.

PostPosted: Tue 21 May 2019, 10:56    Post subject: beowulf 64  

Thanks for all that info fred! but further looking into beowulf shows a Kernel: 4.19.0-4... my machine will only handle up to a 4.12 (max) so will have to pass on testing this for now.

>>>---Indian------?

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1417

PostPosted: Fri 24 May 2019, 01:26    Post subject:  

I've been trying to build a minimal as possible pure openbox version with ceres64 and I can't get it to build without mesa-dri being included.

Do I have something that depends on mesa-dri or is it something else?


Quote:
Live system built on x86_64 for amd64 on Tue May 21 20:36:52 CDT 2019
Preinstalled on top of debootstrap build:
live-boot wget menu dialog apt-utils dbus ca-certificates apt-transport-https xserver-xorg-legacy

Base Install:
wget net-tools ifupdown wireless-tools sysvinit-core xserver-xorg-core xserver-xorg psmisc fuse x11-xserver-utils dbus-x11 busybox sudo mawk xinit xterm pciutils usbutils file rsync dosfstools volumeicon-alsa alsa-utils pm-utils xdotool wmctrl desktop-file-utils mime-support squashfs-tools fakeroot xserver-xorg-input-evdev pv ntfs-3g

Base Dog Packages Install:
yad gtkdialog obshutdown pup-volume-monitor peasywifi chpupsocket edit-sfs-pcmanfm filemnt-pcmanfm remaster-scripts quick-remaster apt2sfs sfsload fixdepinstall greybird-theme-dd-stretch makedebpackage peasyclock

Applications Install:
leafpad viewnior pfind

Desktop Environment Packages:
openbox=3.6.1-4.3 obconf pcmanfm lxpanel lxrandr lxinput lxappearance

Firmware:


Extra Dog Packages:
unrar dirmngr lxterminal gdmap

Remove xserver-xorg-video-vmware=TRUE
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4217
Location: holland

PostPosted: Fri 24 May 2019, 12:31    Post subject:  

dancytron wrote:
I've been trying to build a minimal as possible pure openbox version with ceres64 and I can't get it to build without mesa-dri being included.

Do I have something that depends on mesa-dri or is it something else?


Quote:
Live system built on x86_64 for amd64 on Tue May 21 20:36:52 CDT 2019
Preinstalled on top of debootstrap build:
live-boot wget menu dialog apt-utils dbus ca-certificates apt-transport-https xserver-xorg-legacy

Base Install:
wget net-tools ifupdown wireless-tools sysvinit-core xserver-xorg-core xserver-xorg psmisc fuse x11-xserver-utils dbus-x11 busybox sudo mawk xinit xterm pciutils usbutils file rsync dosfstools volumeicon-alsa alsa-utils pm-utils xdotool wmctrl desktop-file-utils mime-support squashfs-tools fakeroot xserver-xorg-input-evdev pv ntfs-3g

Base Dog Packages Install:
yad gtkdialog obshutdown pup-volume-monitor peasywifi chpupsocket edit-sfs-pcmanfm filemnt-pcmanfm remaster-scripts quick-remaster apt2sfs sfsload fixdepinstall greybird-theme-dd-stretch makedebpackage peasyclock

Applications Install:
leafpad viewnior pfind

Desktop Environment Packages:
openbox=3.6.1-4.3 obconf pcmanfm lxpanel lxrandr lxinput lxappearance

Firmware:


Extra Dog Packages:
unrar dirmngr lxterminal gdmap

Remove xserver-xorg-video-vmware=TRUE


Yes, noticed that also, it looks like that mesa-dri is (sort of) part of the core now, don't know which package(s) depend on it.

EDIT: Found out now, xorg depends on libgl1-mesa-dri, so can only be uninstalled if running without X.

Code:
root@live:~# apt-cache rdepends --installed libgl1-mesa-dri
libgl1-mesa-dri
Reverse Depends:
  xserver-xorg-video-nouveau
  xserver-xorg-core
  xserver-xorg-core
  libglx-mesa0
  xserver-xorg


Fred

_________________
Dog Linux website
Tinylinux blog by wiak

Last edited by fredx181 on Sun 26 May 2019, 12:35; edited 1 time in total
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4217
Location: holland

PostPosted: Sun 26 May 2019, 12:25    Post subject:  

-- removed --
_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1417

PostPosted: Sun 26 May 2019, 14:43    Post subject:  

fredx181 wrote:
dancytron wrote:
I've been trying to build a minimal as possible pure openbox version with ceres64 and I can't get it to build without mesa-dri being included.

Do I have something that depends on mesa-dri or is it something else?


Quote:
Live system built on x86_64 for amd64 on Tue May 21 20:36:52 CDT 2019
Preinstalled on top of debootstrap build:
live-boot wget menu dialog apt-utils dbus ca-certificates apt-transport-https xserver-xorg-legacy

Base Install:
wget net-tools ifupdown wireless-tools sysvinit-core xserver-xorg-core xserver-xorg psmisc fuse x11-xserver-utils dbus-x11 busybox sudo mawk xinit xterm pciutils usbutils file rsync dosfstools volumeicon-alsa alsa-utils pm-utils xdotool wmctrl desktop-file-utils mime-support squashfs-tools fakeroot xserver-xorg-input-evdev pv ntfs-3g

Base Dog Packages Install:
yad gtkdialog obshutdown pup-volume-monitor peasywifi chpupsocket edit-sfs-pcmanfm filemnt-pcmanfm remaster-scripts quick-remaster apt2sfs sfsload fixdepinstall greybird-theme-dd-stretch makedebpackage peasyclock

Applications Install:
leafpad viewnior pfind

Desktop Environment Packages:
openbox=3.6.1-4.3 obconf pcmanfm lxpanel lxrandr lxinput lxappearance

Firmware:


Extra Dog Packages:
unrar dirmngr lxterminal gdmap

Remove xserver-xorg-video-vmware=TRUE


Yes, noticed that also, it looks like that mesa-dri is (sort of) part of the core now, don't know which package(s) depend on it.

EDIT: Found out now, xorg depends on libgl1-mesa-dri, so can only be uninstalled if running without X.

Code:
root@live:~# apt-cache rdepends --installed libgl1-mesa-dri
libgl1-mesa-dri
Reverse Depends:
  xserver-xorg-video-nouveau
  xserver-xorg-core
  xserver-xorg-core
  libglx-mesa0
  xserver-xorg


Fred


Well, it is unstable. Smile

I think that is going to break it for some computers.

For me, it is broken unless I install the intel drivers, then it loads x with mesa. Other Dogs will load x with vesa with no mesa-dri, but will not load x with mesa dri and no intel drivers.

If I had a computer that I had to run on vesa, then it wouldn't work.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1417

PostPosted: Sun 26 May 2019, 20:12    Post subject:  

The mklive-beowulf script fails with the messages below. I tried it twice and internet connection seemed fine.

Quote:
Download linux-image-4.19.0-4-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-image-4.19.0-4-amd64
E: Couldn't find any package by glob 'linux-image-4.19.0-4-amd64'
E: Couldn't find any package by regex 'linux-image-4.19.0-4-amd64'
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-image-4.19.0-4-amd64
E: Couldn't find any package by glob 'linux-image-4.19.0-4-amd64'
E: Couldn't find any package by regex 'linux-image-4.19.0-4-amd64'
FAILED
Unmounting mount binds in chroot
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4217
Location: holland

PostPosted: Mon 27 May 2019, 10:41    Post subject:  

Thanks for info Dan !
That's bad about the mesa/vesa issue you mention (not only with 'unstable', same problem for beowulf), hopefully the Debian maintainers will change things to how it was (but I doubt it because beowulf/buster is very near to become the 'stable' branch).
I've found some more issues btw, e.g. the 'ceres' branch apparently doesn't exist anymore (getting error from apt-get update) (probably should be named 'unstable' now from sources.list) and about the kernel: the previous version (=4.19.0-4) is always removed from testing (beowulf) and unstable Debian repository when there's a new version (=4.19.0-5) , so need to find a diiferent way to handle this in the build script.

All together, I think better to put this project on hold now until I found out how to solve these problems.
Announced that at first post and will get back about it later.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4217
Location: holland

PostPosted: Tue 28 May 2019, 15:24    Post subject:  

*** Updated mklive-beowulf and mklive-ceres ***

See for info Changes and fixes
Download links at first post replaced with new versions.

The issue that @dancytron mentioned Here I don't know how to solve, any suggestions are very welcome.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 535
Location: Yugoslavija

PostPosted: Sat 15 Jun 2019, 03:14    Post subject:  

fred:
Yes, it's possible, but I don't do Debian anymore because full systemd integration cannot be avoided nowadays (for buster and sid)

suggestion: antix is pure debian no systemd

it could be done mklive script with antix linux instead of debian...

regards
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 5 [66 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1498s ][ Queries: 13 (0.0485s) ][ GZIP on ]