Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 15 Nov 2019, 20:07
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Problem updating Palemoon
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
JFB

Joined: 17 Oct 2017
Posts: 34

PostPosted: Mon 22 Oct 2018, 04:35    Post subject:  Problem updating Palemoon  

I'm using Tharpup 6.0.5. Pale Moon is the default web browser. Using the Pale Moon updater, I have updated Pale Moon a number of times. But now, when I try to update, I get an error message. Any suggestions? Thanks...
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12837
Location: S.C. USA

PostPosted: Mon 22 Oct 2018, 05:00    Post subject:  

With Palemoon 28 they stopped using the updater and now have update built into the browser.

Here is a pet for Xenialpup 7.5.
Not sure but it should work in Tahrpup.
http://distro.ibiblio.org/puppylinux/pet_packages-xenial/palemoon-28.0.0-i686.pet
This will give you Palemoon 28.0.0

If this works OK.
Updates are done in Palemoon>Help>About Palemoon>Check for Updates

This will update Palemoon to 28.1.0

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 5548
Location: King's Lynn, UK.

PostPosted: Mon 22 Oct 2018, 06:19    Post subject:  

@ JFB:-

This .pet will give you 28.1.0 direct. As bigpup says, Moonchild Productions have now adopted the same method as Firefox.....updating from within the browser. Look in the 'Help->About Palemoon' menu item.

(This was built from the tarball, so is essentially 'generic'. I have it running in several older Pups.)


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
6502coder


Joined: 23 Mar 2009
Posts: 649
Location: Western United States

PostPosted: Mon 22 Oct 2018, 18:39    Post subject:  

@Mike Walsh
Thanks for the PET. Works nicely in Tahr 6.0.6, posting from it now.

Update 11 nov 2018:
This PET is also working for me in SailorE's Slacko571 WoofCE build.

Last edited by 6502coder on Sun 11 Nov 2018, 20:50; edited 2 times in total
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 5548
Location: King's Lynn, UK.

PostPosted: Mon 22 Oct 2018, 19:06    Post subject:  

@ 6502coder:-

6502coder wrote:
@Mike Walsh
Thanks for the PET. Works nicely in Tahr 6.0.6, posting from it now.


You're very welcome! Enjoy.


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 51

PostPosted: Wed 21 Nov 2018, 00:57    Post subject:  

Hello Mike Walsh -

Thanks for this - I'd been using the palemoon-28.0.0-glibc219tweak.pet for Wary/Racy from the Palemoon browser thread but wasn't sure if it was the best one for Tahrpup. Works great! Smile
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 5548
Location: King's Lynn, UK.

PostPosted: Wed 21 Nov 2018, 09:20    Post subject:  

DustyPixel wrote:
Hello Mike Walsh -

Thanks for this - I'd been using the palemoon-28.0.0-glibc219tweak.pet for Wary/Racy from the Palemoon browser thread but wasn't sure if it was the best one for Tahrpup. Works great! Smile


Dusty; you're most welcome, lass. I just hope it works okay for you. The one you've been using has in fact got a self-contained version of the exact same glibc that Tahrpup uses anyway - libc-2.19.

(That's the whole point of this community of ours, y'see; we all help each other out.... Those that can, do; those that can't, often do what they can to help out anyway.)

Enjoy..!


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
peppyy


Joined: 27 Jun 2005
Posts: 442
Location: VT USA

PostPosted: Fri 23 Nov 2018, 10:10    Post subject:  

Hey all, Long Time No See. I am still running Puppy exclusively, although on newer hardware.
I used the update pet on tahrpup,64 6.05 full install and it appears to have worked except for one small problem. I have lost the indicator on my right side scroll bar and I now see I am running the 32 bit version. Any ideas?

Edit: Also noticed there are no check boxes or radio buttons.

_________________
Puppy Linux...
It just works!
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
bigpup


Joined: 11 Oct 2009
Posts: 12837
Location: S.C. USA

PostPosted: Fri 23 Nov 2018, 18:06    Post subject:  

Use Puppy Package Manager(PPM) to uninstall the 32bit version of PaleMoon.

Get the 64 bit version of Pale Moon.

Install this 64 bit version of PaleMoon.
http://distro.ibiblio.org/puppylinux/pet_packages-xenial64/palemoon-28.0.0-x86_64.pet
After you get it installed and running.
I know it is not the latest version, but it is the one that will let you update Pale Moon internally by using help>About Pale Moon>check for updates.
One time selecting check for updates will get the latest version at that time.
Quick an easy.

That is how I did it.

Note:
In Pale Moon preferences>Advanced>Updates
There will now be options for how you want update to work.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
peppyy


Joined: 27 Jun 2005
Posts: 442
Location: VT USA

PostPosted: Sat 24 Nov 2018, 07:54    Post subject:  

Thanks Big Pup. I am hoping I can save my bookmarks etc. I should have a backup of my profile somewhere, if not I will make one again. It took me a week to set it all up a couple years ago.
_________________
Puppy Linux...
It just works!
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
bigpup


Joined: 11 Oct 2009
Posts: 12837
Location: S.C. USA

PostPosted: Sat 24 Nov 2018, 13:35    Post subject:  

I am not sure what may be messed up because you installed the 32bit version of Pale Moon.
So, that is why i suggested to uninstall the 32bit Pale Moon.

The pet should just install over the older Pale Moon changing it to that newer version. All stored settings and stuff should still be there. That is how it worked when I installed the newer 64bit version when an older 64 bit version was installed.

I guess you could keep everything installed and just install the newer version pet package. See what happens.

Menu bar>bookmarks>Organize Bookmarks has options for making backups.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
peppyy


Joined: 27 Jun 2005
Posts: 442
Location: VT USA

PostPosted: Sun 25 Nov 2018, 08:06    Post subject:    

Thanks again. Downloaded and installed the 64 bit and everything is back. I can see checkboxes, scrollbars and radio buttons and it appears to use my current Puppy theme perfectly. Even remembered mu pass for the forum Wink
_________________
Puppy Linux...
It just works!
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0659s ][ Queries: 12 (0.0076s) ][ GZIP on ]