Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 18 Nov 2018, 08:23
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPupSc64 - 64bit version of Puppy with the LXDE desktop
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 20 of 20 [296 Posts]   Goto page: Previous 1, 2, 3, ..., 18, 19, 20
Author Message
Billtoo


Joined: 07 Apr 2009
Posts: 3605
Location: Ontario Canada

PostPosted: Thu 11 Oct 2018, 17:30    Post subject: LxPupSc64 - 64bit version of Puppy with the LXDE desktop  

Installed 18.06+9-uefi to the hard drive of HP desktop:

System: Host: puppypc9263 Kernel: 4.17.0-lxpup64 x86_64 (64 bit) Desktop: LXDE (Openbox 3.6.1)
Distro: LxPupSc64 18.06
Machine: Device: desktop System: Hewlett-Packard product: p7-1246s serial: MXX232077R
Mobo: Foxconn model: 2ADA v: 1.00 BIOS: AMI v: 7.12 date: 06/07/2012
CPU: Quad core Intel Core i5-3550 (-MCP-) speed/max: 1602/3301 MHz
Graphics: Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
Display Server: X.org 1.20.1 driver: intel tty size: 180x31 Advanced Data: N/A for root
Network: Card-1: Ralink RT5390 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives: HDD Total Size: 2000.4GB (1.0% used)
Weather: Conditions: 72 F (22 C) - Mostly Cloudy Time: October 11, 5:05 PM EDT
Info: Processes: 146 Uptime: 1:22 Memory: 372.2/11901.7MB Client: Shell (bash) inxi: 2.3.8

Added Kpat and Smplayer/Smtube,no luck with Kodi.
Added Chromium64_69.0.3497.100+pepper_31.0.0.122_lx_spot.sfs

Thanks.
screenshot.jpg
 Description   
 Filesize   47.82 KB
 Viewed   771 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 394
Location: S.E Australia

PostPosted: Wed 24 Oct 2018, 01:03    Post subject: Video issue  

I have had trouble playing some videos via seamonkey 2.49.4 - works fine in Slacko64-6.9.9.9, Xenialpup64 7.5, Bionicpup64 7.9.5. Video advances to (at best) advert and stops, sometimes locking up. Main site I've noticed is afl.com.au (any video in middle of page). Have tried adding extra gtk3 packages, changing about:config, turning off acceleration - no avail. Versions of Palemoon before 28.0 & supplied Light browser work. Any ideas?

EDIT: this is a GTK3 problem. Seamonkey64-2.48 (gtk2) works fine. If only it was secure.

EDIT2: apulse libs are in /usr/lib64 - apulse executable points to /usr/lib/64/apulse folder. When moved there, videos work!
.

Last edited by ozsouth on Thu 01 Nov 2018, 20:50; edited 2 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3534
Location: Worcestershire, UK

PostPosted: Fri 26 Oct 2018, 07:05    Post subject:  

Interim delta to 18.06+11-uefi

iso md5 = 29fe9aa0fe97a5db3840f1ff2079be1e lxpupsc64-18.06+11-uefi.iso

Just Slackware64 Current updates to Sat Oct 27 18:22:46 UTC 2018 + reversion to pup-volume-monitor-0.1.15

Later 64-bit kernels (4.19.x) are available

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Mon 29 Oct 2018, 11:34; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
wadmalaw

Joined: 16 May 2017
Posts: 7

PostPosted: Sun 28 Oct 2018, 12:59    Post subject:  

Mounted volumes disappear from desktop and pcmanfm panel when attach external drive (pcmanfm bookmarks remain and function though).

Since about k 4.18.10 (through subsequent kernel updates posted and OS updates). Various obvious gui setting changes had no positive effect (pcmanfm/event manager). Tested when new OS 18.06 updates posted (without save folder) and same result. Thought it might be particular to this system but recent load (no save folder) to laptop produced same result.

Checkums matched prior to install. No idea if kernel or OS upgrade specific but sometimes pmount automatically popped up and sometimes not. (Pmount always worked as expected though.)

Reinitializing pup-volume-monitor-starter consistently works for me. (Plug in external drive, wait for volume icons to disappear, reinitialize pup-volume-monitor-starter and all volumes show up and fully functional again in pcmanfm and desktop.)

This isn't a big deal, just a tip for anyone else who has adopted this as their main and experiencing same perplexing issue and is of similar dubious skill level. (I'd gotten really used to letting pcmanfm handle drive mounts/unmounts.) Bear in mind it could still be something weird I've done causing this...

Thanks for keeping so many things updated PeeBee, greatly appreciate your efforts.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3534
Location: Worcestershire, UK

PostPosted: Mon 29 Oct 2018, 05:54    Post subject:  

wadmalaw wrote:
Mounted volumes disappear from desktop and pcmanfm panel when attach external drive

Thank you for the report which I have verified....

Problem can be traced back to change to 64-bit pup-volume-monitor-0.1.17 on or about 15-sep-2018.

Have reverted back to pup-volume-monitor-0.1.15 in delta 18.06+11

The dmesg crash with 0.1.17 is:
Code:
pool[7353]: segfault at 40 ip 00007f2127bb54f0 sp 00007f21263b6dd8 error 4 in libpupvm.so.0.0.0[7f2127ba9000+13000]
Code: 40 00 48 8b 05 11 6b 20 00 48 8b 00 48 85 c0 74 e4 ff d0 48 89 df 5b e9 de aa ff ff 0f 1f 40 00 66 2e 0f 1f 84 00 00 00 00 00 <8b> 47 40 85 c0 74 09 48 8b 07 ff a0 a0 00 00 00 c3 0f 1f 44 00 00
I'll report it on github.
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
wadmalaw

Joined: 16 May 2017
Posts: 7

PostPosted: Mon 29 Oct 2018, 22:16    Post subject:  

Thank you PeeBee, didn't expect you to look into it so quick, thought maybe it'd go in the lower levels of a punch list.

Volumes stay put with 18+11. Nice to have them arranged in the expected order. Pmount automatically popped up when attached external drives, doesn't bother me at all.

Everything else you said was way beyond me. Very Happy

I am really liking this OS. Thanks again.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3534
Location: Worcestershire, UK

PostPosted: Sun 04 Nov 2018, 06:53    Post subject: Re: Video issue  

ozsouth wrote:
I have had trouble playing some videos via seamonkey 2.49.4

I downloaded the UNOFFICIAL 64-bit seamonkey-2.49.4......(only 32-bit seamonkey is official).....
I installed my 64-bit gtk+3 pet that I use in other browsers
I extracted seamonkey to a directory and ran it directly from there...

in my 2 standard tests (youtube and bbc-iplayer) videos and sound played correctly..........no changes to apulse were required.....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
norgo


Joined: 13 Nov 2015
Posts: 286
Location: Germany

PostPosted: Thu 08 Nov 2018, 14:01    Post subject:  

@ozsouth

to change settings on spec won't help you along.
find out what your SM version has included and what system components are used.

type about:buildconfig in address line of SM and press enter

look whether SM has been built with pulseaudio support or not
in case of built without pulseaudio you should find the entries ( --disable-pulseaudio --enable-alsa )

is system or internal libvpx used ?
in case of system libvpx usage you should find ( --with-system-libvpx ) and of course a recent version should be installed

whether SM has been built for gtk2 or gtk3 you can detect which toolkit is used
( --enable-default-toolkit=cairo-gtk2 ) or ( --enable-default-toolkit=cairo-gtk3 )

in case of trouble you could also look here
type about:support in address line of SM and look for messages
Back to top
View user's profile Send private message Visit poster's website 
ozsouth

Joined: 01 Jan 2010
Posts: 394
Location: S.E Australia

PostPosted: Sat 10 Nov 2018, 00:45    Post subject:  

@norgo - thanks for your help. about:buildconfig makes no mention of pulse or vpx. SM64 2.49.4 uses gtk3. All I noticed is that videos didn't work until I put libs into /usr/lib64/apulse in lxpup64, & I had no video issue with xenialpup64 & bionicpup64, which both have their pulse libs in /usr/lib/apulse. And to confuse things further, slacko64 doesn't have pulse libs & videos play. All with the same Seamonkey setup. Peebee had the same issue with the same videos, but not in Chromium. I don't understand - it's not logical, but I'll have to make do with the workaround for now.
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 286
Location: Germany

PostPosted: Sat 10 Nov 2018, 07:24    Post subject:  

@ozsouth
for clarification, we are talking about 64 bit version of SM, right ?

did a short test in Slacko64 700RC3 and SM 2.49.4 (64bit) from official Website
build configuration shows:

Quote:
Build platform
target
x86_64-pc-linux-gnu

Configure options
MOZ_AUTOMATION=1 --with-external-source-dir=/builds/slave/rel-c-esr-lnx64-bld/build --enable-application=suite --enable-update-channel=release PKG_CONFIG=/builds/slave/rel-c-esr-lnx64-bld/build/gtk3/usr/local/bin/pkg-config --with-ccache=/usr/bin/ccache CC=/builds/slave/rel-c-esr-lnx64-bld/build/gcc/bin/gcc CXX=/builds/slave/rel-c-esr-lnx64-bld/build/gcc/bin/g++ --enable-rust RUSTC=/builds/slave/rel-c-esr-lnx64-bld/build/rustc/bin/rustc CARGO=/builds/slave/rel-c-esr-lnx64-bld/build/cargo/bin/cargo --enable-js-shell --enable-default-toolkit=cairo-gtk3 --with-google-api-keyfile=/builds/google-api.key MAKE=make --enable-alsa --enable-crashreporter --enable-elf-hack --enable-release --enable-stdcxx-compat


this means:
gtk3 is needed
installation of alsa is sufficient for audio playback
internal libvpx is used

real 64 bit OS doesn't search for libs in /usr/lib they expect libs in /usr/lib64

if you are install apulse and the libs are going to /usr/lib Slacko will not find them
Ubuntu basing distros have a symbolic link from /usr/lib64 to /usr/lib
that's why they are working nevertheless if the needed libs are located in /usr/lib
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3534
Location: Worcestershire, UK

PostPosted: Sat 10 Nov 2018, 09:50    Post subject:  

Interim delta to 18.06+12-uefi

iso md5 = 1f9d9df6fc0718fcd78cdb7176615c6d lxpupsc64-18.06+12-uefi.iso

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 20 of 20 [296 Posts]   Goto page: Previous 1, 2, 3, ..., 18, 19, 20
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1589s ][ Queries: 13 (0.0808s) ][ GZIP on ]