Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 18 Nov 2018, 09:13
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to use Simplecom NW601 Wireless USB? (Solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [28 Posts]   Goto page: Previous 1, 2
Author Message
Semme


Joined: 07 Aug 2011
Posts: 7852
Location: World_Hub

PostPosted: Sun 28 Oct 2018, 07:51    Post subject:  

He has the 4.1.48 kernel.

https://wikidevi.com/wiki/Realtek_RTL8812BU_USB_Module

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1049
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Sun 28 Oct 2018, 08:22    Post subject:  

Here is some interesting stuff
https://github.com/Grawp/rtl8812au_rtl8821au

references to working with 0bda:a811
got that from here

https://www.linuxquestions.org/questions/linux-networking-3/ourlink-ac600-wireless-usb-adapter-not-working-on-newly-installed-ubuntu-gnome-16-10-a-4175597852/



.

_________________
Giving with an expectation for return brings misery.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1049
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Sun 28 Oct 2018, 09:00    Post subject:  

Ok one more try.

This pet/driver compiled from github sources listed in the previous post.
It is for Dpup Stretch 4.1.48
Tested and working

rtl8812au_rtl8821au-4.3.20_k4.1.48.pet

I did not include the firmware in the pet

Thanks for testing cthisbear!

.

Last edited by perdido on Sat 10 Nov 2018, 11:57; edited 4 times in total
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1049
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Sun 28 Oct 2018, 12:25    Post subject:  

And another driver to try, compiled from source at https://github.com/zebulon2/rtl8812au
It is for Dpup Stretch 4.1.48
Tested and working

rtl8812au-5.1.5_k4.1.48.pet

I did not include the firmware in the pet

Thanks to Semme for pointing me to these sources.Smile
Thanks for testing cthisbear!

.

Last edited by perdido on Sat 10 Nov 2018, 11:56; edited 2 times in total
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4349
Location: Sydney Australia

PostPosted: Sun 28 Oct 2018, 15:56    Post subject:  

Thanks everyone again.

I am in the Devil's OS at the moment, although these days is that
Windows or Android???

I wll report back soon.
And I will test perdido's treats.

Simplecom is treating me like a Simpleton, but you all suspected as much.

Semme... I saw your messages after I posted here...thanks.

Thanks again.....Chris.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4349
Location: Sydney Australia

PostPosted: Sun 28 Oct 2018, 17:08    Post subject:  

This works after reboot
I might try and copy the System files and redo an ISO

rtl8812au_rtl8821au-4.3.20_k4.1.48.pet

Then I will test some of your others after booting another Puppy
and deleting the Save File first.

I tried to cheat and do xorg but that didn't work.
I will mark as solved later.

Got a busy day.

Cheers ....Chris
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1049
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Sun 28 Oct 2018, 17:48    Post subject:  

Thanks for the good news Very Happy
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4349
Location: Sydney Australia

PostPosted: Sun 28 Oct 2018, 18:18    Post subject:  

I copied the firmware.

This was in Firmware ...>>> rtl_bt

Probably all I need to stick in my ISO?????

I'll be a good few hours till I get back.

Chris.
rtl_bt.zip
Description  Realtek 4 Simplecom
zip

 Download 
Filename  rtl_bt.zip 
Filesize  186.87 KB 
Downloaded  20 Time(s) 
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4349
Location: Sydney Australia

PostPosted: Mon 29 Oct 2018, 05:29    Post subject:  

After 5 hours of lawn mowing...so PleB...
and a rest afterwards...I'm back.

Yet Ze cheers aren't forthcoming.

I have booted quite a few times trying to cheat it with other methods.
And with other references in this thread.

::::::::

And Solved twice.

perdido

" And another driver to try, compiled from source at

https://github.com/zebulon2/rtl8812au

It is for Dpup Stretch 4.1.48

rtl8812au-5.1.5_k4.1.48.pet

" Thanks to Semme for pointing me to the sources.:) "

:::::

which also works on reboot...and posting now with it.

It shows as >> wlan0 Wireless8812au
usb:Realtek Wireless Lan Driver

I suppose an SFS I could just add on with no reboot might be even better.

Anyway I will check with Radky if he could include this driver.

Thanks to all who have helped me here.

Chris.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1049
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Mon 29 Oct 2018, 08:18    Post subject:  

In both solutions for the Simplecom NW601 the driver has the same name after being compiled. (8812au.ko)

So cannot have both at the same time.

The rtl8812au-5.1.5_k4.1.48.pet driver has more recent upgrades and is also slightly smaller in size.

No way of determining which one is "better"

I like old stuff better since old is usually repairable and not made of plastic <grin>

.

_________________
Giving with an expectation for return brings misery.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4349
Location: Sydney Australia

PostPosted: Mon 29 Oct 2018, 18:37    Post subject:  

" So cannot have both at the same time. "

Now you tell me...no wonder I am Simple after dealing
with this crap....ha! ha!

No all is good mate.
I booted pristine Stretch pups and installed only one pet
and rebooted and voila your pet did the job.

Booted another Puppy, removed the Save file,
rebooted the pristine Stretch again and tried the second pet,
and more goodness again.

You were kind enough to help, so I should test it twice >> right?
I did try looking at Gyros firmware and tried a few but maybe I took the
wrong approach and didn't do it correctly.

I tried what I thought was the saved extras in firmware and copied
them in a pristine Stretch...again...restarted in Xorg to see if I could cheat it.

I prefer for banking to boot a pristine Puppy,
add my stored bookmarks, and usually Slimjet
and off I go.

Anyway it has forced me to try other new Pups, but none of them have
Simplecom, including UPup Bionic Beaver, Bionicpup64, and
32-bit UPup Cosmic Cuttlefish.

I have just downloaded X Slacko Slim now, see how it goes.

So as stated to all...many thanks.
I'll be sad to leve TPG, a great company and reps if you know how to play it.

But I didn't want to connect to Vodaphone and be charged until I
could connect in Puppy on these new Nano dongles.

Chris.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1049
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Tue 30 Oct 2018, 23:23    Post subject:  

One more, this one for Upup Bionic Beaver 32-bit with kernel 4.9.96

rtl8812au_rtl8821au-4.3.20_k4.9.96.pet

Compiled from the same sources as other working drivers.

Tested and working in upup bionic beaver with kernel 4.9.96
Does not include the firmware, see earlier post in this thread for that.
---------------
edit: fixed 11-01-18 10:22AM thanks for testing cthisbear!

.

Last edited by perdido on Sat 10 Nov 2018, 11:43; edited 4 times in total
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4349
Location: Sydney Australia

PostPosted: Wed 31 Oct 2018, 00:16    Post subject:  

" One more, this one for Upup Bionic Beaver 32-bit with kernel 4.9.96 "


perdido is haunting me around the forum today.

Thanks mate I will test it soon, but not today.

Things to do, but many thanks.

Although I just downloaded it.

Chris.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [28 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0554s ][ Queries: 13 (0.0059s) ][ GZIP on ]