Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 13 Nov 2018, 17:13
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Samba shares & USB disk automount <SOLVED>
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
dcung

Joined: 13 Jul 2018
Posts: 229
Location: Down Under - 3rd rock from Sun.

PostPosted: Sat 18 Aug 2018, 21:50    Post subject:  Samba shares & USB disk automount <SOLVED>  

Hi,

I searched and went thru these old threads, but have not found a solution yet. Some .pet can't install in my Fatdog64_721. Some links to script/software are dead.
http://www.murga-linux.com/puppy/viewtopic.php?t=50845
http://www.murga-linux.com/puppy/viewtopic.php?t=78321
http://www.murga-linux.com/puppy/viewtopic.php?t=45815&start=165

In short, I'm looking to automount my USB disks (NTFS).

Pls excuse the long story - try to be as short as possible.
I have samba shares (root full access) that can't be accessed (from Windows 10) before disks were mounted.
So, I thought, this should be simple enough.
I just put a script in Startup, two lines of mount commands would do..

Code:
#!/bin/sh
mount /dev/sdb1 /mnt/sdb1
mount /dev/sdc1 /mnt/sdc1


I was happy to see the disks icons got the green lit up,
But upon accessing the shares, found that I can do most of the stuff (even delete) except writing (new file) to the shares, but it was flaky/weird/inconsistent too.

If I mount the disks by clicking the icons, no such problem.
So, I investigated and found the difference, the type

Code:
/dev/sdb1 on /mnt/sdb1 type ntfs (rw,relatime,uid=0,gid=0,fmask=0177,dmask=077,nls=iso8859-1,errors=continue,mft_zone_multiplier=1)
/dev/sdc1 on /mnt/sdc1 type ntfs (ro,relatime,uid=0,gid=0,fmask=0177,dmask=077,nls=iso8859-1,errors=continue,mft_zone_multiplier=1)

<By CLICKING>
/dev/sdb1 on /mnt/sdb1 type fuseblk (rw,relatime,user_id=0,group_id=0,default_permissions,blksize=4096)
/dev/sdc1 on /mnt/sdc1 type fuseblk (rw,relatime,user_id=0,group_id=0,default_permissions,blksize=4096)


So, I thought, okay, modify the script
Code:
#!/bin/sh
mount -t fuseblk /dev/sdb1 /mnt/sdb1
mount -t fuseblk /dev/sdc1 /mnt/sdc1

Well, it's not happy with the option,... Embarassed

And I thought, this tinkering since yesterday is not fruitful...
Back to looking for help automount from forum...while tinkering...
samba2.png
 Description   
 Filesize   11.45 KB
 Viewed   81 Time(s)

samba2.png

samba1.png
 Description   
 Filesize   4.83 KB
 Viewed   82 Time(s)

samba1.png

samba3.png
 Description   
 Filesize   140.92 KB
 Viewed   83 Time(s)

samba3.png


Last edited by dcung on Sun 19 Aug 2018, 16:55; edited 1 time in total
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1095

PostPosted: Sun 19 Aug 2018, 06:33    Post subject:  

If you want to mount a local disk the way clicking its desktop icon does try using
/usr/sbin/fatdog-drive-icon-mount-helper.sh /dev/sdb1 /mnt/sdb1

This command is exactly what's invoked when you click the drive icon. This script is a front-end to mount. You can unmount with the regular umount command (or click the desktop icon green square).

OOTB, is samba server configured to export shares as user root with _write_ permissions? I can't remember.

_________________
Fatdog64-721|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
dcung

Joined: 13 Jul 2018
Posts: 229
Location: Down Under - 3rd rock from Sun.

PostPosted: Sun 19 Aug 2018, 16:55    Post subject:  

step wrote:
/usr/sbin/fatdog-drive-icon-mount-helper.sh /dev/sdb1 /mnt/sdb1

Exactly what I was looking for. This did the trick!


step wrote:
OOTB, is samba server configured to export shares as user root with _write_ permissions? I can't remember.


Not sure what you meant, but all I had to do was to put these lines in smb.conf and start samba service.
Code:
[RW-Data]
path = /mnt/sdb1/RW-Data
writable = yes
read only = no
force user = root
guest ok = yes
guest only = yes


OOTB you can only access spot's download dir.

Thank you, step!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0525s ][ Queries: 13 (0.0179s) ][ GZIP on ]